Risultati da 1 a 8 di 8

Discussione: trovare data più recente



  1. #1
    L'avatar di RICCARDO_75
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Vicenza
    Età
    42
    Messaggi
    14
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    11

    trovare data più recente

    Ciao
    nella colonna "A" ho una serie di articoli (alcuni si ripetono) e nella colonna "B" ho una serie di date, se possibile vorrei trovare il modo per avere nella colonna"C" la data più recente per ogni articolo.

    spero sia chiara la mia domanda, sono alle prime armi con excel :292:
    grazie
    ciao
    Ultima modifica fatta da:Canapone; 14/03/17 alle 12:35

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1689
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185

    Re: trovare data più recente

    la domanda è chiara, un esempio su un file di esempio sarebbe stato gradito , comunque:
    =MIN(SE($A$1:$A$10=A1;$B$1:$B$10))
    matriciale

    oppure
    =AGGREGA(15;6;$B$1:$B$10/($A$1:$A$10=A1);1)
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. I seguenti 2 utenti hanno dato un "Like" a ninai per questo post:


  4. #3
    L'avatar di RICCARDO_75
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Vicenza
    Età
    42
    Messaggi
    14
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    11

    Re: trovare data più recente

    Ciao
    scusate se non avevo allegato esempio.
    nelle prime tre righe ho l'articolo SP1001 che si ripete con date diverse, io vorrei trovare la più recente, idem per le altre righe.
    Nella colonna "C" vorrei vedere solo la data più recente per ogni articolo (colonna A)
    File Allegati File Allegati

  5. #4

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4028
    Versione Office
    2013
    Likes ricevuti
    1232
    Likes dati
    925

    Re: trovare data più recente

    Ciao a tutti,

    @RICCARDO
    hai provato le formule proposte da ninai?

    In base al tuo file, nella cella A2 devi mettere questa formula matriciale (quindi da confermare con CTRL+MAIUSC+INVIO) e copiare in basso:

    =MIN(SE($A$2:$A$1617=A2;$B$2:$B$1617))

    oppure (NON matriciale):

    =AGGREGA(15;6;$B$2:$B$1617/($A$2:$A$1617=A2);1)

    Se vuoi dei risultati differenti (tipo: in colonna C l'articolo e in colonna D la data più recente) spiegati meglio, o ancora meglio, nel file allegato inserisci manualmente il risultato che vorresti ottenere.

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  6. I seguenti utenti hanno dato un "Like"


  7. #5
    L'avatar di RICCARDO_75
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Vicenza
    Età
    42
    Messaggi
    14
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    11

    Re: trovare data più recente

    Scusami
    forse non mi spiego bene..ho riportato un esempio...

    grazie
    File Allegati File Allegati

  8. #6

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4028
    Versione Office
    2013
    Likes ricevuti
    1232
    Likes dati
    925

    Re: trovare data più recente

    Nella cella C2, questa formula matriciale :
    =SE(CONTA.SE($A$1:A2;A2)=1;MAX(SE($A$2:$A$1617=A2;$B$2:$B$1617));"")

    e dopo copi in basso.

    Ti riallego il file... la formula l'ho messa nella colonna a fianco (dalla D2 e dopo copiata in basso).


    [EDIT]
    Citazione Originariamente Scritto da Canapone
    Ciao Cromagno: scusa la sovrapposizione...
    Ciao,
    più siamo meglio è... :246:
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  9. #7
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204

    Re: trovare data più recente

    Ciao a tutti,

    e' una formula equivalente a chi mi ha preceduto

    Prova in C2:

    =SE(CONTA.SE(A$2:A2;A2)=1;AGGREGA(14;6;B$1:B$2000/(A$1:A$2000=A2);1);"")

    e copia la formula in basso.

    Saluti

    -----------

    Ciao Cromagno: scusa la sovrapposizione...

  10. I seguenti 2 utenti hanno dato un "Like" a Canapone per questo post:


  11. #8
    L'avatar di RICCARDO_75
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Vicenza
    Età
    42
    Messaggi
    14
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    11

    Re: trovare data più recente

    Grazie...gentilissimo :255:
    ciao

Discussioni Simili

  1. Trovare chi è senza data di nascita
    Di RUGANT54 nel forum Domande su Excel in generale
    Risposte: 14
    Ultimo Messaggio: 12/03/17, 08:12
  2. [Risolto] Filtrare per data più recente a parità di valore
    Di fulviogsx nel forum Domande su Excel in generale
    Risposte: 20
    Ultimo Messaggio: 10/01/17, 16:22
  3. [Risolto] Exel 2013 Trovare Valori doppi solo in successione in ordine di data
    Di ginofamilio nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 15/11/16, 00:56
  4. Funzione per trovare una data compresa in un intervallo
    Di ProgrammD69 nel forum Domande su Excel in generale
    Risposte: 14
    Ultimo Messaggio: 07/07/16, 15:10
  5. Riferimento al video EM 57 estrazione dati con data più recente
    Di nino1 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 13/09/15, 16:32

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •