Risultati da 1 a 10 di 10

Discussione: celle precedenti con colonna fissa e riga variabile



  1. #1
    L'avatar di mpaolett
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    roma
    Età
    32
    Messaggi
    23
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    7

    celle precedenti con colonna fissa e riga variabile

    Salve, sono nuovo e mi scuso se non scrivo bene la richiesta.
    Allora quello che mi servirebbe e riportare i risultati di molte tabelle in un foglio "riepilogo". Ora dato che devo riportare 3 risultati per ogni tabella e le tabelle distano esattamente tra di loto tot righe, è possibile fare una formula di riferimento con colonna bloccata e riga incrementale?
    Provo a fare un esempio
    In una cell scrivo ='Foglio'1!$A1
    La cella sotto invece deve darmi ='Foglio1'$A21
    la terza cella in ='Foglio1'$A41 etc

    l'incremento di 20 righe è solo d'esempio

    Grazie

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202

    Re: celle precedenti con colonna fissa e riga variabile

    Ciao,

    un modo potrebbe essere

    =INDICE(A$1:A$1000;1+(RIGHE($1:1)*20-20))


    oppure

    =INDICE(A$1:A$1000;RIGHE($1:1)*20-19)

    da copiare in basso.

    Anche

    =INDIRETTO("A"&RIGHE($1:1)*20-19)

    ma useresti una funzione volatile (rimando a Google per approfondimenti)


    Spero sia d'aiuto

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di mpaolett
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    roma
    Età
    32
    Messaggi
    23
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    7

    Re: celle precedenti con colonna fissa e riga variabile

    Guarda, forse è meglio se ti allego il file.
    Nel foglio 'RIEPILOGO CARICHI' vedrai delle tabelle, io le ho compilate a mano e sono tutte con riferimento incrementale, ma dato che saranno molte volevo capire bene la formula.
    File Allegati File Allegati

  5. #4
    L'avatar di mpaolett
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    roma
    Età
    32
    Messaggi
    23
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    7

    Re: celle precedenti con colonna fissa e riga variabile

    Citazione Originariamente Scritto da Canapone Visualizza Messaggio
    Ciao,

    un modo potrebbe essere

    =INDICE(A$1:A$1000;1+(RIGHE($1:1)*20-20))


    oppure

    =INDICE(A$1:A$1000;RIGHE($1:1)*20-19)

    da copiare in basso.

    Anche

    =INDIRETTO("A"&RIGHE($1:1)*20-19)

    ma useresti una funzione volatile (rimando a Google per approfondimenti)


    Spero sia d'aiuto
    Ho sbagliato nel dirti che il valore deve essere nella riga sotto, invece deve stare a due colonne di distanza. Con riferimento all'allegato scrivendo =INDICE('PESO PORTATO TRAVI'!$D$15:'PESO PORTATO TRAVI'!$D$1000;RIGHE($14:14)*20-19) e copiandolo per le righe sotto mi rida tutti i valore che appunto volevo (quelli a distanza di 20 righe). Non capisco però che devo modificare se non voglio copiarlo sotto, ma a due colonne a destra, sulla stessa riga?
    Quando la distanza è diversa (distanza n righe) che devo inserire come ultimo valore? *n-(n-1)?

    Grazie

  6. #5
    L'avatar di mpaolett
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    roma
    Età
    32
    Messaggi
    23
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    7

    Re: celle precedenti con colonna fissa e riga variabile

    Ho riordinato le tabelle, penso che ora sia più semplice....
    quello di cui ho bisogno è:
    in A1 ='Foglio1'!$D$14
    in B1 ='Foglio1'!$D$34
    in C1 ='Foglio1'!$D$54
    etc

    poi in
    in A15 ='Foglio1'!$D$50
    in B15 ='Foglio1'!$D$75
    in C15 ='Foglio1'!$D$100
    etc

    Come posso fare?

  7. #6

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923

    Re: celle precedenti con colonna fissa e riga variabile

    Citazione Originariamente Scritto da mpaolett Visualizza Messaggio
    Ho riordinato le tabelle, penso che ora sia più semplice....
    quello di cui ho bisogno è:
    in A1 ='Foglio1'!$D$14
    in B1 ='Foglio1'!$D$34
    in C1 ='Foglio1'!$D$54
    etc

    poi in
    in A15 ='Foglio1'!$D$50
    in B15 ='Foglio1'!$D$75
    in C15 ='Foglio1'!$D$100
    etc

    Come posso fare?
    Ciao a tutti,

    @mpaolett
    hai scritto che hai riordinato le tabelle ma noi abbiamo ancora il tuo primo file allegato e non ho capito dove vuoi le formule e soprattutto che dati dovrei prendere.

    Riallega il tuo "nuovo file" facendo un esempio pratico (e inserendo manualmente il risultato che vorresti ottenere) altrimenti si continuerà ad andare a tentativi...

    Ciao
    Tore

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  8. #7
    L'avatar di mpaolett
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    roma
    Età
    32
    Messaggi
    23
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    7

    Re: celle precedenti con colonna fissa e riga variabile

    Ecco il file, è nel foglio "RIEPILOGO PESO TRAVI" che ho il problema ed ho inserito le istruzioni su quello che mi servirebbe.

    Grazie

    Marco
    File Allegati File Allegati

  9. #8
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202

    Re: celle precedenti con colonna fissa e riga variabile

    Ciao a tutti,

    nell'allegato sto usando un altro sistema per pescare i dati.

    Ho evidenziato le formule da copiare in basso ed a destra in azzurro, ma ogni formula azzurra doveva essere aggiustata per farle capire da dove partire.

    Sto usando degli INDICE

    =INDICE('PESO PORTATO TRAVI'!$D$1:$D$1000;AGGREGA(15;6;RIF.RIGA($1:$1000)/('PESO PORTATO TRAVI'!$A$1:$A$1000=$C6);RIF.COLONNA(A$1)))


    Non credo sia questo che stai cercando, ma ho fatto molta fatica ad orientarmi nel file : forse è d'aiuto per qualche amico del Forum.
    File Allegati File Allegati

  10. I seguenti 4 utenti hanno dato un "Like" a Canapone per questo post:


  11. #9
    L'avatar di mpaolett
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    roma
    Età
    32
    Messaggi
    23
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    7

    Re: celle precedenti con colonna fissa e riga variabile

    Credo di aver capito, invece di ripescarle a una distanza precisa, cosi le ripesca se trova nell'altro foglio lo stesso nome di riferimento. Per quanto riguarda il riferimento della riga lo aggiusto ogni volta, ma così è molto più facile.
    Grazie davvero, ora provo cosi e continuo a compilare le tabelle. Mentre per i nomi delle colonne? (cioè il nome dell'elemento T1-2,T2-3, etc)
    PS c'è un errore nella tabella da riga 42 a 48, quella non la considerare.


    Ottimo lavoro :255:

  12. #10
    L'avatar di mpaolett
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    roma
    Età
    32
    Messaggi
    23
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    7

    Re: celle precedenti con colonna fissa e riga variabile

    Ecco allego il file modificato con la formula che mi hai dato, funziona alla grande!
    Ho solo un problema con 2 tabelle che non mi riportano i valori giusti, e con i titoli.
    Ti ho scritto tutto nel file. Come sempre il foglio che mi interessa è il "RIEPILOGO PESO TRAVI".
    :286:
    Grazie come sempre
    File Allegati File Allegati

Discussioni Simili

  1. Risposte: 8
    Ultimo Messaggio: 10/03/17, 21:48
  2. Risposte: 19
    Ultimo Messaggio: 21/11/16, 16:32
  3. Cambiare colore a riga/colonna di celle se una cella uguale ad un testo
    Di Cavier80 nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 22/05/16, 13:23
  4. Risposte: 2
    Ultimo Messaggio: 02/02/16, 15:54
  5. Macro: variabile per selezione riga
    Di Luigi Traversetti nel forum Domande su Excel VBA e MACRO
    Risposte: 3
    Ultimo Messaggio: 21/10/15, 23:25

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •