Risultati da 1 a 4 di 4

Discussione: Formula di Excel per conteggio univoco



  1. #1
    L'avatar di Sofia
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Tortona
    Età
    31
    Messaggi
    1
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0

    Formula di Excel per conteggio univoco

    Buonasera,
    vorrei porre una domanda su una formula che vorrei utilizzare per fare un calcolo di excel:
    Supponiamo che io abbia questi valori e mi serva sapere se in corrispondenza delle celle in cui c'è lo stesso nome c'è anche anche lo stesso n° nelle celle sulla stessa riga. In pratica se ci sono dei doppioni nei numeri in funzione dei nomi.
    Per esempio, in questo caso il risultato sarebbe positivo per il nome "mario" (2 volte "2" in corrispondenza dello stesso nome) e anche per il nome "luca" ma non per il nome "gianni"
    Esiste una formula per calcolare questo dato?
    Grazie a tutti per l'aiuto :171:

    mario 2
    mario 2
    mario 5
    gianni 6
    gianni 8
    luca 4
    luca 4
    Ultima modifica fatta da:Canapone; 19/05/16 alle 08:01 Motivo: Titolo non descrittivo del problema

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Domanda formula di excel

    Ciao Sofia!
    benvenuta in forumexcel.it

    In D1 dovresti mettere questa formula matriciale che però ha bisogno di essere attivata con tasti di scelta rapida
    CTRL+SHIFT+ENTER



    copiala e trascila in basso

    =SE.ERRORE(INDICE($A$1:$A$7&" "&$B$1:$B$7;PICCOLO(SE(FREQUENZA(CONFRONTA($A$1:$A$7&$B$1:$B$7;$A$1:$A$7&$B$1:$B$7;0);RIF.RIGA($A$1:$A$7)-RIF.RIGA($A$1)+1)>1;RIF.RIGA($A$1:$A$7)-RIF.RIGA($A$1)+1);RIGHE($D$1:D1)));"")

    Sono sicuro che ci sono altre soluzioni ma a me è venuta cosi
    Un saluto a tutti gli amici del forum

  3. I seguenti utenti hanno dato un "Like"


  4. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7165
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1304

    Re: Domanda formula di excel

    Ciao a tutti,
    alternativa alla formula di Gerardo, che saluto, se ho ben capito:

    =A1&" "&MATR.SOMMA.PRODOTTO(($A$1:$A$7&$B$1:$B$7=A1&B1)*1)

    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  5. I seguenti 2 utenti hanno dato un "Like" a ges per questo post:


  6. #4
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    782
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    319
    Likes dati
    1

    Re: Domanda formula di excel


    Buona Sera


    A
    B
    C
    1
    mario
    2
    2
    mario
    2
    duplicato
    3
    mario
    5
    4
    gianni
    6
    5
    gianni
    8
    6
    luca
    4
    7
    luca
    4
    duplicato


    c1=SE(CONTA.PIÙ.SE($A$1:A1;A1;$B$1:B1;B1)>1;"duplicato";"") copia in basso

    Saluti
    Window 8.1 Excel 2013/2016

  7. I seguenti 3 utenti hanno dato un "Like" a Pitagora per questo post:


Discussioni Simili

  1. Elenco univoco ordinato alfabeticamente con condizione
    Di ninazen nel forum Domande su Excel in generale
    Risposte: 26
    Ultimo Messaggio: 13/02/17, 08:32
  2. Conteggio parziale
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 26/03/16, 07:29
  3. Conteggio Km
    Di claudiopsr nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 10/01/16, 17:56
  4. Univoco
    Di scravx nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 13/12/15, 22:06
  5. Come tradurre una formula di Excel attraverso "Excel Traslator"
    Di Gerardo Zuccalà nel forum Link Utili
    Risposte: 0
    Ultimo Messaggio: 29/10/15, 19:21

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •