Risultati da 1 a 7 di 7

Discussione: Spiegazione formula



  1. #1
    L'avatar di lala10
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    N/D
    Messaggi
    68
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    16

    Spiegazione formula

    Ciao a tutti ho bisogno del vostro aiuto per capire bene il significato di questa formula:

    =SE.ERRORE(INDICE('Foglio (1)'!B$2:B$3000;AGGREGA(15;6;(RIF.RIGA('Foglio (1)'!$F$2:$F$3000)-RIF.RIGA('Foglio (1)'!$B$2)+1)/(('Foglio (1)'!$F$2:$F$3000<>""));RIGHE('Foglio (1)'!F$2:F2)));"")

    Ringrazio tutti per il futuro aiuto,
    saluti

  2. #2

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2808
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: Spiegazione formula

    Ti elenca tutti i valori nella colonna B (B2:B3000) che abbiano i valori nella colonna F diversi da zero cioè tutte le celle "piene"

  3. I seguenti 2 utenti hanno dato un "Like" a Rubik72 per questo post:


  4. #3
    L'avatar di lala10
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    N/D
    Messaggi
    68
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    16

    Re: Spiegazione formula

    Grazie mille per la risposta ma avrei bisogno di entrare più nel dettaglio per capire bene come si utilizzano quelle funzioni :)

  5. #4

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2808
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: Spiegazione formula

    Prova queste lezioni del grande GERARDO:






  6. I seguenti utenti hanno dato un "Like"


  7. #5
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1659
    Versione Office
    2010 PC
    Likes ricevuti
    891
    Likes dati
    184

    Re: Spiegazione formula

    ciao
    a parte il video di Gerardo, ben fatto e sicuramente esaustivo per i tuoi scopi, ti voglio indurre in alcune constatazioni sulla formula:

    =SE.ERRORE(INDICE('Foglio (1)'!B$2:B$3000;AGGREGA(15;6;(RIF.RIGA('Foglio (1)'!$F$2:$F$3000)-RIF.RIGA('Foglio (1)'!$B$2)+1)/(('Foglio (1)'!$F$2:$F$3000<>""));RIGHE('Foglio (1)'!F$2:F2)));"")

    cominciamo a togliere
    'Foglio (1)'! che riguarda il caso in cui le celle risiedono in un foglio diverso da quello della formula, rimane
    =SE.ERRORE(INDICE(B$2:B$3000;AGGREGA(15;6;(RIF.RIGA($F$2:$F$3000)-RIF.RIGA($B$2)+1)/(($F$2:$F$3000<>""));RIGHE(F$2:F2)));"")

    togliamo il SE.ERRORE(.........;"")
    che serve a restituire cella vuota (""), qualora il rrisultato sia un tipo di errore, rimane:

    =INDICE(B$2:B$3000;AGGREGA(15;6;(RIF.RIGA($F$2:$F$3000)-RIF.RIGA($B$2)+1)/(($F$2:$F$3000<>""));RIGHE(F$2:F2)))
    a questo punto rimane:

    INDICE(B$2:B$3000; ........) , il range da dove estrarre i vari valori

    AGGREGA(15;6;(RIF.RIGA($F$2:$F$3000)-RIF.RIGA($B$2)+1)/(($F$2:$F$3000<>""));RIGHE(F$2:F2))
    il numero di riga dell'INDICE che via via identifica le celle non vuote da estrarre.

    con la funzione AGGREGA, in questo caso, sostituisce la vecchia procedura PICCOLO(SE(..........) ,con invio matriciale , infatti:
    15: sta per la funzione PICCOLO
    6: sta per ignorare eventuali errori (che provocheremo noi con un diviso zero))

    (RIF.RIGA($F$2:$F$3000)-RIF.RIGA($B$2)+1) (le parentesi esterne sono superflue)
    è un modo per creare una progressione che parta da 1: 1,2,3,4,5,6,7, ecc.

    /(($F$2:$F$3000<>"")) (le parentesi esterne sono superflue)
    con questa parte otteniamo: /1 se vero oppure, /0 se falso
    un operazione diviso zero è un errore e pertanto tale valore del range viene ignorato (non estratto)

    RIGHE(F$2:F2)

    è il K del piccolo che si incrementa man mano che trascinerai la formula in basso (1°, 2°, 3°)
    e che darà tramite INDICE il primo, secondo,terzo ecc. valore che soddisfa al criterio (diverso da vuoto)

    ovviamente ci si può sbizzarrire con i criteri, sia in tipo che in quantità (basta moltiplicare o addizionare più condizioni, secondo le logiche boleane).

    Spero che questa mia (non chiara) esposizione ti dia altri spunti di riflessione su tale tipo di formula
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  8. I seguenti 3 utenti hanno dato un "Like" a ninai per questo post:


  9. #6
    L'avatar di lala10
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    N/D
    Messaggi
    68
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    16

    Re: Spiegazione formula

    ok le guardo subito grazie mille :)

  10. #7
    L'avatar di lala10
    Clicca e Apri
    Data Registrazione
    Apr 2016
    Località
    N/D
    Messaggi
    68
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    16

    Re: Spiegazione formula

    Ciao Ninai, non so davvero come ringraziartiii!
    Sei stato molto preciso ed esaustivo complimenti, come sempre il forum è di grande aiuto :)

Discussioni Simili

  1. spiegazione formula
    Di D@nilo nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 07/08/16, 12:56
  2. cambiare formula o aggiungere formula in più celle ed in pagine diverse
    Di prof84 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 11/07/16, 20:34

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •