Risultati da 1 a 8 di 8

Discussione: Analizzare database



  1. #1
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Smile Analizzare database

    Ciao a tutti
    Visto il grand caldo (Milano +39°) mi sto facendo una lampada davanti al monitor
    come potete vedere sulla sinistra ho un data base di soli due campi e io vorrei una formula in E2 da copiare in baso che mi vede il criterio che è nella colonna D

    buon divertimento
    A
    B
    C
    D
    E
    1
    date totale criterio grantotale
    2
    21/01/2015
    7
    gennaio
    13
    3
    31/01/2015
    6
    febbraio
    12
    4
    10/02/2015
    3
    marzo
    11
    5
    20/02/2015
    9
    6
    02/03/2015
    3
    7
    12/03/2015
    3
    8
    22/03/2015
    5
    9
    01/04/2015
    2
    10
    11/04/2015
    8
    11
    21/04/2015
    7
    12
    01/05/2015
    7
    13
    11/05/2015
    3
    14
    21/05/2015
    8
    15
    31/05/2015
    4
    16
    10/06/2015
    3
    17
    20/06/2015
    3
    18
    30/06/2015
    6


    PS prego Gurus astenersi! :)
    Ultima modifica fatta da:Gerardo Zuccalà; 21/07/15 alle 19:29

  2. #2
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    779
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1
    Buona Sera

    =SOMMA(SE(TESTO($A$4:$A$20;"mmmm")=D4;$B$4:$B$20)) premere CTRL+MAIUSC+INVIO.

    edit

    =MATR.SOMMA.PRODOTTO(--((TESTO(A4:A20;"mmmm")=D4));(B4:B20))



    Saluti
    Ultima modifica fatta da:Pitagora; 21/07/15 alle 20:53
    Window 8.1 Excel 2013/2016

  3. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da Pitagora Visualizza Messaggio
    Buona Sera

    =SOMMA(SE(TESTO($A$4:$A$20;"mmmm")=D4;$B$4:$B$20)) premere CTRL+MAIUSC+INVIO.

    Saluti
    Ottimo!!
    Però attenzione ci sono altre soluzioni e una potrebbe essere senza CTRL+MAIUSC+INVIO.

    vediamo se qualcun altro ha delle idee!!!

  4. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299
    Perchè questa non mi funziona?

    =SOMMA.SE(TESTO($G$2:$G$8;"mmmm");D2;$B$2:$B$18)

  5. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Perchè questa non mi funziona?

    =SOMMA.SE(TESTO($G$2:$G$8;"mmmm");D2;$B$2:$B$18)
    @ ges
    Pitagora ha scritto SOMMA(SE e non SOMMA.SE

    =SOMMA(SE
    (TESTO($A$4:$A$20;"mmmm")=D4;$B$4:$B$20))


    @Pitagora ottima soluzione con il MATR.SOMMA.PRODOTTO
    e in attesa che il caldo finisca vi invito anche a voi a fare dei quiz cosi da tenerci tutti allenati

    Ciao

  6. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    @ ges
    Pitagora ha scritto SOMMA(SE e non SOMMA.SE

    =SOMMA(SE
    (TESTO($A$4:$A$20;"mmmm")=D4;$B$4:$B$20))

    ...
    ..o
    Si, Gerardo, ma sono io ad aver pensato alla formula =SOMMA.SE(TESTO($G$2:$G$8;"mmmm");D2;$B$2:$B$18) solo che non me la fa neanche applicare dicendomi che c'è un errore nella stessa .... ma io francamente non lo vedo, cioè mi sembra che la sintassi sia in ordine.
    Qualcuno riesce a spiegarmi perchè?

  7. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Ges
    cerco di spiegartelo in parole povere
    la tua formula con il SOMMA.SE è una formula che lavora direttamente su intervalli e non su matrici, questo vuol dire che i dati che ci sono non si possono trasformare a nostro piacimento, per esempio abbiamo dovuto trasformare le date in formato gg/mm/aaaa in "mmmm" per cui avendo fatto una operazione matematica tra intervalli abbiamo ottenuto una matrice che poi andrà a moltiplicarsi con l'elemento corrispondente il totale e avremo una formula matrice che per farla funzionare dbbiamo fare CTRL+SHIFT+ENTER
    per cui in sintesi il SOMMA.SE lavora solo direttamente su intervalli e il SOMMA(SE lavora sulle matrici
    infatti pitagora nel post nr.2 nella seconda formula ha usato il MATR.SOMMA.PRODOTTO che è anche questa una funzione che lavora su matrici senza pero fare CTRL+SHIFT+ENTER perche questa funzione sopporta le matrici
    spero di essermi spiegato
    Ciao

  8. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299
    Grazie Gerardo della delucidazione

Discussioni Simili

  1. Analizzare Dati
    Di Andrea Mollo nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 15/06/16, 13:16
  2. Cerca.Vert si ferma al primo elemento. Alternativa per analizzare tutti i risultati?
    Di DaylighterSL nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 02/12/15, 19:17
  3. Analizzare database con valuta
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 20/08/15, 15:21
  4. Analizzare DataBase con piu condizioni
    Di Vincenzo Damiani nel forum Domande su Excel in generale
    Risposte: 15
    Ultimo Messaggio: 31/07/15, 08:46
  5. Analizzare DataBase con piu condizioni
    Di Vincenzo Damiani nel forum Test dei vostri post
    Risposte: 0
    Ultimo Messaggio: 29/07/15, 22:26

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •