Risultati da 1 a 7 di 7

Discussione: Estrarre records



  1. #1
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125

    Smile Estrarre records

    Ciao a tutti! :292:
    Sto diventando matto

    Vorrei fare una formula in D2 e copiare in basso che mi vada ad estrarre tutti records che soddisfano i criteri che sono in C2 e C3

    normalmente tutto questo sarebbe facile con un solo criterio, ma qui i criteri sono 2
    Ciaooo!

    A
    B
    C
    D
    1
    data CRITERIO risultato
    2
    blu Bianco Bianco
    3
    bianco Rosso Bianco
    4
    rosso Bianco
    5
    blu Bianco
    6
    bianco rosso
    7
    rosso rosso
    8
    rosso rosso
    9
    bianco
    10
    verde
    11
    bianco

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    È la stessa cosa. Ti suggerisco di usare il segno + per il secondo criteri.

  3. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    È la stessa cosa. Ti suggerisco di usare il segno + per il secondo criteri.
    ho provato con questa che mi sembra piu logica

    =INDICE($A$2:$A$11;PICCOLO(SE(A2:A11=$C$2;SE($A$2:$A$11=$C$3;RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1));RIGHE($D$2:D2)))

    niente

    ma cosa intendi il segno + (più)? INDICE+INDICE?

    =INDICE($A$2:$A$11;PICCOLO(SE($A$2:$A$11=$C$2;RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1);RIGHE($D$2:D2)))+INDICE($A$2:$A$11;PICCOLO(SE($A$2:$A$11=$C$3;RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1);RIGHE($D$2:D2)))

    ma non funziona neanche questa

  4. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    Non riescp a scrivere formule con il telefonino. Intendo usare un solo SE() e nel primo argomento mettere i due criteri con il segno + che equivale ad O(). SE( (($a$2:$a$11=$c$2)+($a$2:$a$11=$c$3));.......

  5. #5
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    Ciao
    adesso che sono rientrato al pc posso analizzare meglio il quesito e rispondere meglio.
    La formula che intendevo prima io era in D2:
    =INDICE($A$2:$A$11;PICCOLO(SE((($A$2:$A$11=$C$2)+($A$2:$A$11=$C$3));RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1);RIGHE($D$2:D2)))
    Ma, in effetti, non da esattamente il risultato che tu hai richiesto (restituisce i due colori nell'ordine nel quale si trovano in A).

    Per ottenere esattamente quello che tu hai riportato:

    in D2:
    =SE.ERRORE(SE(RIGHE($D$2:D2)<=CONTA.SE($A$2:$A$11;$C$2);INDICE($A$2:$A$11;PICCOLO(SE($A$2:$A$11=$C$2;RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1);CONTA.SE($D$1:D1;$C$2)+1));INDICE($A$2:$A$11;PICCOLO(SE($A$2:$A$11=$C$3;RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1);CONTA.SE($D$1:D1;$C$3)+1)));"")

    Ovviamente sono ambedue matriciali e da trascinare in basso

  6. #6
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199
    Ciao a tutti,

    provo a giocare con il conta.se:


    Codice: 
    =SE(CONTA.SE(A$2:A$11;C$2)>=RIF.RIGA(A1);$C$2;SE((CONTA.SE(A$2:$A$11;$C$2)+CONTA.SE(A$2:$A$11;C$3))>=RIF.RIGA(A1);C$3;""))
    Saluti

  7. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Citazione Originariamente Scritto da Canapone Visualizza Messaggio
    Ciao a tutti,

    provo a giocare con il conta.se:


    Codice: 
    =SE(CONTA.SE(A$2:A$11;C$2)>=RIF.RIGA(A1);$C$2;SE((CONTA.SE(A$2:$A$11;$C$2)+CONTA.SE(A$2:$A$11;C$3))>=RIF.RIGA(A1);C$3;""))
    Saluti
    Credo che con quest'ultima chicca di Canapone il quiz sia finito e anche oggi ho imparato qualcosa di nuovo da archiviare nel mio repertorio
    ciao grazie
    Ultima modifica fatta da:Gerardo Zuccalà; 22/07/15 alle 09:13

Discussioni Simili

  1. Eliminazione records duplicati
    Di Master nel forum Domande su Microsoft Access
    Risposte: 7
    Ultimo Messaggio: 09/04/16, 21:46
  2. Trasferire i dati da un data base (campi e records) verso una tabella incrociata
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 21/08/15, 07:35

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •