Risultati da 1 a 5 di 5

Discussione: Sommare dati giornalieri su più mesi ed anni.



  1. #1
    L'avatar di Herardo
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Firenze
    Messaggi
    3
    Versione Office
    excel 2013
    Likes ricevuti
    0
    Likes dati
    0

    Sommare dati giornalieri su più mesi ed anni.

    Salve a tutti, sono un nuovo iscritto del forum, uso excel poco per cui avrei bisogno di un vostro aiuto per calcolare quanta pioggia cade in media nella mia zona, mi serve per valutare se conviene raccoglierla per uso orto/giardino familiare.
    Nel file allegato ho una lunga lista di valori pluviometrici giornalieri su un periodo di molti anni.
    Avrei bisogno di creare una formula (o più) che mi consenta di:
    - sommare tra loro i valori giornalieri di ogni mese dei diversi anni per sapere in media quanti mm di pioggia sono caduti nel mese di gennaio, febbraio, marzo, etc. nel periodo considerato (dall'anno 1916 all'anno 2001);
    - sommare tra loro i valori giornalieri di ogni anno per sapere quanti mm di pioggia sono caduti in ogni anno;
    - fare la media annuale dei mm di pioggia nel periodo indicato.
    Grazie per chi vorrà darmi una mano.
    Buona giornata !
    File Allegati File Allegati
    Ultima modifica fatta da:Canapone; 13/03/17 alle 17:23

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204

    Re: Sommare dati giornalieri su più mesi ed anni.

    Ciao,

    si può fare in molti modi.

    Uso MATR.SOMMA.PRODOTTO

    in E20:E31 scrivi 1,2...12 i mesi

    In F20 media mese negli anni

    =MATR.SOMMA.PRODOTTO(($B$20:$B$21926<>"")*(MESE($A$20:$A$21926)=E20);$B$20:$B$21926)/MATR.SOMMA.PRODOTTO(($B$20:$B$21926<>"")*(MESE($A$20:$A$21926)=E20))

    da copiare accanto ai mesi

    in G20 somma delle precipitazioni per mese

    =MATR.SOMMA.PRODOTTO(($B$20:$B$21926<>"")*(MESE($A$20:$A$21926)=E20);$B$20:$B$21926)


    In I20 scrivi 1916, sotto 1917.... somma rpecipitazioni per anno.


    =MATR.SOMMA.PRODOTTO(($B$20:$B$21926<>"")*(ANNO($A$20:$A$21926)=I20);$B$20:$B$21926)

    da copiare accanto agli anni

    Uso matr.somma.prodotto perchè spero sia intuibile come aggiustare il tiro ai vari calcoli.

    Esempio, riprendo l'ultima formula

    =MATR.SOMMA.PRODOTTO(($B$20:$B$21926<>"")*(ANNO($A$20:$A$21926)=I20);$B$20:$B$21926)

    In I20 trovo 2016, mi interessa sapera i mm caduti a solo marzo 1916

    =MATR.SOMMA.PRODOTTO(($B$20:$B$21926<>"")*(ANNO($A$20:$A$21926)=1916)*(MESE($A$20:$A$21926)=3);$B$20:$B$21926)

    Anche una pivot potrebbe essere d'aiuto.

    Mi spiace non possa ora allegare il file.

    Saluti
    Ultima modifica fatta da:Canapone; 24/05/16 alle 15:47

  3. I seguenti 3 utenti hanno dato un "Like" a Canapone per questo post:


  4. #3
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204

    Re: Sommare dati giornalieri su più mesi ed anni.

    Ciao,

    un modo per tenere sotto controllo visivo (passami il termine) il dato, potrebbe essere la creazione di due colonne di servizio che isolino i mesi e gli anni delle date della colonna A

    esempio

    in E20

    =mese(a20)

    in F20

    =anno(a20)

    copiando le formule ottieni due colonne che potresti far elaborare ad una MEDIA.PIU'.SE o ad un SOMMA.PIU'.SE.


    Esempio:

    =MEDIA.PIÙ.SE($B$20:$B$21926;$D$20:$D$21926;3;$E$20:$E$21926;1916)

    =SOMMA.PIÙ.SE($B$20:$B$21926;$D$20:$D$21926;3;$E$20:$E$21926;1916)

    leggono le nuove colonne di servizio D ed E

    Non so se può servire.

    Saluti

  5. I seguenti 2 utenti hanno dato un "Like" a Canapone per questo post:


  6. #4
    L'avatar di Herardo
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Firenze
    Messaggi
    3
    Versione Office
    excel 2013
    Likes ricevuti
    0
    Likes dati
    0

    Re: Sommare dati giornalieri su più mesi ed anni.

    Canapone grazie della risposta, non sapendone nulla di formule in excel oltre alla semplice sommatoria, potresti indicarmi qualche riferimento per approfondire il loro uso e significato ? Possibilmente che siano testi chiari e il più possibile brevi. Se non capisco bene le formule da te indicate non mi sento di limitarmi ad un copia ed incolla, devo capirle e imparare ad usarle in autonomia ... proviamoci ! Buona giornata e grazie ancora !

  7. #5
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204

    Re: Sommare dati giornalieri su più mesi ed anni.

    Ciao,

    trovo molto efficace la serie video di Gerardo su Youtube.

    Esempio questo video è dedicato al somma.più.se (parente strettissimo di media.più.se)

    https://www.youtube.com/watch?v=Qn70xPveL7A

    Oppure questo dedicato a MATR.SOMMA.PRODOTTO: un vero e proprio coltellino svizzero.

    https://www.youtube.com/watch?v=4ApRuQ939yM

    Hai il grosso vantaggio di poter lavorare su numeri ben disposti.
    Saluti

  8. I seguenti utenti hanno dato un "Like"


Discussioni Simili

  1. [Risolto] ammontare di 2 datei in anni, mesi, giorni
    Di Brivido.xls nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 27/02/17, 18:31
  2. Aggiornare dati giornalieri secondo elenco
    Di jonajams nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 09/06/16, 11:48
  3. estrarre dati in base ai mesi
    Di Franco71 nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 23/12/15, 16:43
  4. [RISOLTO] numero di mesi/anno (...) contano solo i mesi da maggio a novembre
    Di Canapone nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 27/09/15, 18:01
  5. Gestione testo per mesi ed anni
    Di giackko86 nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 09/09/15, 15:04

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •