Risultati da 1 a 15 di 15

Discussione: Sommare numeri pari



  1. #1
    L'avatar di Khan
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Padova
    Messaggi
    55
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    1

    Sommare numeri pari

    Vorrei sommare i numeri pari da 1 a 65000
    The saddest aspect of life right now is that science gathers knowledge faster than society gathers wisdom. - Isaac Asimov

    Windows 10 + Excel 2013

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1124
    Versione Office
    2010 su Win
    Likes ricevuti
    642
    Likes dati
    224
    Ciao

    un modo potrebbe essere:

    =SOMMA(INDICE(RIF.RIGA(1:65000)*(RESTO(RIF.RIGA(1:65000);2)=0);0))

    Saluti

  3. #3
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    2141
    Versione Office
    2010 PC
    Likes ricevuti
    1180
    Likes dati
    238
    ciao
    un modo:
    =MATR.SOMMA.PRODOTTO(RIF.RIGA(1:65000)*(VAL.PARI(RIF.RIGA(1:65000))))

    edit
    ciao Stefano, non ti avevo letto

  4. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1124
    Versione Office
    2010 su Win
    Likes ricevuti
    642
    Likes dati
    224
    Ciao Ninai,

    mi piace molto di più la formula con VAL.PARI.

  5. #5
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1124
    Versione Office
    2010 su Win
    Likes ricevuti
    642
    Likes dati
    224
    Ciao a tutti,

    usando SCARTO dovrebbe funzionare anche così:

    =SOMMA(INDICE(2*RIF.RIGA(SCARTO($A$1;0;0;65000/2));0))

    SCARTO è funzione volatile: meglio soluzione precedente.

  6. #6
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    2141
    Versione Office
    2010 PC
    Likes ricevuti
    1180
    Likes dati
    238
    Ho trovato questa regola matematica
    S = (2 + 2n)n/2
    Perciò =(2+65000)*65000/4 ma non posso testarla
    Ultima modifica fatta da:ninai; 22/07/15 alle 11:30

  7. #7
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1124
    Versione Office
    2010 su Win
    Likes ricevuti
    642
    Likes dati
    224
    Ciao,

    funziona: ho messo la formula alla prova.

  8. #8
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1273
    Likes dati
    1339
    Citazione Originariamente Scritto da Khan Visualizza Messaggio
    Vorrei sommare i numeri pari da 1 a 65000
    @Kahn se invece sei semplicemente interessato a contare o sommare i numeri pari e/o dispari di un intervallo.
    Guardati questo video per schiarirti un po le idee!!

    ciao


    Ultima modifica fatta da:Gerardo Zuccalà; 22/07/15 alle 11:56
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  9. #9
    L'avatar di Khan
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Padova
    Messaggi
    55
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    1
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ciao
    un modo:
    =MATR.SOMMA.PRODOTTO(RIF.RIGA(1:65000)*(VAL.PARI(RIF.RIGA(1:65000))))
    bravo



    Ho visto qualche minuto del video di Gerardo ma è una cosa diversa. Impiega molte risorse in quanto lavora su array e non su intervalli quindi utilizza molte risorse. Nella formula di ninai si può comunque stabilire qualsiasi punto di partenza e di arrivo. Test superato
    Ultima modifica fatta da:Khan; 22/07/15 alle 19:50
    The saddest aspect of life right now is that science gathers knowledge faster than society gathers wisdom. - Isaac Asimov

    Windows 10 + Excel 2013

  10. #10
    L'avatar di Andrea
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Levico Terme
    Età
    60
    Messaggi
    38
    Versione Office
    2016
    Likes ricevuti
    5
    Likes dati
    14
    Perciò =(2+65000)*65000/4 ma non posso testarla

    Ho provato. Ma funziona solo se metti un numero pari

  11. #11
    L'avatar di Khan
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Padova
    Messaggi
    55
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    1
    Citazione Originariamente Scritto da Andrea Visualizza Messaggio
    Perciò =(2+65000)*65000/4 ma non posso testarla

    Ho provato. Ma funziona solo se metti un numero pari
    La formula è questa: n*(2+2N)/2 e funziona con qualsiasi numero la tua è diversa.
    The saddest aspect of life right now is that science gathers knowledge faster than society gathers wisdom. - Isaac Asimov

    Windows 10 + Excel 2013

  12. #12

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    58
    Messaggi
    1207
    Versione Office
    .
    Likes ricevuti
    451
    Likes dati
    0
    Citazione Originariamente Scritto da Khan Visualizza Messaggio
    Impiega molte risorse in quanto lavora su array e non su intervalli quindi utilizza molte risorse....
    Scusa, mi spiegheresti il senso di questa frase?
    Lavorare su un array è molto più efficiente che non lavorare su un range.
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  13. #13
    L'avatar di Khan
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Padova
    Messaggi
    55
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    1
    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    Scusa, mi spiegheresti il senso di questa frase?
    Lavorare su un array è molto più efficiente che non lavorare su un range.
    Forse mi sono espresso male e frettolosamente e non ho visto a fondo il video di Gerardo ma senza dubbio le formule matriciali sono più lente di quelle che lavorano su intervalli.
    The saddest aspect of life right now is that science gathers knowledge faster than society gathers wisdom. - Isaac Asimov

    Windows 10 + Excel 2013

  14. #14

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    58
    Messaggi
    1207
    Versione Office
    .
    Likes ricevuti
    451
    Likes dati
    0
    Citazione Originariamente Scritto da Khan Visualizza Messaggio
    Forse mi sono espresso male e frettolosamente e non ho visto a fondo il video di Gerardo ma senza dubbio le formule matriciali sono più lente di quelle che lavorano su intervalli.
    Scusa, ho frainteso io, pensavo parlassi di VBA (non ho visto il video), pardon!
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  15. #15
    L'avatar di Khan
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Padova
    Messaggi
    55
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    1
    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    Scusa, ho frainteso io, pensavo parlassi di VBA (non ho visto il video), pardon!
    E' sempre un piacere dialogare con un professionista
    The saddest aspect of life right now is that science gathers knowledge faster than society gathers wisdom. - Isaac Asimov

    Windows 10 + Excel 2013

Discussioni Simili

  1. [Risolto] Sommare dei numeri in funzione ad un intervallo di date
    Di sitolofi nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 03/01/17, 07:06
  2. Sommare ore numeri con VBA
    Di Allocco nel forum Domande su Excel VBA e MACRO
    Risposte: 3
    Ultimo Messaggio: 10/03/16, 07:20
  3. Sommare numeri che hanno la stessa data
    Di G.Bove nel forum Domande su Excel in generale
    Risposte: 27
    Ultimo Messaggio: 04/02/16, 00:09
  4. Sommare numeri naturali
    Di Khan nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 24/07/15, 11:15
  5. [Risolto] Estrarre numeri pari e dispari ed inserirli su due tabelle mantenedo la stessa rig
    Di BRAZ66 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 24/06/15, 21:57

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •