Risultati da 1 a 15 di 15

Discussione: Articoli arrivati per anno



  1. #1
    L'avatar di RICCARDO_75
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Vicenza
    Età
    42
    Messaggi
    14
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    11

    Articoli arrivati per anno

    Ciao a tutti
    allego esempio, perchè non saprei come descrivere il problema (spero sia chiaro)
    Scusate
    File Allegati File Allegati

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7183
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2067
    Likes dati
    1308

    Re: Articoli arrivati per anno

    Ciao,

    per il 2015:

    =SOMMA(SE(FREQUENZA(SE(A2:A9=2015;CONFRONTA(B2:B9;B2:B9;0);"");CONFRONTA(B2:B9;B2:B9;0))>0;1))

    per il 2016:

    =SOMMA(SE(FREQUENZA(SE(A2:A9=2016;CONFRONTA(B2:B9;B2:B9;0);"");CONFRONTA(B2:B9;B2:B9;0))>0;1))

    Matriciali, cioè si attivano con CTRL+SHIFT+INVIO
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di RICCARDO_75
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Vicenza
    Età
    42
    Messaggi
    14
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    11

    Re: Articoli arrivati per anno

    Ciao,
    scusami l'ignoranza...cosa significa Matriciali ecc ecc....
    Perchè la formula non mi funziona...

  4. #4

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4050
    Versione Office
    2013
    Likes ricevuti
    1240
    Likes dati
    931

    Re: Articoli arrivati per anno

    Ciao a tutti,

    un'alternativa alla formula di ges:
    ho usato le colonne F e G, quindi nella cella F2 inserisci questa formula matriciale (da confermare con la combinazione di tasti CTRL+MAIUSC+INVIO) e dopo copia in basso e a destra:

    =SE(MIN(SE.ERRORE((1/($A$2:$A9=STRINGA.ESTRAI(F$1;6;4)*1))*(1/($B$2:$B9=$B2))*RIF.RIGA($A$2:$A$9);""))=RIF.RIGA();1;"no")


    Ti riallego il file...

    @ges
    in effetti con la formula da te proposta i risultati non corrispondono :273:
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  5. I seguenti 2 utenti hanno dato un "Like" a cromagno per questo post:


  6. #5
    L'avatar di RICCARDO_75
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Vicenza
    Età
    42
    Messaggi
    14
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    11

    Re: Articoli arrivati per anno

    Grazie a tutti...funziona
    gentilissimi
    :274:

  7. #6

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4050
    Versione Office
    2013
    Likes ricevuti
    1240
    Likes dati
    931

    Re: Articoli arrivati per anno

    Citazione Originariamente Scritto da RICCARDO_75 Visualizza Messaggio
    Grazie a tutti...funziona
    gentilissimi
    :274:
    Ciao Riccardo,
    se hai risolto il problema, segna questo thread come "RISOLTO".
    Vai sul menù "Strumenti Discussione" (all'inizio del thread) e scegli la voce "Segna questa discussione come Risolta...".

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  8. I seguenti utenti hanno dato un "Like"


  9. #7

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7183
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2067
    Likes dati
    1308

    Re: Articoli arrivati per anno

    Citazione Originariamente Scritto da cromagno Visualizza Messaggio
    ..
    ....

    @ges
    in effetti con la formula da te proposta i risultati non corrispondono :273:
    Ciao cromagno,
    avrò capito male la richiesta... mi era sembrato che si chiedesse QUANTI articoli sono arrivati nel 2015 e quanti nel 2016 per ciascun cliente escludendo i duplicati e la mia formula fa esattamente quello.
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  10. I seguenti utenti hanno dato un "Like"


  11. #8
    L'avatar di RICCARDO_75
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Vicenza
    Età
    42
    Messaggi
    14
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    11

    Re: Articoli arrivati per anno

    Scusate ragazzi
    solo ora ho visto che la formula non funziona.
    Forse mi sono spiegato male e chiedo scusa....io vorrei avere il risultato (come da esempio colonna C e D) avendo solo i dati come da colonna A e B....

  12. #9

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4050
    Versione Office
    2013
    Likes ricevuti
    1240
    Likes dati
    931

    Re: Articoli arrivati per anno

    Citazione Originariamente Scritto da RICCARDO_75 Visualizza Messaggio
    Scusate ragazzi
    solo ora ho visto che la formula non funziona.
    Forse mi sono spiegato male e chiedo scusa....io vorrei avere il risultato (come da esempio colonna C e D) avendo solo i dati come da colonna A e B....
    Spiegati meglio, perchè in base al file che allegato, la formula che ti ho proposto dà i risultati che cercavi.
    Cosa vorresti?

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  13. I seguenti utenti hanno dato un "Like"


  14. #10
    L'avatar di RICCARDO_75
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Vicenza
    Età
    42
    Messaggi
    14
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    11

    Re: Articoli arrivati per anno

    Ciao Cromagno
    nella tua formula c'è anche il cerca.vert in riferimento a colonna c e d
    In realtà io vorrei una formula da inserire nella colonna c e d che mi dia il stesso risultato dell'esempio in rosso.

  15. #11

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4050
    Versione Office
    2013
    Likes ricevuti
    1240
    Likes dati
    931

    Re: Articoli arrivati per anno

    Citazione Originariamente Scritto da RICCARDO_75 Visualizza Messaggio
    Ciao Cromagno
    nella tua formula c'è anche il cerca.vert in riferimento a colonna c e d
    In realtà io vorrei una formula da inserire nella colonna c e d che mi dia il stesso risultato dell'esempio in rosso.
    :256::256:

    nella mia formula non c'è nessun riferimento alle colonne C e D :

    =SE(MIN(SE.ERRORE((1/($A$2:$A9=STRINGA.ESTRAI(F$1;6;4)*1))*(1/($B$2:$B9=$B2))*RIF.RIGA($A$2:$A$9);""))=RIF.RIGA();1;"no")

    Copia la cella F2 nella cella C2 e dopo copia la cella C2 in basso e a destra.

    [EDIT]
    o semplicemente, copia la cella F2 nel range C:D

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  16. I seguenti utenti hanno dato un "Like"


  17. #12
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4937
    Versione Office
    2013
    Likes ricevuti
    1122
    Likes dati
    1131

    Re: Articoli arrivati per anno

    Ciao ragazzi
    Giusto per condividere una soluzione alternativa a quella di Cromagno, solo che ho messo una colonna aggiuntiva nella colonna E , se questa colonna da fastidio la si può spostare o nascondere

    Nella cella E2 metti questa formula e trascina in basso

    =A2&B2

    in C2 metti questa formula e trascinala in basso

    =SE(A$2:A$9=2015;SE(CONTA.SE($E$2:E2;E2)=1;1;"no");"no")


    in D2 metti questa formula e trascinala in basso

    =SE(A$2:A$9=2016;SE(CONTA.SE($E$2:E2;E2)=1;1;"no");"no")

    Sicuramente ci sono altre soluzioni migliori
    un saluto Gerardo :43:

  18. I seguenti utenti hanno dato un "Like"


  19. #13
    L'avatar di RICCARDO_75
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Vicenza
    Età
    42
    Messaggi
    14
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    11

    Re: Articoli arrivati per anno

    ok...però se aggiungo articoli (altri nomi) nella colonna c e d non mi riporta il risultato (mi dà tutto no)
    Il mio era un esempio, ho molti articoli che si ripetono e diversi tra loro.....ti allego una parte del file dove stò lavorando (in realtà sono quasì 4000 righe)
    File Allegati File Allegati

  20. #14

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4050
    Versione Office
    2013
    Likes ricevuti
    1240
    Likes dati
    931

    Re: Articoli arrivati per anno

    Citazione Originariamente Scritto da RICCARDO_75 Visualizza Messaggio
    ok...però se aggiungo articoli (altri nomi) nella colonna c e d non mi riporta il risultato (mi dà tutto no)
    Il mio era un esempio, ho molti articoli che si ripetono e diversi tra loro.....ti allego una parte del file dove stò lavorando (in realtà sono quasì 4000 righe)
    Riccardo,
    le formule che ti proponiamo si basano su quello che ci fai vedere!
    Sta a te prendere spunto dalle formule e adattarle alla tua situazione reale.
    Il nuovo file è completamente diverso come disposizione e anche la stringa di testo, dalla quale estraggo l'anno per poterlo verificare con l'attuale colonna B, è diversa.
    Con il file attuale, in colonna I2 da copiare poi in basso e a destra dovresti usare una formula del genere:

    =SE(MIN(SE.ERRORE((1/($B$2:$B$10=DESTRA(I$1;4)*1))*(1/($H$2:$H$10=$H2))*RIF.RIGA($A$2:$A$10);""))=RIF.RIGA();1;"no")

    [EDIT]
    In caso di aggiunta di nuovi record, devi adattare i range nella formula, oppure usa i riferimenti relativi invece degli assoluti:

    =SE(MIN(SE.ERRORE((1/($B$2:$B2=DESTRA(I$1;4)*1))*(1/($H$2:$H2=$H2))*RIF.RIGA($A$2:$A2);""))=RIF.RIGA();1;"no")

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  21. I seguenti utenti hanno dato un "Like"


  22. #15
    L'avatar di RICCARDO_75
    Clicca e Apri
    Data Registrazione
    Mar 2016
    Località
    Vicenza
    Età
    42
    Messaggi
    14
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    11

    Re: Articoli arrivati per anno

    Grazie a tutti
    siete splendidi....
    ciao

Discussioni Simili

  1. [Risolto] Come riepilogare articoli e quantità
    Di Tonyvox nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 18/02/17, 16:07
  2. Creazione database per gestione tecnica di mescole per articoli in gomma
    Di gfavaretto nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 06/01/17, 18:37
  3. Creare un Codice Per articoli
    Di ortofrutta_palladino nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 24/07/16, 12:19
  4. Selezione rapida gruppo articoli
    Di MauroS nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 27/06/15, 20:49
  5. Selezione rapida gruppo articoli
    Di MauroS nel forum Test dei vostri post
    Risposte: 0
    Ultimo Messaggio: 26/06/15, 22:31

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •