Risultati da 1 a 3 di 3

Discussione: estrai ed ordina numeri (solo una volta)



  1. #1
    L'avatar di Andre81
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Parma
    Età
    36
    Messaggi
    65
    Versione Office
    2013
    Likes ricevuti
    2
    Likes dati
    9

    estrai ed ordina numeri (solo una volta)

    Stesso tipo di problema ma stavolta con i numeri:

    Excel 2013
    Row\Col
    A
    B
    C
    1
    40
    10
    2
    30
    20
    3
    20
    30
    4
    20
    40
    5
    10
    50
    6
    40
    7
    50
    8
    40
    9
    50
    Sheet: Foglio2

    Stavolta la formula è più comprensibile (da attivare sempre selezionando C1:C9 e poi ctrl+maiusc+invio):

    =SE.ERRORE(PICCOLO(SE(FREQUENZA(A1:A9;A1:A9)>0;A1:A9);RIF.RIGA(A1:A9));"")

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    in C2

    Codice: 
    =SE.ERRORE(AGGREGA(15;6;A$1:A$9/(CONTA.SE(C$1:C1;A$1:A$9)=0);1);"")
    da copiare in basso

    Saluti
    Ultima modifica fatta da:Canapone; 23/07/15 alle 17:02

  3. #3
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao a tutti,

    condivido anche questa formula che può essere usata anche su Excel 2003

    Numeri in A1:A9

    in C1

    Codice: 
    =MIN(A1:A9)
    In C2 da copiare poi in basso

    Codice: 
    =SE(MATR.SOMMA.PRODOTTO(1/CONTA.SE(A$1:A$9;A$1:A$9))>=RIF.RIGA(A2);PICCOLO(A$1:A$9;CONTA.SE(A$1:A$9;"<="&C1)+1);"")

    Se servisse.

Discussioni Simili

  1. Risposte: 10
    Ultimo Messaggio: 05/02/17, 09:14
  2. Cancellare solo numeri da una cella excel
    Di pgft nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 09/09/16, 13:36
  3. Cerca un record in almeno una colonna ed estrai quella riga una sola volta..?
    Di Kogenta nel forum Domande su Excel VBA e MACRO
    Risposte: 2
    Ultimo Messaggio: 03/03/16, 14:08
  4. Somma.piu.se ma solo i primi n numeri
    Di Chabba nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 05/01/16, 16:26
  5. Estrarre solo i numeri da una stringa
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 15/07/15, 18:04

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •