Risultati da 1 a 12 di 12

Discussione: Problema calcolo excel



  1. #1
    L'avatar di Alberto999
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    lecce
    Messaggi
    3
    Versione Office
    2010
    Likes ricevuti
    1

    Problema calcolo excel

    Salve a tutti,io ho un problema su excel 10,in pratica avrei bisogno di un calcolo matematico che non riesco a far uscire.Vi posto una foto per spigarmi meglio:Io ho provato questa formula: =MATR.SOMMA.PRODOTTO(B:B;F:F;I:I) ma non sono riuscito,spero che qualcuno sia cosi' gentile da aiutarmi.Grazie
    Ultima modifica fatta da:Canapone; 28/06/17 alle 12:40

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923

    Re: Problema calcolo excel

    Ciao,
    per come hai esposto i dati non si capisce quello vuoi ottenere.

    Allega il file excel e spiega precisamente cosa vuoi fare

    Leggi qui:
    http://www.forumexcel.it/forum/2-ann...isposta-rapida

    Ciao

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. #3

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2810
    Versione Office
    Excel 2013
    Likes ricevuti
    1022
    Likes dati
    979

    Re: Problema calcolo excel

    Non capisco cosa sia contenuto nella colonna "B" (a me sembra il codice a barre)

    EDIT: Scusa Tore ci siamo sovrapposti (e non abbiamo capito entrambi il quesito :92:)

  4. #4
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: Problema calcolo excel

    Ciao Alberto999, se ho capito bene!!!!, dovrebbe andar bene la seguente:

    dove desideri tu, incolla:
    =MATR.SOMMA.PRODOTTO(($B$2:$B$10=B2)*($D$2:$D$10)*($E$2:$E$10))
    e tiri giù, dopo aver adattato l'intervallo al tuo file.
    Allego il file di prova.
    Ciao, fa sapere se va bene.

    Chiedo scusa sia a Cromagno, che a Rubik, e colgo l'occasione per un cordiale saluto ad entrambi, purtroppo non ho fatto l'aggiornamento pagina.
    Comunque ho tentato di dare una mia interpretazione alla discussione aperta.
    File Allegati File Allegati

  5. I seguenti utenti hanno dato un "Like"

    ges

  6. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: Problema calcolo excel

    Ciao a tutti,
    alternativa alla formula proposta da pkrome:

    =SOMMA.SE(B:B;B2;D:D)*E2
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  7. I seguenti utenti hanno dato un "Like"


  8. #6
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2302
    Versione Office
    Excel 2010
    Likes ricevuti
    913
    Likes dati
    451

    Re: Problema calcolo excel

    Un saluto a tutti visto che avevo già preparato la formula ma è arrivato il suggerimento di Pk la posto comunque.
    La mia interpretazione è simile a quella di Pk ma ho lasciato i riferimenti colonna come detto da Alberto999 e da un totale unico
    =MATR.SOMMA.PRODOTTO(($B$2:$B$11*$F$2:$F$11*$I$2:$I$11))

  9. I seguenti 3 utenti hanno dato un "Like" a Berna11 per questo post:


  10. #7
    L'avatar di Alberto999
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    lecce
    Messaggi
    3
    Versione Office
    2010
    Likes ricevuti
    1

    Re: Problema calcolo excel

    Salve innanzi a tutto ringrazio PKROME,GES E BERNA 11 per il supporto.Essendo un po' ignorante in materia,non avevo postato bene la foto del problema che vorrei risolvere.Ne allego un'altra,e cerco di spiegarmi meglio.Nella colonna B io metto la quantita' che desidero dei colli,nella colonna F sono riportati i pezzi che contiene ogni collo e nalla colonna I c'e' ilprezzo di ogni prodotto.Io vorrei la somma istantanea totale man mano che si aggiungono i colli nella colonna B.Spero di essermi spiegato bene.Grazie a tutti in anticipo
    File Allegati File Allegati

  11. I seguenti utenti hanno dato un "Like"


  12. #8
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: Problema calcolo excel

    Ciao Alberto999, se ho capito bene, copia:

    Per quanto riguarda il totale pe ogni articolo,

    In M2:
    =SE(B2<>"";($F$2:$F$10)*($I$2:$I$10)*B2;0)

    e tiri giù fin dove ti occorre, variando l'intervallo.
    Per quanto riguarda il totale complessivo, copia:

    In N2:
    =SOMMA($M$2:$M$10)

    Allego il file di prova, fa sapere se va bene.
    Ciao.
    File Allegati File Allegati

  13. I seguenti 3 utenti hanno dato un "Like" a pkrome59 per questo post:


  14. #9
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2302
    Versione Office
    Excel 2010
    Likes ricevuti
    913
    Likes dati
    451

    Re: Problema calcolo excel

    Citazione Originariamente Scritto da Alberto999
    Io vorrei la somma istantanea totale man mano che si aggiungono i colli nella colonna B
    Salve Alberto999, non so se hai avuto modo di provare la mia formula che ti da il totale generale man mano che inserisci la q.tà in colonna B.
    Naturalmente i riferimenti finali sono da modificare da ...$11 al numero ultima riga del tuo elenco.
    Non ci hai indicato dove vorresti avere il totale ma, la formula che ti ho proposto, la puoi mettere in qualsiasi cella.
    Se invece vuoi un totale progressivo per riga segui l'indicazione proposta da Pk. (che saluto).

  15. I seguenti utenti hanno dato un "Like"


  16. #10

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301

    Re: Problema calcolo excel

    Un saluto a tutti i partecipanti,
    concordo con Berna, la sua formula postata sopra calcola il totale al pari della formula di krome (SOMMA) postata nell'ultimo messaggio.

    Giusto per partecipare propongo delle piccole alternative, in M2 da trascinare in basso:

    =MATR.SOMMA.PRODOTTO((I2:I2)*(F2:F2)*B2)

    =SE.ERRORE(($F$2:$F$10)*($I$2:$I$10)*B2;"")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  17. I seguenti 3 utenti hanno dato un "Like" a ges per questo post:


  18. #11
    L'avatar di Alberto999
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    lecce
    Messaggi
    3
    Versione Office
    2010
    Likes ricevuti
    1

    Re: Problema calcolo excel

    Un sentito ringraziamento a tutti voi,in particolare a PKROME 59,BERNA11 E GES. Grazie al vostro aiuto e alla vostra esperienza sono riuscito a risolvere il problema!:255::255::255:

  19. #12

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923

    Re: Problema calcolo excel

    Citazione Originariamente Scritto da Alberto999 Visualizza Messaggio
    Un sentito ringraziamento a tutti voi,in particolare a PKROME 59,BERNA11 E GES. Grazie al vostro aiuto e alla vostra esperienza sono riuscito a risolvere il problema!:255::255::255:
    Alberto, son felice che tu abbia risolto, ma se la prossima volta mettessi direttamente il file, si eviterebbe di andare "a tentativi".

    P.S.
    Se hai risolto, divresti "segnare" questa discussione come RISOLTA.

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

Discussioni Simili

  1. calcolo con Excel
    Di cesare nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 15/11/16, 06:59
  2. problema con foglio di calcolo da 150.000 righe di dati
    Di nemoclipru nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 03/10/16, 18:43
  3. Problema sistema calcolo ore settimanali
    Di jacobrs nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 01/06/16, 18:15
  4. problema calcolo con decimali
    Di laly nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 15/02/16, 17:24
  5. Problema calcolo ore dopo la mezzanotte
    Di alessio nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 10/12/15, 02:18

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •