Risultati da 1 a 5 di 5

Discussione: Convalida Dati e celle vuote in mezzo ad elenco



  1. #1
    L'avatar di Mudir
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Italia
    Messaggi
    3
    Versione Office
    Office 2016
    Likes ricevuti
    0
    Likes dati
    0

    Convalida Dati e celle vuote in mezzo ad elenco

    Salve a tutte e tutti,
    e complimenti per la community. :286:
    Vorrei condividere con voi un problema su cui sto lavorando.
    Nel file in allegato ho elaborato una semplice gestione di turni. Secondo voi è possibile, nel menu a discesa, eliminare gli spazi vuoti eventualmente utilizzando anche colonne di appoggio?
    Vi ringrazio anticipatamente per qualsiasi contributo vogliate darmi.
    Saluti


    Allegato 271

  2. #2
    L'avatar di Mudir
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Italia
    Messaggi
    3
    Versione Office
    Office 2016
    Likes ricevuti
    0
    Likes dati
    0
    Eccomi di nuovo!
    Girando per il web ho trovato questa formula complessa che funziona se applicata alle colonne e non alle righe (vedi file allegato).

    Come potrei trasformarla per adattarla al mio caso?
    {=SE.ERRORE(INDICE($A$2:$A$10;PICCOLO(SE(VAL.NUMERO(CONFRONTA(RIF.RIGA($A$2:$A$10)-1;SE($A$2:$A$10=0;"";CONFRONTA($A$2:$A$10;$A$2:$A$10;0));0));CONFRONTA($A$2:$A$10;$A$2:$A$10;0);"");RIF.RIGA(A1)));"")}

    Allego file con formula funzionante

    Grazie!!

    Allegato 275
    "Non è tanto importante quello che ci accade,
    quanto il modo con cui vi reagiamo".

    Hans Selye

  3. #3
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    nella cella C1 del file prova2 trovo "AF".

    Volevo chiederti se è un refuso o se volevi registrare sia A che F nel primo turno di venerdì 1/1/2016. Non fosse un un errore, gli INDICE da costruire sarebbero davvero complicati.

    Credo che potrebbe essere d'aiuto sapere anche la versione di Excel che usi.

    Saluti
    Ultima modifica fatta da:Canapone; 24/07/15 alle 07:10

  4. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202

    indice aggrega convalida

    Ciao,

    condivido un primo esempio dove uso


    =SE.ERRORE(INDICE($J$5:$J$12;AGGREGA(15;6;RIF.RIGA($A$1:$A$8)/(CONTA.SE($C5:$H5;$J$5:$J$12)=0);RIF.COLONNA(A$1)));"")



    Nella convalida ho messo come origine


    =SCARTO($N5;;;;CONTA.SE($N5:$U5;">-"))

    Saluti

  5. #5
    L'avatar di Mudir
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Italia
    Messaggi
    3
    Versione Office
    Office 2016
    Likes ricevuti
    0
    Likes dati
    0
    :222: Grazie Mille Canapone!!!!
    Adesso tenterò di decodificare la formula, da te suggerita, per comprenderla fino in fondo!
    A presto!
    "Non è tanto importante quello che ci accade,
    quanto il modo con cui vi reagiamo".

    Hans Selye

Discussioni Simili

  1. [Risolto] Aggrega spese del conto corrente per tipo di spesa + seleziona da elenco senza celle vuote
    Di mauri73 nel forum Domande su Excel in generale
    Risposte: 17
    Ultimo Messaggio: 12/11/16, 22:17
  2. Selezionamento di celle non vuote di un elenco di dati
    Di CRISTIAN nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 28/04/16, 16:05
  3. Elenco Convalida Dati
    Di Cirino nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 02/03/16, 09:20
  4. Creare ELENCO (convalida dati) con celle non consecutive + opzione nulla.
    Di aldomattana nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 05/11/15, 19:25
  5. Convalida dati da elenco per dati univoci dinamica
    Di tsunami1978 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 27/08/15, 00:52

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •