Risultati da 1 a 7 di 7

Discussione: sommare valori con parte del riferimento nella stringa della cella



  1. #1
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    sommare valori con parte del riferimento nella stringa della cella

    Ciao a tutti.
    Vorrei sommare i valori tenendo conto della stringa della cella.
    In breve:
    la formula dovrebbe cercare nel foglio di lavoro "WGT1" le righe che contengono una parte del codice e sommarli tra di loro riportandoli nel foglio di lavoro "Menu" nelle rispettive righe E25, F25 ed F26.
    Nel foglio di lavoro Helper sono presenti le matrici dei codici.
    https://www.dropbox.com/s/6jtgb3j8z1...0%2B.xlsm?dl=0

    Spero che l'allegato vi aiuti a capire più della descrizione di cui sopra

    Grazie e buon WE lungo a chi lo fà :243:.

    Gene

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7118
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1297

    Re: sommare valori con parte del riferimento nella stringa della cella

    Ciao,
    ti riporto le tre formule (MATRICIALI) richieste:

    1) sommati valori che hanno nel parte finale del codice : xxxxx-x8519C:

    =SOMMA(SE(DESTRA('WGT1'!$B$2:$B$46;5)="8519C";'WGT1'!$F$2:$F$46))


    2) sommati valori che hanno nel parte finale del codice : xxxxx-x8519S

    =SOMMA(SE(DESTRA('WGT1'!$B$2:$B$46;5)="8519S";'WGT1'!$F$2:$F$46))


    3)sommati valori che hanno nel parte finale del codice : xxxxx-x8519SW

    =SOMMA(SE(DESTRA('WGT1'!$B$2:$B$46;6)="8519SW";'WGT1'!$F$2:$F$46))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    779
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1

    Re: sommare valori con parte del riferimento nella stringa della cella

    k
    l
    m
    2
    c s sw
    3
    65278
    109982
    35719

    Buon giorno

    nel foglio wgt1

    k3=SOMMA.SE($B$2:$B$46;"*"&8519&K$2;$F$2:$F$46) trascina a destra

    c s sw sono i riferimenti finali dei codici

    Saluti
    Window 8.1 Excel 2013/2016

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125

    Re: sommare valori con parte del riferimento nella stringa della cella

    Ciao a tutti

    Giusto per condividere delle altrenative
    Gene ma i calcoli li avevi fatti a mano? perchè ho delle piccole differenze

    Comunque nella cella E25:
    =MATR.SOMMA.PRODOTTO(--(VAL.NUMERO(RICERCA("08519C";'WGT1'!$B$2:$B$46)));'WGT1'!$F$2:$F$46)

    nella cella F25
    =MATR.SOMMA.PRODOTTO(--(VAL.NUMERO(RICERCA("08519S";'WGT1'!$B$2:$B$46)));'WGT1'!$F$2:$F$46)


    nella cella F26
    =MATR.SOMMA.PRODOTTO(--(VAL.NUMERO(RICERCA("8519SW";'WGT1'!$B$2:$B$46)));'WGT1'!$F$2:$F$46)

    Da testare è un approccio un po volatile

  5. #5
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    779
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1

    Re: sommare valori con parte del riferimento nella stringa della cella

    Buon Giorno

    Collegare i risultati della formula nel foglio wgt1

    k3=SOMMA.SE($B$2:$B$46;"*"&8519&K$2;$F$2:$F$46) trascina a destra





    al foglio menu

    e25='WGT1'!K3

    f25='WGT1'!L3

    f26='WGT1'!M3

    Saluti
    Window 8.1 Excel 2013/2016

  6. #6
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Re: sommare valori con parte del riferimento nella stringa della cella

    Come al solito avete risposto alla grande.
    Grazie a tutti.
    Le provo tutte e poi restituisco feedback ( che se qui in montagna migliora il tempo...non sarà immediato! :50:)


    Gene

  7. #7
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Re: sommare valori con parte del riferimento nella stringa della cella

    Ciao a tutti,
    doverose risposte in ordine di apparizione ( ...il meteo non è dalla mia :239:)

    @ Ges
    Tutto perfetto e funzionante.

    @Pitagora
    Vedi sopra

    @ Gerardo
    Le differenze su alcuni item nascono perchè la tua formula tiene conto e somma, sia gli articoli S che quelli SW(xxxxx-x8519S e xxxxx-x8519SW)

    Grazie ancora a tutti.

    Alla prossima
    Gene

Discussioni Simili

  1. [Risolto] Ricerca di parte di una stringa in una cella con restituzione del contenuto di un'altra cella
    Di MartaL. nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 06/03/17, 11:45
  2. [Risolto] Come posso fare la ricerca nella combobox....digitando parte della parola da ricercare
    Di CAVALLO67 nel forum Domande su Excel VBA e MACRO
    Risposte: 39
    Ultimo Messaggio: 06/12/16, 18:00
  3. Aumentare Numero nella Stringa Piuttosto che della Cella
    Di LuigiMdg nel forum Domande su Excel in generale
    Risposte: 26
    Ultimo Messaggio: 17/04/16, 22:24
  4. Sommare valori compresi in una stringa di testo
    Di Pierpaolo nel forum Domande su Excel in generale
    Risposte: 32
    Ultimo Messaggio: 11/09/15, 00:43
  5. [Risolto] Come sostituire valori nella stessa tabella di riferimento (con formule)
    Di jimbrass nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 30/06/15, 22:34

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •