Risultati da 1 a 7 di 7

Discussione: Aggiungere colonne con ore maggiorate



  1. #1
    L'avatar di slvt82
    Clicca e Apri
    Data Registrazione
    May 2016
    LocalitÓ
    bari
    Messaggi
    31
    Versione Office
    211 mac
    Likes ricevuti
    0
    Likes dati
    5

    Aggiungere colonne con ore maggiorate

    Ciao a tutti, avrei bisogno di una grande mano. Vorrei aggiungere tre colonne a fianco delle ore notturne, una per calcolare le ore di lavoro festivo, una per calcolare le ore di lavoro domenicale ed una per calcolare le ore di notturno festivo, mi servirebbe anche una mano per risolvere l'errore che mi da se lascio le celle vuote. Grazie
    File Allegati File Allegati

  2. #2
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125

    Re: Aggiungere colonne con ore maggiorate

    Ciao Slvt82, benvenuto in forumexcel.it
    Quando fai le domande nel forum Ŕ meglio fare una domanda alla volta, altrimenti la tua domanda rischia di non essere vista, perchŔ qui siamo tutti disponibili ad aiutare ma non siamo disponibile a farti trovare il pacchetto pronto chiavi in mano

    comunque:
    Ho messo nel foglio "turni" le festivitÓ e le ho definite con un nome (servirÓ per le formula notturno festivo festivo)
    =TURNI!$K$3:$K$14

    Per le ore festive, ho aggiunto una colonna in (G)
    =SE(NON(GIORNI.LAVORATIVI.TOT(A2;A2;festivitÓ))<>O(GIORNO.SETTIMANA(A2;2)=6;GIORNO.SETTIMANA(A2;2)=7);F2;"")

    Per le domeniche ho aggiunto una colonna (H)
    in H2 metti questa formula e copiala in basso

    =SE(GIORNO.SETTIMANA(A2;2)=7;F2;"")

    Per il notturno festivo ho aggiunto una colonna nell (I)
    =SE(NON(GIORNI.LAVORATIVI.TOT(A2;A2;festivitÓ))<>O(GIORNO.SETTIMANA(A2;2)=6;GIORNO.SETTIMANA(A2;2)=7);J2;"")


    In attesa di un tuo riscontro, se ci sono altre soluzioni benvengano
    un saluto:43:




    Excel 2013 32 bit
    A
    B
    C
    D
    E
    F
    G
    H
    I
    J
    1
    GIORNI
    TURNO
    INIZIO
    FINE
    TOT.ORE
    ORE DIURNE
    Festivo
    Domenicale
    Notturno fesivo
    ORE NOTTURNE
    2
    venerdý 1 gennaio 2016
    1
    1:34
    8:30
    6:56
    2:30
    2:30
    4:26
    4:26
    3
    sabato 2 gennaio 2016
    #
    0:00
    0:00
    0:00
    0:0
    0:00
    4
    domenica 3 gennaio 2016
    4
    0:36
    7:12
    6:36
    1:12
    1:12
    5:24
    5
    lunedý 4 gennaio 2016
    4
    0:36
    7:12
    6:36
    1:12
    5:24
    6
    martedý 5 gennaio 2016
    #
    7
    mercoledý 6 gennaio 2016
    5
    0:36
    7:12
    6:36
    1:12
    1:12
    5:24
    5:24
    8
    giovedý 7 gennaio 2016
    6
    0:36
    7:12
    6:36
    1:12
    5:24
    Sheet: GENNAIO
    File Allegati File Allegati

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    LocalitÓ
    Latina
    EtÓ
    62
    Messaggi
    2277
    Versione Office
    Excel 2010
    Likes ricevuti
    905
    Likes dati
    450

    Re: Aggiungere colonne con ore maggiorate

    Un saluto a tutti,
    Anche se Gerardo ti ha gi¨ dato una prima soluzione visto che ci stavo lavorando su posto anche la mia soluzione.
    Ho tolto quel # nell'elenco dei turni basta lasciarlo in bianco.
    Anch'io ho inserito le Festivit¨ nel foglio Turni.

    Di sicuro ci saranno dei parametri da verificare per le ore notturne festive ho messo sia le festivit¨ che le domeniche non so se intendevi entrambi.
    Cmq intanto vedi le due proposte e vedi se fanno al caso tuo.
    File Allegati File Allegati

  5. #4
    L'avatar di slvt82
    Clicca e Apri
    Data Registrazione
    May 2016
    LocalitÓ
    bari
    Messaggi
    31
    Versione Office
    211 mac
    Likes ricevuti
    0
    Likes dati
    5

    Re: Aggiungere colonne con ore maggiorate

    Ringrazio entrambi, gentilissimi, le soluzioni proposte vanno benissimo!
    Scusami Gerardo la prossima volta far˛ una domanda per volta.
    Saluti.

  6. #5
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125

    Re: Aggiungere colonne con ore maggiorate

    Ciao Berna11
    grazie per il tuo contributo, tuttavia ti chiedo una gentilezza, quando inserisci un allegato Ŕ necessario che inserisci anche i codici VBA o le formule, perche gli allegati in futuro potrebbero non esserci pi¨, leggi qui sotto il regolamento

    Regola nr. 12 "Insieme all'allegato postare Codici VBA e formule"
    Oltre ai file allegati Ŕ buona norma pubblicare anche le formule o i codici VBA utilizzati, perchŔ non sempre si possono aprire i file allegati per problemi di banda e problemi con telefonini che non possono accedere all'Editor VBA, cosi da non avere il piacere di capire il codice scritto, oltretutto i file potrebbero non essere pi¨ disponibili nel tempo.


    grazie
    Un saluto

  7. #6
    L'avatar di Gerardo ZuccalÓ
    Clicca e Apri
    Data Registrazione
    May 2015
    LocalitÓ
    Milano, Italy
    EtÓ
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125

    Re: Aggiungere colonne con ore maggiorate

    Citazione Originariamente Scritto da slvt82 Visualizza Messaggio
    Ringrazio entrambi, gentilissimi, le soluzioni proposte vanno benissimo!
    Scusami Gerardo la prossima volta far˛ una domanda per volta.
    Saluti.
    Slvt82
    Grazie per il tuo riscontro e se la tua domanda Ŕ stata risolta segna questa discussione come [RISOLTO]
    Vai nella barra dei menu, situata all’inizio di questa discussione, troverai il menu “Strumenti Discussione” quindi scegliere “Segna questo Thread come risolto”

  8. #7
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    LocalitÓ
    Latina
    EtÓ
    62
    Messaggi
    2277
    Versione Office
    Excel 2010
    Likes ricevuti
    905
    Likes dati
    450

    Re: Aggiungere colonne con ore maggiorate

    Ciao Gerardo,
    mi scuso per non aver rispettato la regola n.12 del regolamento.:275:
    Visto che il mio allegato rispecchiava nella forma la tua proposta con inserimento dei festivi ed inserimento delle 3 colonne (come richiesto) ho ritenuto superfluo allegare le formule inserite nelle 3 colonne.

    Allora nella colonna ore festive ho inserito:

    =SE.ERRORE(SE(CERCA.VERT(A2:$A$32;Festivi;1;0)=0;0;E2);"")

    Dove Festivi Ŕ il nome asegnato all'elenco dei giorni festivi inseriti nel foglio Turni.

    Nella colonna Ore Domenica ho messo:

    =SE(GIORNO.SETTIMANA(A2)=1;E2;"")

    Infine nella colonna Ore notturne Festivi ho usato una combinazioni di SE
    che confrontano se le colonne delle ore notturne e festivi sono diverse da vuote e se le colonne ore notturne e ore domenicali sono diverse da vuote...

    =SE(E(G2<>"";H2<>"");G2;+SE(E(G2<>"";I2<>"");I2;""))

    Tutto qui.

  9. I seguenti utenti hanno dato un "Like"


Discussioni Simili

  1. [Risolto] Aggiungere l'etÓ
    Di RUGANT54 nel forum Domande su Excel VBA e MACRO
    Risposte: 10
    Ultimo Messaggio: 22/12/16, 19:20
  2. aggiungere info
    Di Pacoarge nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 14/09/16, 01:29
  3. Grafico con istogrammi in colonne raggruppate e in colonne in pila
    Di Duchess@71 nel forum Domande sui Grafici di Excel
    Risposte: 2
    Ultimo Messaggio: 10/05/16, 08:49
  4. Aggiungere una colonna
    Di ric91 nel forum Domande su Excel VBA e MACRO
    Risposte: 11
    Ultimo Messaggio: 03/03/16, 22:12
  5. Aggiungere Protezione al codice Vba
    Di Bruno nel forum Domande su Excel VBA e MACRO
    Risposte: 12
    Ultimo Messaggio: 09/12/15, 11:22

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •