Risultati da 1 a 7 di 7

Discussione: codificazione e ricodificazione



  1. #1
    L'avatar di luiperre
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    trieste
    Messaggi
    2
    Versione Office
    Office365
    Likes ricevuti
    0
    Likes dati
    0

    codificazione e ricodificazione

    Salve
    sto tentando un business plan per la mia startup! che è qui http://www.jonathanproject.eu (solo per curiosità)
    ho un foglio (che allego) in cui sono elencate una serie di attività ognuna delle quali codifico in modo "arbitrario"

    affitti amministrativi aa
    materie prime mp
    trasporti tr
    ... ...

    poi però devo unificare sotto una unica codifica "finanziaria" uba serie di codifiche "arbitrarie"
    e quindi aa deve diventare ca (costi amministrativi) mp deve diventare cp (costi di produzione) e così via
    al risultato ci sono comunque arrivato ma con una serie infinita di SE()&SE... ma sicuramente non è il modo più efficiente

    =SE(($C5=F$5);F$3;)&SE(($C5=F$6);F$3;)&SE(($C5=F$7);F$3;)&SE(($C5=F$8);F$3;)&SE(($C5=F$9);F$3;)&SE(($C5=F$10);F$3;)&SE(($C5=F$11);F$3;)&SE(($C5=F$12);F$3..............

    ho tentato una contrazione così

    =SE(($C5=F$5:F$15);F$3;)&SE(($C5=G$5:G$15);G$3;)&SE(($C5=H$5:H$15);H$3;)&SE(($C5=I$5:I$15);I$3;)&SE(($C5=J$5:J$15);J$3;"")

    se non funzionasse e basta, OK: invece funziona solo sulla prima riga e le successive no. Perché??
    mi aiutate a farla funzionare su tutte le righe?
    Grazie infinite

    Luigi
    File Allegati File Allegati

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204

    Re: codificazione e ricodificazione

    Ciao,

    potresti servirti di una serie di conta.se per asciugare la formula:

    =SE(CONTA.SE(F$5:F$15;C5);F$3;)&SE(CONTA.SE(G$5:G$15;C5);G$3;)&SE(CONTA.SE(H$5:H$15;C5);H$3;)&SE(CONTA.SE(I$5:I$15;C5);I$3;)&SE(CONTA.SE(J$5:J$15;C5);J$3;)

    E' un ragionamento simile a quello da te condiviso.

    Spero sia d'aiuto

  3. #3
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    784
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    319
    Likes dati
    1

    Re: codificazione e ricodificazione

    Buon Giorno

    foglio formula contratta

    d5=SE(O($C7=F$5:F$15);F$3;)&SE(O($C7=G$5:G$15);G$3;)&SE(O($C7=H$5:H$15);H$3;)&SE(O($C7=I$5:I$15);I$3;)&SE(O($C7=J$5:J$15);J$3;"")

    control+shift +enter copia in basso

    Saluti
    Window 8.1 Excel 2013/2016

  4. I seguenti 2 utenti hanno dato un "Like" a Pitagora per questo post:


  5. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204

    Re: codificazione e ricodificazione

    Ottimo Pitagora! la formula matriciale rispetta ancora di più il lavoro proposto da Luiperre

    Saluti da Firenze

    Stefano

  6. #5
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2082
    Versione Office
    2016
    Likes ricevuti
    554
    Likes dati
    119

    Re: codificazione e ricodificazione

    Ciao

    Codice: 
    d5=SE(O($C7=F$5:F$15);F$3;)&SE(O($C7=G$5:G$15);G$3;)&SE(O($C7=H$5:H$15);H$3;)&SE(O($C7=I$5:I$15);I$3;)&SE(O($C7=J$5:J$15);J$3;"")
    perfetta
    solo una precisazione
    in D5 va cambiato $C7 con $C5 e

    Codice: 
    =SE(C5<>"";SE(O($C5=F$5:F$15);F$3;)&SE(O($C5=G$5:G$15);G$3;)&SE(O($C5=H$5:H$15);H$3;)&SE(O($C5=I$5:I$15);I$3;)&SE(O($C5=J$5:J$15);J$3;"");"")
    per non avere riscontri se ci sono celle in C vuote

    mai si sa che uno non se ne accorga:227:

  7. #6
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    784
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    319
    Likes dati
    1

    Re: codificazione e ricodificazione

    Ciao Stefano

    Saluti da Milano

    Ferdinando
    Window 8.1 Excel 2013/2016

  8. #7
    L'avatar di luiperre
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    trieste
    Messaggi
    2
    Versione Office
    Office365
    Likes ricevuti
    0
    Likes dati
    0

    Re: codificazione e ricodificazione

    grazie a tutti per la vostra cortese partecipazione
    ho risolto con =SE(MATR.SOMMA.PRODOTTO(--($C5=F$5:F$25));$F$3;"")&SE... ma sperimenterò anche i vostri suggerimenti
    non credo che sarò mai in grado di esservi utile invece son sicuro che ricorrerò ancora alla vostra perizia
    ciao e grazie ancora

    Luigi

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •