Risultati da 1 a 3 di 3

Discussione: Modificare riferimenti a file e foglio in una formula



  1. #1
    L'avatar di Sbarba
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Messaggi
    7
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    0

    Modificare riferimenti a file e foglio in una formula

    Buongiorno a tutti,

    questo è il mio primo messaggio sul forum. Sto seguendo i tutorial di Gerardo su Youtube, trovandoli davvero molto utili, e così sono arrivato qui.


    Il mio quesito riguarda la possibilità di modificare i riferimenti a file e fogli in una formula, inserendo tali valori in una cella di testo.

    Ad esempio, in una formula =CERCA.VERT(B5;'[File1.xlsx]Foglio1'!B2:D45;3;FALSO)

    vorrei poter modificare il file (File1.xlsx, File2.xlsx ecc) e i fogli (Foglio1, Foglio2) ecc in cui far compiere la ricerca, inserendo i valori in una cella. Cioè che al posto di [File1.xlsx] mi prenda il nome che c'è nella cella C5, ad esempio, e al posto di Foglio1! quello che c'è nella cella C6.

    Sono riuscito, attraverso l'aiuto di utenti più esperti di me, ad ottenere quanto desiderato attraverso la funzione INDIRETTO, che però non funziona su file chiusi.

    =CERCA.VERT(B5;INDIRETTO("'["&C5&"]"&C6"'!B5:D45");3;FALSO)

    dove in B5 c'è il valore da cercare, in C5 il nome del file (Prova2.xlsx) e in C6 il nome del foglio (Foglio2)


    C'è una soluzione alternativa, che mi permetta di far funzionare la formula senza dover aprire i file?

    Specifico che, purtroppo, non so usare le macro.


    Grazie in anticipo

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199
    Ciao,

    se usi INDIRETTO non è possibile.

    In rete trovi un'aggiunta (addin) chiamata morefunc

    http://www.download.com/Morefunc/300...-10423159.html

    Morefunc rende disponibili fra le funzioni INDIRECT.EXT che legge anche i file chiusi.

    Su Excel 2007 non ho avuto problemi a far funzionare il tutto, sulle versioni successive ho avuto meno fortuna.

    Forse è d'aiuto

  3. #3
    L'avatar di Sbarba
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Messaggi
    7
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    0
    Grazie per la risposta, Canapone. Proverò :)

Discussioni Simili

  1. Copia Incolla su altro file senza portare i riferimenti del vecchio File
    Di CarloM nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 05/02/17, 18:36
  2. [Risolto] Modificare file excel
    Di SerialKiller nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 19/01/17, 11:08
  3. [Risolto] Sostituire i riferimenti cella ai nome delle variabili in una formula
    Di Trial4life nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 28/12/16, 18:34
  4. [Risolto] Rendere riferimenti file dinamici
    Di G.Bove nel forum Domande su Excel VBA e MACRO
    Risposte: 4
    Ultimo Messaggio: 20/12/16, 17:43
  5. Formula per moltiplicazione con riferimenti cella dinamici
    Di Lety88 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 25/04/16, 11:17

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •