Risultati da 1 a 3 di 3

Discussione: funzioni INDICE-CONFRONTA-GRANDE insieme



  1. #1
    L'avatar di Davide
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Rimini
    Messaggi
    10
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    funzioni INDICE-CONFRONTA-GRANDE insieme

    ciao a tutti,
    ho questo tipo di problema:

    foglio2: da C3 a Z3 ho una serie di nomi
    e sotto da C10 a Z10 ho una serie di numeri

    Nel foglio1 ho queste formule:

    nella cella C10 =GRANDE(FOGLIO2!C10:Z10;1)
    nella cella E10 =GRANDE(FOGLIO2!C10:Z10;2)
    nella cella G10 =GRANDE(FOGLIO2!C10:Z10;3)

    e fin qui tutto bene.
    però vorrei che nel foglio1 mi trova anche quale nome corrisponde il grande1, il grande2, il grande3.
    come posso fare? ho provato ad utilizzare queste formule:

    =INDICE(FOGLIO2!C3:Z3;CONFRONTA(GRANDE(FOGLIO2!C10:Z10;1);FOGLIO2!C10:Z10;0))
    =INDICE(FOGLIO2!C3:Z3;CONFRONTA(GRANDE(FOGLIO2!C10:Z10;2);FOGLIO2!C10:Z10;0))
    =INDICE(FOGLIO2!C3:Z3;CONFRONTA(GRANDE(FOGLIO2!C10:Z10;3);FOGLIO2!C10:Z10;0))

    il problema è che se ad esempio il grande1 è uguale a grande2, con queste formule mi trova solo il 1° valore.
    Immagino dovrei utilizzare il rif.colonne, però non sono riuscito a fare una formula che funzioni.
    allego il file.

    Qualcuno può aiutarmi?
    grazie in anticipo.
    Davide
    File Allegati File Allegati

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204

    Re: funzioni INDICE-CONFRONTA-GRANDE insieme

    Ciao,


    in D10, da copiare poi alla destra degli altri due risultati


    Codice: 
    =INDICE(FOGLIO2!$C3:$Z3;AGGREGA(15;6;RIF.COLONNA($C:$Z)-2/(FOGLIO2!$C10:$Z10=C10);CONTA.SE($C10:C10;C10)))

    Allego il file.



    Excel 2010 32 bit

    C
    D
    E
    F
    G
    H
    5
    6
    7
    8
    9
    GRANDE1
    GRANDE2
    GRANDE3
    10
    20
    X.6
    20
    X.8
    13
    X.5
    11
    DOVREBBE ESSERE X.8
    12
    Sheet: FOGLIO1


    Saluti
    File Allegati File Allegati
    • Tipo File: xlsx XXX.xlsx (15.0 KB, 23 Visualizzazioni)

  3. #3
    L'avatar di Davide
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Rimini
    Messaggi
    10
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: funzioni INDICE-CONFRONTA-GRANDE insieme

    è perfetto così! funziona benissimo!

    grazie mille
    ciao
    davide

Discussioni Simili

  1. [Risolto] problema errore #NUM con le funzioni di CONFRONTA e GRANDE
    Di davide574 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 15/12/16, 21:23
  2. [Risolto] ordine alfabetico dopo le funzioni Indice e Confronta
    Di vittorio dit nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 17/11/16, 12:40
  3. Indice e confronta co SE(E(O(rif,rig(rrf.col))))
    Di Amerigo nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 21/09/16, 00:21
  4. INDICE/CONFRONTA/GRANDE con valori uguali
    Di MattoMar nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 02/07/16, 22:55
  5. Indice confronta con risultati multipli
    Di yari1 nel forum Domande su Excel VBA e MACRO
    Risposte: 18
    Ultimo Messaggio: 07/04/16, 12:50

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •