Risultati da 1 a 10 di 10

Discussione: Quiz # - Ordinare libri



  1. #1

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7125
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1298

    Quiz # - Ordinare libri

    Nella colonna B ho inseriti dei libri (titolo in alto e autore in basso). Ho bisogno una formula nelle colonne D ed E che mi ordini in senso orizzontale i titoli e i relativi autori nella colonna, coma da figura.


    Allego file: https://www.dropbox.com/s/0rgmwl7jvz...ibri.xlsx?dl=0

  2. #2
    L'avatar di Khan
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Padova
    Messaggi
    55
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    1
    In D1
    =SE.ERRORE(INDICE($A$1:$A$18;RIF.RIGA()*2-1);"")

    In E1
    =SE.ERRORE(INDICE($A$1:$A$18;RIF.RIGA()*2);"")
    The saddest aspect of life right now is that science gathers knowledge faster than society gathers wisdom. - Isaac Asimov

    Windows 10 + Excel 2013

  3. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao a tutti
    una piccola variante con la funzione SCARTO, che grazie a ninai mi sta entrando in testa

    in D1:

    =SE.ERRORE(SCARTO($B$1;RIF.RIGA()*2-2;;;);"")




    in E1:

    =SE.ERRORE(SCARTO($B$1;RIF.RIGA()*2-1;;;);"")

    L'unico problema che non sono riuscito a risolvere è che se accidentalmente inserissimo una riga in alto la formula non funziona, se qualcuno ha qualche suggerimento per risolvere il problema
    Ciao a tutti

  4. #4
    L'avatar di Khan
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Padova
    Messaggi
    55
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    1
    Citazione Originariamente Scritto da Khan Visualizza Messaggio
    In D1
    =SE.ERRORE(INDICE($A$1:$A$18;RIF.RIGA()*2-1);"")

    In E1
    =SE.ERRORE(INDICE($A$1:$A$18;RIF.RIGA()*2);"")
    Naturalmente il riferimento della colonna è B e credo sia intuitivo trascinare in basso
    The saddest aspect of life right now is that science gathers knowledge faster than society gathers wisdom. - Isaac Asimov

    Windows 10 + Excel 2013

  5. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7125
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1298
    Citazione Originariamente Scritto da Khan Visualizza Messaggio
    Naturalmente il riferimento della colonna è B e credo sia intuitivo trascinare in basso
    @Khan: ottima!!! E' quella che ho usato io.

  6. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7125
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1298
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Ciao a tutti
    una piccola variante con la funzione SCARTO, che grazie a ninai mi sta entrando in testa

    in D1:

    =SE.ERRORE(SCARTO($B$1;RIF.RIGA()*2-2;;;);"")




    in E1:

    =SE.ERRORE(SCARTO($B$1;RIF.RIGA()*2-1;;;);"")

    L'unico problema che non sono riuscito a risolvere è che se accidentalmente inserissimo una riga in alto la formula non funziona, se qualcuno ha qualche suggerimento per risolvere il problema
    Ciao a tutti
    @Gerardo: Ottima anche questa ... che non conoscevo!
    Per il fatto che non funziona quando si aggiunge una riga in alto non saprei dirti, può essere che le righe pari diventano dispari e viceversa?

  7. #7

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7125
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1298
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    ...
    L'unico problema che non sono riuscito a risolvere è che se accidentalmente inserissimo una riga in alto la formula non funziona, se qualcuno ha qualche suggerimento per risolvere il problema
    ...
    Forse ho capito il motivo perché non funziona, può essere perché cambia il valore della riga =SE.ERRORE(SCARTO($B$1;RIF.RIGA()*2-2;;;);"") , si può risolvere se al posto di RIF.RIGA() si usa RIGHE($E$1:E1)

  8. #8
    L'avatar di Khan
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Padova
    Messaggi
    55
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    1
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Ciao a tutti
    una piccola variante con la funzione SCARTO, che grazie a ninai mi sta entrando in testa

    in D1:

    =SE.ERRORE(SCARTO($B$1;RIF.RIGA()*2-2;;;);"")




    in E1:

    =SE.ERRORE(SCARTO($B$1;RIF.RIGA()*2-1;;;);"")

    L'unico problema che non sono riuscito a risolvere è che se accidentalmente inserissimo una riga in alto la formula non funziona, se qualcuno ha qualche suggerimento per risolvere il problema
    Ciao a tutti
    Ciao Gerardo,
    le tue formule sono innanzitutto ottimizzabili.
    =SCARTO($B$1;RIF.RIGA()*2-2;;;)
    =SCARTO($B$1;RIF.RIGA()*2-1;;;)
    Nel caso di inserimento di una riga in alto:
    =SCARTO($B$1;RIGHE(B$1:B1)*2-2;;;)
    =SCARTO($B$1;RIGHE(B$1:B1)*2-1;;;)
    Stesso discorso per le mie formule.
    Ancora un’altra cosa. Quando trascini in basso vedi inveceche degli spazi vuoti, come ti aspetti, dei fastidiosi “zero”. Vai in File >Opzioni > Impostazioni avanzate e togli la spunta in Visualizza zero nellecelle con valore zero.
    Devi comunque tener conto che la formula SCARTO è volatile.
    The saddest aspect of life right now is that science gathers knowledge faster than society gathers wisdom. - Isaac Asimov

    Windows 10 + Excel 2013

  9. #9
    L'avatar di Khan
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Padova
    Messaggi
    55
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    1
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    @Khan: ottima!!! E' quella che ho usato io.
    Ti ringrazio per il riscontro.

    Buona notte
    The saddest aspect of life right now is that science gathers knowledge faster than society gathers wisdom. - Isaac Asimov

    Windows 10 + Excel 2013

  10. #10
    L'avatar di Luigi Paravan
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Arquata Scrivia
    Età
    62
    Messaggi
    46
    Versione Office
    2011 MAC
    Likes ricevuti
    0
    Likes dati
    0
    Buona giornata, un altro modo per non visualizzare gli zeri
    Codice: 
    =SE.ERRORE(SE(INDICE($B$1:$B$19;RIGHE(B$1:B1)*2)<>0;INDICE($B$1:$B$19;RIGHE(B$1:B1)*2);"");"")
    e se un burlone inserisce un riga non in alto ma nel mezzo?
    Ultima modifica fatta da:Luigi Paravan; 26/07/15 alle 10:00

Discussioni Simili

  1. Gestione Libri versione 3
    Di Rudolfet nel forum Domande su Excel VBA e MACRO
    Risposte: 4
    Ultimo Messaggio: 06/01/17, 23:07
  2. Libri excel
    Di AleVozza nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 04/01/17, 17:02
  3. Gestione Libri
    Di Rudolfet nel forum Domande su Excel VBA e MACRO
    Risposte: 14
    Ultimo Messaggio: 05/10/16, 12:19
  4. [Risolto] Gestione Libri
    Di Rudolfet nel forum Domande su Microsoft Access
    Risposte: 14
    Ultimo Messaggio: 05/10/16, 12:19
  5. Libri per Excel
    Di Mikelius nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 02/03/16, 14:18

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •