Risultati da 1 a 17 di 17

Discussione: Riepilogo da men¨ a tendina



  1. #1
    L'avatar di Silvio65
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Milano
    Messaggi
    134
    Versione Office
    2013 WIN
    Likes ricevuti
    9
    Likes dati
    28

    Riepilogo da men¨ a tendina

    Buongiorno a tutti,
    sono nuovamente a chiedere un aiuto.
    In un foglio ho i risultati di un campionato di calcio (calendario), mentre nell'altro foglio (riepilogo)
    vorrei estrarre il riepilogo delle partite coi relativi risultati, della squadra inserita in F2 (da menu' a tendina).

    Ringraziando in anticipo, porgo i miei pi¨ cordiali saluti a tutti.

    Silvio65
    File Allegati File Allegati

  2. #2
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    LocalitÓ
    Latina
    EtÓ
    62
    Messaggi
    2290
    Versione Office
    Excel 2010
    Likes ricevuti
    909
    Likes dati
    450

    Re: Riepilogo da men¨ a tendina

    Ciao Silvio
    Dunque spiego brevemente il lavoro:
    Dopo aver creato il menu a tendina per selezionare le squadre da verificare non sto a spiegare come si crea un menu a tendina penso sia superfluo, ti elenco le formule inserite nel foglio Riepilogo
    Lasciando la giornata da inserire manualmente in colonna data:
    =SE.ERRORE(INDICE(Calendario!$C$5:$C$74;CONFRONTA(B5&$F$2;INDICE(Calendario!$B$5:$B$74&Calendario!$E$5:$E$74;0);0));INDICE(Calendario!$C$5:$C$74;CONFRONTA(B5&$F$2;INDICE(Calendario!$B$5:$B$74&Calendario!$F$5:$F$74;0);0)))
    In colonna ora:
    =SE.ERRORE(INDICE(Calendario!$D$5:$D$74;CONFRONTA(B5&$F$2;INDICE(Calendario!$B$5:$B$74&Calendario!$E$5:$E$74;0);0));INDICE(Calendario!$D$5:$D$74;CONFRONTA(B5&$F$2;INDICE(Calendario!$B$5:$B$74&Calendario!$F$5:$F$74;0);0)))

    In colonna casa/fuori:
    =SE(VAL.NON.DISP(INDICE(Calendario!$E$5:$E$74;CONFRONTA(B5&$F$2;INDICE(Calendario!$B$5:$B$74&Calendario!$E$5:$E$74;0);0)));"";"a")

    In colonna squadra avversaria:
    =SE.ERRORE(INDICE(Calendario!$F$5:$F$74;CONFRONTA(B5&$F$2;INDICE(Calendario!$B$5:$B$74&Calendario!$E$5:$E$74;0);0));INDICE(Calendario!$E$5:$E$74;CONFRONTA(B5&$F$2;INDICE(Calendario!$B$5:$B$74&Calendario!$F$5:$F$74;0);0)))

    In colonna esito:

    =SE(H5="-";"da giocare";SE(E(E5="a";SINISTRA(H5;1)>DESTRA(H5;1));"Vinta";SE(E(E5="";SINISTRA(H5;1)<DESTRA(H5;1));"Vinta";SE(E(E5="";SINISTRA(H5;1)<DESTRA(H5;1));"Persa";SE(E(E5="";SINISTRA(H5;1)>DESTRA(H5;1));"Persa";SE(E(E5="a";SINISTRA(H5;1)<DESTRA(H5;1));"Persa";SE(SINISTRA(H5;1)=DESTRA(H5;1);"Pareggiata")))))))

    Infine in colonna esito:
    =SE.ERRORE(INDICE(Calendario!$G$5:$G$74;CONFRONTA(B5&$F$2;INDICE(Calendario!$B$5:$B$74&Calendario!$E$5:$E$74;0);0));INDICE(Calendario!$G$5:$G$74;CONFRONTA(B5&$F$2;INDICE(Calendario!$B$5:$B$74&Calendario!$F$5:$F$74;0);0)))&"-"&SE.ERRORE(INDICE(Calendario!$H$5:$H$74;CONFRONTA(B5&$F$2;INDICE(Calendario!$B$5:$B$74&Calendario!$E$5:$E$74;0);0));INDICE(Calendario!$H$5:$H$74;CONFRONTA(B5&$F$2;INDICE(Calendario!$B$5:$B$74&Calendario!$F$5:$F$74;0);0)))

    d
    etto tra noi con questi "mostri" di formule e vba che ci sono nel forum di sicuro le formule le tagliano di metÓ ma io mi accontento del risultato.
    Vedi il file


    File Allegati File Allegati

  3. I seguenti 3 utenti hanno dato un "Like" a Berna11 per questo post:


  4. #3
    L'avatar di Silvio65
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Milano
    Messaggi
    134
    Versione Office
    2013 WIN
    Likes ricevuti
    9
    Likes dati
    28

    Re: Riepilogo da men¨ a tendina

    Grazie mille Berna,
    sembra funzionare tutto alla perfezione.
    Hai ragione, qui ci sono dei veri e propri mostri, ma giustamente come dici te, l'importante Ŕ il risultato.
    Ancora grazie, e buona serata

  5. #4
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    LocalitÓ
    Latina
    EtÓ
    62
    Messaggi
    2290
    Versione Office
    Excel 2010
    Likes ricevuti
    909
    Likes dati
    450

    Re: Riepilogo da men¨ a tendina

    Ciao Silvio, grazie a te del cortese riscontro.
    Alla prossima ... :43:

  6. #5
    L'avatar di Silvio65
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Milano
    Messaggi
    134
    Versione Office
    2013 WIN
    Likes ricevuti
    9
    Likes dati
    28

    Re: Riepilogo da men¨ a tendina

    Il riscontro e i ringraziamenti sono doverosi.
    E' il rispetto per chi ci mette passione e aiuta a risolvere
    i problemi nel fantastico mondo di excel

  7. #6
    L'avatar di Silvio65
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Milano
    Messaggi
    134
    Versione Office
    2013 WIN
    Likes ricevuti
    9
    Likes dati
    28

    Re: Riepilogo da men¨ a tendina

    Ciao Berna, scusami se ti disturbo ancora.
    Guardando con attenzione la formula vedo che le partite giocate in casa della squadra selezionata in F2 vengono segnate con la lettera a
    mentre dovrebbero essere indicate con la lettera a le partite in trasferta.
    Ho provato a correggere la formula in E5 invertendo ;"";"a") con ;"a";"") ma cosý facendo mi si inverte il risultato, la sconfitta diventa vittoria e viceversa.
    Dove devo effettuare la correzzione in modo che la partita in trasferta venga indicata con a ?
    Inoltre un un'ultima "finezza" se possibile, nella colonna H4 risultato Ŕ possibile evidenziare la vittoria sempre con il numero maggiore dei gol sempre prima di quello minore ?
    Mi spiego meglio, vittoria in casa 2-1 vittoria fuori casa 3,1 (vorrei che venisse indicato 2-1 3-1 e non 2-1 1-3).
    Sperando di essere stato chiaro, ringrazio nuovamente.

  8. #7
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    LocalitÓ
    Latina
    EtÓ
    62
    Messaggi
    2290
    Versione Office
    Excel 2010
    Likes ricevuti
    909
    Likes dati
    450

    Re: Riepilogo da men¨ a tendina

    Ciao Silvio, eccomi scusa per l'incomprensione...
    Veniamo alle correzioni la formula in E5 diventa (come hai corretto tu)

    =SE(VAL.NON.DISP(INDICE(Calendario!$E$5:$E$74;CONFRONTA(B5&$F$2;INDICE(Calendario!$B$5:$B$74&Calendario!$E$5:$E$74;0);0)));"a";"")

    In G5 diventa:

    =SE(H5="-";"da giocare";SE(SINISTRA(H5;1)=DESTRA(H5;1);"Pareggiata";SE(E(E5="";SINISTRA(H5;1)>DESTRA(H5;1));"Vinta";SE(E(E5="a";SINISTRA(H5;1)<DESTRA(H5;1));"Vinta";"Persa"))))

    l'ho sfoltita un pochino.

    Per quanto riguarda l'evidenziare il risultato 2-1,3-1
    non so se ho capito bene come sono attualmente rispecchiano il risultato della partita giocata o in casa o fuori.
    Nel caso la squadra scelta giochi fuori casa e finische 1-3 quindi vinta tu vorresti vedere il risultato 3-1 con esito sempre vinta?





  9. #8
    L'avatar di Silvio65
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Milano
    Messaggi
    134
    Versione Office
    2013 WIN
    Likes ricevuti
    9
    Likes dati
    28

    Re: Riepilogo da men¨ a tendina

    innanzitutto ti ringrazio,
    adesso non riesco ad approntare le correzioni, ma sicuramente ha capito
    a cosa mi riferivo.
    Per quanto riguarda l'altro problema vorrei, sempre se possibile,
    che sia le vittorie in casa sia quelle fuori, venissero sempre evidenziate
    allo stesso modo 3-1 piuttosto che 2-1 piuttosto che 4-2,
    quindi col numero maggiore (gol) a sinistra.
    Stesso discorso al contrario per le sconfitte 1-3 1-2 2-4
    Grazie mille per la tua disponibilitÓ.

  10. #9
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    LocalitÓ
    Latina
    EtÓ
    62
    Messaggi
    2290
    Versione Office
    Excel 2010
    Likes ricevuti
    909
    Likes dati
    450

    Re: Riepilogo da men¨ a tendina

    Scusa Silvio una cortesia mi mandi il file e, scegliendo la squadra dal menu, indicami in colonna I come vorresti vedere il risultato.
    Sai c'Ŕ da considerare in casa e fuori casa vinte e perse e non vorrei prendere una cantonata.
    Altra cosa se dovesse servirmi una colonna di appoggio per fare ci˛ magari nascosta ti crea problemi?

  11. #10
    L'avatar di Silvio65
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Milano
    Messaggi
    134
    Versione Office
    2013 WIN
    Likes ricevuti
    9
    Likes dati
    28

    Re: Riepilogo da men¨ a tendina

    Di nuovo grazie,
    ti allego il file e nella colonna I ti ho indicato come vorrei vedere se possibile i risultati.
    Nessun problema per una eventuale colonna aggiuntiva.
    File Allegati File Allegati

  12. #11
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    LocalitÓ
    Latina
    EtÓ
    62
    Messaggi
    2290
    Versione Office
    Excel 2010
    Likes ricevuti
    909
    Likes dati
    450

    Re: Riepilogo da men¨ a tendina

    Ciao Silvio, ti rimando il file la formula l'ho inserita in colonna J per verificare il rispetto delle tue indicazioni.
    Ti ho nascosto la colonna H che Ŕ quella che riporta i risultati dal foglio calendario e che viene usata per determinare l'esito della partita, (pu˛ sempre servire) la colonna J quella per confrontare la formula la puoi eliminare.
    Questa Ŕ la formula:

    =SE(SINISTRA(H5;1)=DESTRA(H5;1);DESTRA(H5;1)&"-"&SINISTRA(H5;1);SE(E(E5="";SINISTRA(H5;1)>DESTRA(H5;1));SINISTRA(H5;1)&"-"&DESTRA(H5;1);SE(E(E5="";SINISTRA(H5;1)<DESTRA(H5;1));SINISTRA(H5;1)&"-"&DESTRA(H5;1);SE(E(E5="a";SINISTRA(H5;1)<DESTRA(H5;1));DESTRA(H5;1)&"-"&SINISTRA(H5;1);SE(E(E5="a";SINISTRA(H5;1)>DESTRA(H5;1));DESTRA(H5;1)&"-"&SINISTRA(H5;1))))))

    File Allegati File Allegati

  13. I seguenti utenti hanno dato un "Like"


  14. #12
    L'avatar di Silvio65
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Milano
    Messaggi
    134
    Versione Office
    2013 WIN
    Likes ricevuti
    9
    Likes dati
    28

    Re: Riepilogo da men¨ a tendina

    Ciao Berna,
    sembra funzionare tutto alla perfezione, mi hai proprio dato un grosso aiuto,
    e' proprio come lo volevo io.
    Grazie mille davvero.

  15. #13
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    LocalitÓ
    Latina
    EtÓ
    62
    Messaggi
    2290
    Versione Office
    Excel 2010
    Likes ricevuti
    909
    Likes dati
    450

    Re: Riepilogo da men¨ a tendina

    Ciao Silvio, intanto grazie a te del riscontro e dell'apprezzamento che mi hai dato.
    Potrebbe esserci un piccolo errore se il risultato dovesse superare la cifra singola e cioŔ dal 10 gol in avanti.
    Ma solo per l'ultima formula che hai chiesto quella di inversione del risultato.
    Cmq per evitare danni ho fatto una piccola modifica vedi se ti interessa testala altrimenti tieni pure l'altro file.
    Poi puoi segnare la discussione come RISOLTO.
    Alla prossima e buona domenica
    File Allegati File Allegati

  16. #14
    L'avatar di Silvio65
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Milano
    Messaggi
    134
    Versione Office
    2013 WIN
    Likes ricevuti
    9
    Likes dati
    28

    Re: Riepilogo da men¨ a tendina

    Di nuovo grazie Berna, per la tua precisione.
    Non avevo proprio tenuto conto del discorso dei 10 goal.
    Tester˛ anche il tuo ultimo lavoro, grazie e buona domenica anche a te e a tutto il forum.

  17. #15
    L'avatar di Silvio65
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Milano
    Messaggi
    134
    Versione Office
    2013 WIN
    Likes ricevuti
    9
    Likes dati
    28

    Re: Riepilogo da men¨ a tendina

    Ciao Berna,
    purtroppo ho visto che nel tuo ultimo file nella colonna G5 (esito) purtroppo c'Ŕ un errore.
    Se io inserisco un ipotetico 12-12 come risultato, non mi dÓ l'esito PAREGGIATA, ma mi dÓ o VINTA o PERSA a seconda di chi gioca in casa o meno.

    ----------Post unito in automatico----------

    Ho provato ad effettuare questa correzzione e sembra funzionare

    formula errata =SE(I5="-";"da giocare";SE(SINISTRA(I5;1)=DESTRA(I5;1);"Pareggiata";SE(E(E5="";SINISTRA(I5;1)>DESTRA(I5;1));"Vinta";SE(E(E5="a";SINISTRA(I5;1)<DESTRA(I5;1));"Vinta";"Persa"))))
    correzione effettuata '=SE(I5="-";"da giocare";SE(J5=K5;"Pareggiata";SE(E(E5="";SINISTRA(I5;1)>DESTRA(I5;1));"Vinta";SE(E(E5="a";SINISTRA(I5;1)<DESTRA(I5;1));"Vinta";"Persa"))))

    devo provare a testarla su tutte le partite

  18. #16
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    LocalitÓ
    Latina
    EtÓ
    62
    Messaggi
    2290
    Versione Office
    Excel 2010
    Likes ricevuti
    909
    Likes dati
    450

    Re: Riepilogo da men¨ a tendina

    Ciao Silvio, scusa ancora per la svista la nuova formula l'avevo giÓ fatta solo che nel file che ho inviato non l'avevo corretta.
    La correzione fatta da te pu˛ andar bene per il pareggio ma ti da esito diverso nel caso il risultato fosse ad esempio di 11-1 in quanto la formula legge solo un carattere o a destra o a sinistra della cella I5.


    La formula nuova da mettere in G5:
    =SE(I5="-";"da giocare";SE(J5=K5;"Pareggiata";SE(E(E5="";J5>K5);"Vinta";SE(E(E5="a";J5<K5);"Vinta";"Persa"))))

    Fai qualche test non si sa nmai e fai sapere grazie.


  19. #17
    L'avatar di Silvio65
    Clicca e Apri
    Data Registrazione
    Aug 2015
    LocalitÓ
    Milano
    Messaggi
    134
    Versione Office
    2013 WIN
    Likes ricevuti
    9
    Likes dati
    28

    Re: Riepilogo da men¨ a tendina

    Grazie Berna per la tua puntualitÓ.
    Sembra che adesso sia tutto totalmente perfetto.
    Lo testo e ti faccio sapere.

Discussioni Simili

  1. [Risolto] Men¨ a tendina
    Di Graale nel forum Domande su Excel in generale
    Risposte: 28
    Ultimo Messaggio: 06/03/17, 17:32
  2. [Risolto] Men¨ a tendina
    Di roky48 nel forum Domande su Excel in generale
    Risposte: 14
    Ultimo Messaggio: 03/11/16, 13:24
  3. [Risolto] Men¨ a tendina
    Di BRAZ66 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 11/09/16, 14:33
  4. Menu a tendina
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 13/11/15, 23:08
  5. Menu a tendina.
    Di GioGio nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 26/06/15, 18:52

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •