Risultati da 1 a 10 di 10

Discussione: Copiare formule da un altro foglio saltando le colonne



  1. #1
    L'avatar di rescassiste
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    genova
    Età
    37
    Messaggi
    7
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    0

    Copiare formule da un altro foglio saltando le colonne

    Ciao, ho un problema in merito ad un xls in fase di avanzamento...
    ho la seguente formula:
    =SE(Anna!G29=Anna!I29;(SOMMA(0;C5));0) - posizionata su C6

    Devo ricopiare questa formula sulle celle E6,G6,I6..ecc.. però a livello di formula deve avanzare G30/I30, G31/I31, G32/I32, ecc...

    Se faccio un semplice copia incolla salta da 29 a 31 a 33 a 35...quindi perdo i valori 30,32,34

    Spero in un vostro aiuto.

    Grazie tante.

  2. #2

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2809
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: Copiare formule da un altro foglio saltando le colonne

    se ho capito bene:
    C6=SE(INDIRETTO("Anna!G" &INT(RIF.COLONNA()/2)+28)=INDIRETTO("Anna!I"&INT(RIF.COLONNA()/2)+28);(SOMMA(0;C5));0)
    e ricopi in E6-G6-I6

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di rescassiste
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    genova
    Età
    37
    Messaggi
    7
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: Copiare formule da un altro foglio saltando le colonne

    Citazione Originariamente Scritto da Rubik72 Visualizza Messaggio
    se ho capito bene:
    C6=SE(INDIRETTO("Anna!G" &INT(RIF.COLONNA()/2)+28)=INDIRETTO("Anna!I"&INT(RIF.COLONNA()/2)+28);(SOMMA(0;C5));0)
    e ricopi in E6-G6-I6
    Perfetto...Grazie infinite...
    Ora però vorrei capire e conoscere meglio le funzioni indiretto e la logica della formula che hai scritto...:93:

  5. #4
    L'avatar di rescassiste
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    genova
    Età
    37
    Messaggi
    7
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: Copiare formule da un altro foglio saltando le colonne

    Citazione Originariamente Scritto da Rubik72 Visualizza Messaggio
    se ho capito bene:
    C6=SE(INDIRETTO("Anna!G" &INT(RIF.COLONNA()/2)+28)=INDIRETTO("Anna!I"&INT(RIF.COLONNA()/2)+28);(SOMMA(0;C5));0)
    e ricopi in E6-G6-I6
    Scusami, ancora un piccolo aiuto per capire.... Se dovessi fare la stessa formula in D6 e copiarla nelle celle F6-H6-I6

  6. #5

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2809
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: Copiare formule da un altro foglio saltando le colonne

    La funzione INDIRETTO restituisce il riferimento specificato da una stringa di testo.
    Esempio:
    in a1 scrivi "Pippo",
    in a2 scrivi A1,
    in A3 scrivi =INDIRETTO(A2)
    La funzione restituirà il riferimento alla cella scritta in a2 (cioè A1) (è più difficile da spiegare che da capire)
    Capito questo, fai delle prove per le celle D6 - F6 - H6 ecc.

  7. #6
    L'avatar di rescassiste
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    genova
    Età
    37
    Messaggi
    7
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    0

    Post Re: Copiare formule da un altro foglio saltando le colonne

    Citazione Originariamente Scritto da Rubik72 Visualizza Messaggio
    La funzione INDIRETTO restituisce il riferimento specificato da una stringa di testo.
    Esempio:
    in a1 scrivi "Pippo",
    in a2 scrivi A1,
    in A3 scrivi =INDIRETTO(A2)
    La funzione restituirà il riferimento alla cella scritta in a2 (cioè A1) (è più difficile da spiegare che da capire)
    Capito questo, fai delle prove per le celle D6 - F6 - H6 ecc.
    Ok chiaro...per la funzione Indiretto diciamo che ho capito la funzionalità, vorrei capire la logica dell'int. e del rif.colonna (quel +28??)

    Scusami lo stress...



    =SE(INDIRETTO("Anna!H" &INT(RIF.COLONNA()/2)+28)=INDIRETTO("Anna!J"&INT(RIF.COLONNA()/2)+28);(SOMMA(0;D5));0)

  8. #7

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2809
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: Copiare formule da un altro foglio saltando le colonne

    La funzione rif.colonna() restituisce il numero di colonna.
    La funzione INT() restituisce il numero intero.
    Visto che le celle di riferimento sono nelle righe 29, 31, 33, 35, basta sommare 28 al rif.colonna() ma siccome sono a celle alterne, bisogna usare la funzione INT(),
    infatti in C6 rif.colonna() restituisce 3,
    si divide per 2, risultato 1,5,
    intero di 1,5=1,
    si somma 28 e il risultato è 29.

    Lo stesso per E6, G6 ecc.

  9. #8
    L'avatar di rescassiste
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    genova
    Età
    37
    Messaggi
    7
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: Copiare formule da un altro foglio saltando le colonne

    Citazione Originariamente Scritto da Rubik72 Visualizza Messaggio
    La funzione rif.colonna() restituisce il numero di colonna.
    La funzione INT() restituisce il numero intero.
    Visto che le celle di riferimento sono nelle righe 29, 31, 33, 35, basta sommare 28 al rif.colonna() ma siccome sono a celle alterne, bisogna usare la funzione INT(),
    infatti in C6 rif.colonna() restituisce 3,
    si divide per 2, risultato 1,5,
    intero di 1,5=1,
    si somma 28 e il risultato è 29.

    Lo stesso per E6, G6 ecc.
    OK, capito...forse..
    Seguendo la logica se ho capito bene la formula nella cella D6 sarebbe questa:

    =SE(INDIRETTO("Anna!H" &INT(RIF.COLONNA()-3)+28)=INDIRETTO("Anna!J"&INT(RIF.COLONNA()-3)+28);(SOMMA(0;D5));0)

  10. #9
    L'avatar di rescassiste
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    genova
    Età
    37
    Messaggi
    7
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: Copiare formule da un altro foglio saltando le colonne

    Citazione Originariamente Scritto da Rubik72 Visualizza Messaggio
    La funzione rif.colonna() restituisce il numero di colonna.
    La funzione INT() restituisce il numero intero.
    Visto che le celle di riferimento sono nelle righe 29, 31, 33, 35, basta sommare 28 al rif.colonna() ma siccome sono a celle alterne, bisogna usare la funzione INT(),
    infatti in C6 rif.colonna() restituisce 3,
    si divide per 2, risultato 1,5,
    intero di 1,5=1,
    si somma 28 e il risultato è 29.

    Lo stesso per E6, G6 ecc.
    Scusami...rileggendo ciò che hai scritto..... la sequenza nel foglio Anna è 20-30-31-32..... mentre nel foglio
    della formula è qui dove devo copiare in colonne alternate...F6-H6-I6

    ----------Post unito in automatico----------

    Citazione Originariamente Scritto da rescassiste Visualizza Messaggio
    Scusami...rileggendo ciò che hai scritto..... la sequenza nel foglio Anna è 20-30-31-32..... mentre nel foglio
    della formula è qui dove devo copiare in colonne alternate...F6-H6-I6

    :167::167::167: Iuuuuhhhh ce l'ho fatta....scusami ho creato solo della confusione ma alla fine ci sono riuscito, grazie al tuo aiuto, ho capito la logica....grazie ancora tanto.

  11. #10

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2809
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: Copiare formule da un altro foglio saltando le colonne

    Se hai risolto il problema, segna questa discussione come "RISOLTO".
    Vai sul menù "Strumenti Discussione" (all'inizio del thread) e scegli la voce "Segna questo thread come risolto...".

Discussioni Simili

  1. Risposte: 14
    Ultimo Messaggio: 16/11/16, 20:36
  2. Risposte: 10
    Ultimo Messaggio: 08/11/16, 15:13
  3. copiare formule da un foglio ad altro
    Di Raffaele Esposito nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 16/08/16, 22:58
  4. Copiare colonne e accodarle in altro foglio
    Di milanetti nel forum Domande su Excel VBA e MACRO
    Risposte: 11
    Ultimo Messaggio: 02/08/16, 11:22
  5. Copiare dati celle in colonne altro foglio
    Di Cavier80 nel forum Domande su Excel VBA e MACRO
    Risposte: 11
    Ultimo Messaggio: 22/05/16, 22:29

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •