Risultati da 1 a 4 di 4

Discussione: Estrarre le intestazioni di campo e di riga di una tabella incrociata



  1. #1
    L'avatar di Carme2014
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Capaccio
    Messaggi
    12
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    Estrarre le intestazioni di campo e di riga di una tabella incrociata

    Ciao a tutti . Sono nuovo e non molto pratico di excel. Vorrei porre un quesito. In effetti ho questa tabella, i valori 10,73 - 8,45 - 8,08 - 7,25 - 6,96 - sono i primi 5 più grandi. Ciò che mi interessa é: vorrei che in M4 e N4 (tabella laterale piccola ),mi escano in automatico quei valori che corrisponde al numero 1 (C2) rossa nella riga orizzontale e al numero 1 nella col. verticale (A4) gialla. Quindi dinamici. E che nel caso in cui il valore piu grande fosse non 10,73, ma 8,45 , il valore in M4 e N4 deve essere il valore in D2 (2) e il valore in A4 (1). Quindi ciò che mi interessa è che la tabella piccola, Rossa e Giallia, dove io ho inserito i dati a mano, ( x intenderci) vorrei che cambi in funzione dei primi 5 + grandi e mi desse i risultati della riga(B2:H2) e colonna (A3:A9) che si trovano nella tabella grande. Spero di essere stato chiaro. Grazie.
    File Allegati File Allegati

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127

    Re: Scommesse calcio

    Ciao Benvenuto in forumexcel.it

    In M4 metti questa formula (da confermare con CTRL+SHIFT+ENTER) e copiala in basso

    =INDICE($B$2:$H$2;MIN(SE($B$3:$H$9=$K4;RIF.COLONNA($B$2:$H$2)-RIF.COLONNA($B$2)+1)))

    In N4 metti questa formula (da confermare con CTRL+SHIFT+ENTER) e copiala in basso

    =INDICE($A$3:$A$9;MIN(SE($B$3:$H$9=$K4;RIF.RIGA($A$3:$A$9)-RIF.RIGA($A$3)+1)))

    Ho cambiato il nome del campo nelle celle N3 e M3 cosi da essere piu chiaro

    Fammi sapere se va bene, ciao


    A
    B
    C
    D
    E
    F
    G
    H
    I
    J
    K
    L
    M
    N
    1
    2
    0
    1
    2
    3
    4
    5
    6
    3
    0
    5,34
    8,08
    6,26
    3,30
    1,23
    0,00
    0,00
    Intest. Colonna Intest. Riga
    4
    1
    6,96
    10,73
    8,45
    4,62
    1,20
    0,01
    0,00
    10,73
    1
    1
    5
    2
    4,64
    7,25
    6,74
    3,12
    1,54
    1,20
    0,50
    8,45
    2
    1
    6
    3
    2,12
    3,60
    2,78
    2,43
    1,22
    0,98
    0,57
    8,08
    1
    0
    7
    4
    0,75
    1,25
    2,50
    1,18
    1,10
    0,78
    0,25
    7,25
    1
    2
    8
    5
    0,22
    0,98
    0,78
    0,50
    0,57
    0,25
    0,00
    6,96
    0
    1
    9
    6
    0,00
    0,70
    0,60
    0,50
    0,40
    0,30
    0,20
    10
    Sheet: 1


    PS il titolo che hai messo non va bene perchè deve anticipare il problema, Adesso lo cambio io tu leggi il regolamento

    Regola nr.5 "il titolo"
    Assicurarti che il titolo sia il più chiaro possibile e che corrisponda al problema, usa termini appropriati che saranno usati come meta tag per una eventuale ricerca su Google.
    Evita di scrivere frasi inutili come “Aiuto” “Urgente ” “Non ci capisco niente” e "sono bloccato"
    perché potrebbero rivelarsi non appropriate e di conseguenza le tue discussioni potrebbero essere non lette.
    Ti consiglio di scrivere titoli che vanno dritto al problema esempio: "come faccio ad analizzare dati....." "come faccio ad estrarre records....." "come faccio a calcolare......." "come creare una TPivot......"
    I titoli ed i testi devono essere scritti in italiano corretto, sia grammaticamente che ortograficamente; postare frasi con errori evidenti è sempre una forma di NON rispetto per chi legge.

  3. I seguenti 2 utenti hanno dato un "Like" a Gerardo Zuccalà per questo post:


  4. #3
    L'avatar di Carme2014
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Capaccio
    Messaggi
    12
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: Scommesse calcio

    Grazie Gerardo, era quello che volevo, scusami per il titolo.

  5. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127

    Re: Scommesse calcio

    Citazione Originariamente Scritto da Carme2014 Visualizza Messaggio
    Grazie Gerardo, era quello che volevo, scusami per il titolo.
    Ciao Carme
    Grazie per il tuo riscontro positivo e se la tua domanda è stata risolta segna questa discussione come [RISOLTO]
    Vai nella barra dei menu, situata all’inizio di questa discussione, troverai il menu “Strumenti Discussione” quindi scegliere “Segna questo Thread come risolto”
    un salutoSaluto

Discussioni Simili

  1. …”Ricerca in una tabella incrociata” del lontano 07-07-15
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 26/01/16, 21:36
  2. modificare le intestazioni di colonna in riga
    Di vtedone nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 19/01/16, 16:21
  3. Formattazione condizionale per tabella incrociata 3 condizioni
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 21/08/15, 20:46
  4. Ricerca in una tabella incrociata
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 18
    Ultimo Messaggio: 12/07/15, 10:23
  5. quiz #9 Analisi dei dati 3 condizioni in una tabella incrociata
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 24/06/15, 01:26

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •