Risultati da 1 a 4 di 4

Discussione: Trasporre e Disporre i numeri in gruppi di 11



  1. #1
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342

    Smile Trasporre e Disporre i numeri in gruppi di 11

    Ciao a tutti
    In allegato troverete nella colonna A:A una serie di numeri che vorrei disporre in gruppi di 11 nella tabella che troverete a destra
    Nell'allegato vedrete che tutto molto intuitivo quello che voglio ottenere perchè ho già scritto il risultato a mano
    Ovviamente la mia idea è quella di avere una formula unica da scrivere in B2 e copiare a destra ed in basso
    ciao e Buon divertimento :43:

    PS un Saluto a ninai che lo vedo on-line che era qualche giorno che non lo vedevo
    Ultima modifica fatta da:Gerardo Zuccalà; 28/07/15 alle 22:07 Motivo: Allea
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    54
    Messaggi
    10112
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2587
    Likes dati
    1555
    Ciao a tutti

    =SE.ERRORE(INDICE($A$2:$A$202;(RIF.RIGA(A1)-1)*11+RIF.COLONNA(A1));"")

  3. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342
    Ciao Ges
    Ottima formula che funziona benissimo:98:,

    Però come al solito con le funzioni RIF.RIGA e RIF.COLONNA se accidentalmente si aggiunge una colonna o riga in alto la formula non funziona
    io ho provato questa formula che evita questo problema

    =SE.ERRORE(INDICE($A$2:$A$202;RIGHE($A$1:$A1)*11-11+COLONNE($A:A));"")

    e se qualcun'altro ha un'altra soluzione.. ben venga
    ciao a tutti
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  4. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    2143
    Versione Office
    2010 PC
    Likes ricevuti
    1183
    Likes dati
    239
    Ciao
    Usando lo stesso tuo algoritmo di trasposizione ma variando la funzione (giusto per diminuire l'usura della tastiera :188::188:):

    =SCARTO($A$2;(RIGHE($A$2:$A2)-1)*11-1+COLONNE($A:A);)

    oppure

    =INDIRETTO("A"&(RIGHE($A$2:$A2)-1)*11+COLONNE($A:B))

Discussioni Simili

  1. [EXCEL 2003] Trasporre due o più righe in una singola colonna
    Di AiaceT nel forum Domande su Excel VBA e MACRO
    Risposte: 16
    Ultimo Messaggio: 29/12/16, 23:21
  2. Unire cella importata da Excell e disporre testo in centro
    Di Paolerrai nel forum Domande sul Microsoft Word
    Risposte: 36
    Ultimo Messaggio: 18/12/16, 15:56
  3. [EXCEL 2003] Trasporre due o più righe in una singola colonna
    Di AiaceT nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 16/12/16, 05:31
  4. [Risolto] Aiuto trasporre dati da riga a colonna escludendone alcuni in maniera veloce.
    Di AlessiaM88 nel forum Domande su Excel in generale
    Risposte: 18
    Ultimo Messaggio: 07/12/16, 17:07
  5. (ricerca, confronta) disporre dati
    Di Manuel Rolando nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 22/10/15, 20:44

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •