Risultati da 1 a 5 di 5

Discussione: Come Incollare dati saltando una riga



  1. #1
    L'avatar di BettaGreg
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    italia
    Messaggi
    2
    Versione Office
    excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    Come Incollare dati saltando una riga

    Salve a tutti, scusate se non mi rivolgerò a voi con la migliore spiegazione possibile ma sono una neofita di questo forum e di excel in generale.

    Il mio problema, in soldoni, è molto semplice ma non riesco a trovare una formula che sia una soluzione veloce ed efficace.

    Nel foglio excel io ho una colonna con le misurazioni della temperatura rilevata ogni 15 minuti e una colonna con una umidità relativa misurata ogni 30 minuti.

    es:

    ora= 00:00 T=15°
    ora= 00:15 T=15°
    ora= 00:30 T=15°

    ora= 00:00 UR= 50%
    ora= 00:30 UR= 50%

    Io ora vorrei associare alle temperature le loro umidità relative, semplicemente affiancandole nella stessa riga. Così facendo praticamente dovrei avere una cella piena e una vuota nella colonna dell' umidità relativa.

    es:

    ora= 00:00 T=15° UR= 50%
    ora= 00:15 T=16° UR= ----
    ora= 00:30 T=17° UR= 55%

    come posso fare? considerando che sto gestendo circa 1000 dati non posso farlo "a mano" spostando i contenuti delle celle...
    avrei bisogno di qualche formula che me lo faccia automaticamente.

    N.B: non posso far saltare le temperature intermedie misurando solo ogni mezzora ma devo per forza lasciare il buco dove non ho la misura rilevata.

    grazie in anticipo per l'aiuto!

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7142
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: Come Incollare dati saltando una riga

    Ciao Betta,
    benvenuta, allega un file excel con l'esempio che hai scritto.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di BettaGreg
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    italia
    Messaggi
    2
    Versione Office
    excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: Come Incollare dati saltando una riga

    è solo un esempio di quello che devo fare ma spero ti aiuti a capire il mio problema
    File Allegati File Allegati

  4. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7142
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: Come Incollare dati saltando una riga

    Allora,
    se ho ben capito in K3 da trascinare in basso:

    =SE(VAL.PARI(RIF.RIGA());INDICE('dati T ext'!$N$30:$N$44;INT(RIF.RIGA(A2)/2));"")


    ----------Post unito in automatico----------

    Col vba è poi ancora più facile.

    Codice: 
    Sub alterne()
            x = 4
        For y = 30 To 100
                Sheets(1).Cells(x, 13) = Sheets(2).Cells(y, 14)
            x = x + 2
        Next
    End Sub
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  5. I seguenti utenti hanno dato un "Like"


  6. #5
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: Come Incollare dati saltando una riga

    Ciao a tutti, se ho capito bene, un'alternativa alla soluzione proposta da Ges, Che saluto, potrebbe essere la seguente:

    In K3:
    =SE.ERRORE(INDICE('dati T ext'!$N$30:$N$44;PICCOLO(SE('dati T ext'!$M$30:$M$44=SENSORI!I3;RIF.RIGA('dati T ext'!$M$30:$M$44)-RIF.RIGA('dati T ext'!$M$30)+1);1));"")
    da attivare premendo i tasti CTRL+MAIUSCOLO+INVIO, e poi tirare giù alla bisogna.
    Allego il file di prova, fa sapere se va bene.
    Buona notte.
    File Allegati File Allegati
    • Tipo File: xlsx UR.xlsx (15.4 KB, 5 Visualizzazioni)

  7. I seguenti utenti hanno dato un "Like"

    ges

Discussioni Simili

  1. Risposte: 19
    Ultimo Messaggio: 11/01/17, 19:50
  2. Risposte: 14
    Ultimo Messaggio: 16/11/16, 20:36
  3. Risposte: 10
    Ultimo Messaggio: 08/11/16, 15:13
  4. Excel 2007- Copiare dati da riga in riga con formula
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 14/01/16, 11:18
  5. copiare cella saltando una riga
    Di Raffaele Esposito nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 14/09/15, 21:42

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •