Risultati da 1 a 16 di 16

Discussione: Analizzare DataBase con piu condizioni



  1. #1
    L'avatar di Vincenzo Damiani
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Molfetta
    Età
    58
    Messaggi
    415
    Versione Office
    2010
    Likes ricevuti
    13
    Likes dati
    634

    Analizzare DataBase con piu condizioni

    Ciao a tutti,
    lo so c'è un caldo boia e io sono alle prese con alcune statistiche e ricerca dati....Vi chiedo, gentilmente, di dare un occhiata al file allegato dove è ben specificato quello che vorrei ottenere....:292:
    grazie


    https://drive.google.com/open?id=0B0...lNKREtoVm9YX3c

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    Il link mi da errore ....

  3. #3
    L'avatar di Vincenzo Damiani
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Molfetta
    Età
    58
    Messaggi
    415
    Versione Office
    2010
    Likes ricevuti
    13
    Likes dati
    634

  4. #4
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    779
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1
    Buona Sera Damiani.

    Allego tabella Pivot dei tuoi dati.

    Utilizzo le PIVOT per scopi uguali a tuoi

    Guarda il tutorial di Gerardo

    Saluti
    Window 8.1 Excel 2013/2016

  5. #5
    L'avatar di Vincenzo Damiani
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Molfetta
    Età
    58
    Messaggi
    415
    Versione Office
    2010
    Likes ricevuti
    13
    Likes dati
    634
    Ciao Pitagora,
    ti ringrazio per aver risposto, ma non è quello che cerco......vorrei avere tutto nel foglio statistiche con le formule...

  6. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao Vincenzo
    sto friggendo davanti allo schermo ma mi sto divertendo da matti

    Prima cosa importante ho usato lo strumento definsci nome cosi da dare un nome a tutti i campi del foglio "DataBase"
    questa è una cosa che consiglio sempre quando dobbiamo fare le formule per evitare di saltare da un foglio all'altro.

    poi ho fatto la mia prima formula che serve ad avre una lista unica dei clienti che tiene in considerazione 3 criteri, l'azienda+ la data iniziale + data finale

    in B9 formula matrice da attivare con CTRL+SHIFT+ENTER:

    =SE(RIGHE($B$9:B9)>$C$3;"";INDICE(Cliente;PICCOLO(SE(FREQUENZA(SE(Cliente<>"";SE(Azienda=$A$3;SE(Data>=$B$3;SE(Data<=$B$5;CONFRONTA(Cliente;Cliente;0)))));RIF.RIGA(Cliente)-RIF.RIGA(DataBase!$C$4)+1);RIF.RIGA(Cliente)-RIF.RIGA(DataBase!$C$4)+1);RIGHE($A$1:A1))))


    in C9 formula normale ENTER:

    =SE(RIGHE($B$9:B9)>$C$3;"";SOMMA.PIÙ.SE(Totale_Comm;Cliente;B9;Data;">="&$B$3;Data;"<="&$B$5))

    in E9 formula matrice da attivare con CTRL+SHIFT+ENTER:

    =SE(RIGHE($B$9:B9)>$F$3;"";(INDICE(Cliente;PICCOLO(SE(FREQUENZA(SE(Cliente<>"";SE(Azienda=$A$3;SE(Data>=$E$3;SE(Data<=$E$5;CONFRONTA(Cliente;Cliente;0)))));RIF.RIGA(Cliente)-RIF.RIGA(DataBase!$C$4)+1);RIF.RIGA(Cliente)-RIF.RIGA(DataBase!$C$4)+1);RIGHE($A$1:A1)))))

    in F9 formula normale ENTER:

    =SE(RIGHE($E$9:E9)>$F$3;"";SOMMA.PIÙ.SE(Totale_Comm;Cliente;E9;Data;">="&$E$3;Data;"<="&$E$5))

    :171: fammi sapere!


  7. #7
    L'avatar di Vincenzo Damiani
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Molfetta
    Età
    58
    Messaggi
    415
    Versione Office
    2010
    Likes ricevuti
    13
    Likes dati
    634
    Ciao Gerardo,
    chiedevo i valori in ordine di grandezza, dal più grande al più piccolo.....è possibile?

  8. #8
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Citazione Originariamente Scritto da Vincenzo Damiani Visualizza Messaggio
    Ciao Gerardo,
    chiedevo i valori in ordine di grandezza, dal più grande al più piccolo.....è possibile?
    Ciao
    Non so se sia possibile, perchè come faccio a sapere il valore più grande se non so ancora il cliente?
    comunque puoi fare una tabella aggiuntiva

    Fai questa formula per scoprire gli incassi dal più grande al più piccolo
    =SE.ERRORE(GRANDE($C$9:$C$18;RIGHE($B$22:B22));"")

    fai questa formula per assegnare al corrispondente incasso, il nome del cliente

    =INDICE($B$9:$B$18;CONFRONTA(B22;$C$9:$C$18;0))

    Ciao

    B
    C
    21
    fatturato A.C 2015 Elenco Clienti
    22
    € 31.409,00
    Cliente_H
    23
    € 15.502,00
    Cliente_K
    24
    € 5.739,00
    Cliente_x

  9. #9

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    Si può anche mettere:

    in C9 =SOMMA(SE((DataBase!$C$4:$C$53=stat_Azienda!$B$9);DataBase!$E$4:$E$53))

    in F9 =SOMMA(SE((DataBase!$C$54:$C$90=stat_Azienda!$B$9);DataBase!$E$54:$E$90))

    matriciali da attivare con CTRL+SHIFT+ENTER

  10. #10
    L'avatar di Vincenzo Damiani
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Molfetta
    Età
    58
    Messaggi
    415
    Versione Office
    2010
    Likes ricevuti
    13
    Likes dati
    634
    Ok Gerardo,
    A questo punto se non è possibile ordinare i dati direttamente seguirò il tuo consiglio, aggiungo un'altra tabella....
    Fatto questo rimane da stabilire la differenza in percentuale tra il cliente_x della colonna fatturato A.C 2015 e lo stesso cliente della colonna fatturato A.P 2014 (che dovrò cercarlo)
    come si può risolvere?
    grazie
    ciao Ges,
    il tuo suggerimento non mi torna......perché?

  11. #11

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    In che senso non ti torna?
    Volevo dire che al posto di queste formule usate da Gerardo (che funzionano benissimo)

    =SE(RIGHE($B$9:B9)>$C$3;"";SOMMA.PIÙ.SE(Totale_Comm;Cliente;B9;Data;">="&$B$3;Data;"<="&$B$5))

    =SE(RIGHE($E$9:E9)>$F$3;"";SOMMA.PIÙ.SE(Totale_Comm;Cliente;E9;Data;">="&$E$3;Data;"<="&$E$5))

    si possono usare le mie, che ho postato sopra.

    E' solo per conoscere altre strade per portare alla stessa soluzione.


  12. #12
    L'avatar di Vincenzo Damiani
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Molfetta
    Età
    58
    Messaggi
    415
    Versione Office
    2010
    Likes ricevuti
    13
    Likes dati
    634
    Se non erro,non tengono conto delle date che sono delle condizioni......
    Il risultato è diverso da quello che mi danno le formule di Gerardo, che tengono conto delle date...
    O sbaglio?

  13. #13

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    Mah .... ogni tanto litigo con questo excel 2016 .... comunque per maggior chiarezza allego il file https://www.dropbox.com/s/6b2vo4og0f...ioni.xlsm?dl=0

  14. #14
    L'avatar di Vincenzo Damiani
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Molfetta
    Età
    58
    Messaggi
    415
    Versione Office
    2010
    Likes ricevuti
    13
    Likes dati
    634
    Ciao Ges,
    ho visto il file che hai allegato...........Ma se metti le formule di Gerardo che fanno riferimento alle date segnate in b3/b5 e c3/c5 danno un risultato diverso che è quello che voglio sapere.....spero di essermi espresso bene.....

    Adesso rimane da stabilire la differenza in percentuale tra il cliente_x della colonna fatturato A.C 2015 e lo stesso cliente della colonna fatturato A.P 2014 (che dovrà cercarlo)
    come si può risolvere?
    Ultima modifica fatta da:Vincenzo Damiani; 31/07/15 alle 00:13

  15. #15
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Citazione Originariamente Scritto da Vincenzo Damiani Visualizza Messaggio
    Adesso rimane da stabilire la differenza in percentuale tra il cliente_x della colonna fatturato A.C 2015 e lo stesso cliente della colonna fatturato A.P 2014 (che dovrà cercarlo)
    come si può risolvere?
    Ciao Vincenzo
    per stabilire la differenza percentuale tra un valore iniziale e un valore finale è abbastanza semplice
    e si fa cosi (valore finale-valore iniziale)/valore iniziale... e fino qui tutto semplice
    pero ovviamente gli elementi devono essere uno vicino all'altro cosa che nel tuo prospetto i valori non sono corrispondenti uno all'altro.
    Vincenzo il problema non è trovare la una formula per per trovare il valor iniziale del clinete _x ma il vero problema far capire la logica del tuo prospetto
    perche nel 2015 ci sono solo 3 clienti e nel 2014 ci sono 5 clienti e i clienti non sono corrispondenti uno con l'altro
    per cui un prospetto con una logica sbagliata
    es. in D9 ho fatto questa formula che funziona bene che va a cercare nell'altra "anno" il cliente corrispondente
    =SE.ERRORE((C9-INDICE($F$9:$F$18;CONFRONTA(B9;$E$9:$E$18;0)))/INDICE($F$9:$F$18;CONFRONTA(B9;$E$9:$E$18;0));"")

    solo che chi legge questo prospetto non ci capisce niente perchè appunto una logica completamente sbagliata.
    anche in questo caso non devi essere dipendente dalla formula precedente.. ma devi fare un prospetto nuovo allineare i clienti uno a fianco dell''altro e poi calcoli la percentuale (valore finale-valore iniziale)/valore iniziale.
    fammi sapere!

  16. #16
    L'avatar di Vincenzo Damiani
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Molfetta
    Età
    58
    Messaggi
    415
    Versione Office
    2010
    Likes ricevuti
    13
    Likes dati
    634
    Ok
    Provo a seguire il tuo consiglio...
    Grazie
    Ultima modifica fatta da:Vincenzo Damiani; 31/07/15 alle 08:53

Discussioni Simili

  1. Creare automaticamente fogli excel da un database in base a condizioni specifiche
    Di luigi.simone nel forum Domande su Excel VBA e MACRO
    Risposte: 4
    Ultimo Messaggio: 30/07/16, 19:24
  2. [Risolto] Filtrare SALDI (da calcolare) in un database in base a più condizioni
    Di MarcoM nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 03/10/15, 09:48
  3. Analizzare database con valuta
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 20/08/15, 15:21
  4. Analizzare DataBase con piu condizioni
    Di Vincenzo Damiani nel forum Test dei vostri post
    Risposte: 0
    Ultimo Messaggio: 29/07/15, 22:26
  5. Analizzare database
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 24/07/15, 00:30

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •