Risultati da 1 a 8 di 8

Discussione: Pronostici risultati preoblema di formattazione



  1. #1
    L'avatar di Jabets
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    italia
    Età
    31
    Messaggi
    55
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    9

    Pronostici risultati preoblema di formattazione

    Buongiorno a tutti,
    scusate ma vorrei proporvi un altro quesito:
    C'è un modo tale per cui con la formattazione condizionale mi si evidenziano i risultati sul foglio "Pronostici Prima Giornata" confrontandoli con i risultati effettivi presenti sul foglio "Calendario" con tre colori diversi in base a questi parametri:

    Verde: Risultato esatto
    Giallo: Esito esatto
    Rosso: Risultato ed esito sbagliato

    ------------------------------

    http://www.forumexcel.it/forum/6-dom...tici-risultati
    Ultima modifica fatta da:Canapone; 17/06/16 alle 10:37 Motivo: messa in evidenza

  2. #2
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2294
    Versione Office
    Excel 2010
    Likes ricevuti
    910
    Likes dati
    451

    Re: Pronostici risultati preoblema di formattazione

    Ciao jabets, ho provato a fare qualcosa con la formattazione come richiesto.
    Ho cambiato da Prima giornata ad 1 ecc...
    e nel foglio Pronostici prima giornata ho usato delle colonne di appoggio per il confronto risultati e per la formattazione
    In cella L2 ho messo:
    =SE.ERRORE(SE(INDICE(Calendario!$I$6:$I$41;CONFRONTA(C2&H2;INDICE(Calendario!$A$6:$A$41&Calendario!$G$6:$G$41;0);0))="";"";SE(E(INDICE(Calendario!$I$6:$I$41;CONFRONTA(C2&H2;INDICE(Calendario!$A$6:$A$41&Calendario!$G$6:$G$41;0);0))=J2;INDICE(Calendario!$J$6:$J$41;CONFRONTA(C2&H2;INDICE(Calendario!$A$6:$A$41&Calendario!$G$6:$G$41;0);0))=K2);VERO;FALSO));"")

    In M2:
    =SE(L2="";"";SE.ERRORE(SE(E(INDICE(Calendario!$I$6:$I$41;CONFRONTA(C2&H2;INDICE(Calendario!$A$6:$A$41&Calendario!$G$6:$G$41;0);0))>INDICE(Calendario!$J$6:$J$41;CONFRONTA(C2&H2;INDICE(Calendario!$A$6:$A$41&Calendario!$G$6:$G$41;0);0));J2>K2);VERO;FALSO);""))

    In N2:
    =SE(L2="";"";SE.ERRORE(SE(E(INDICE(Calendario!$I$6:$I$41;CONFRONTA(C2&H2;INDICE(Calendario!$A$6:$A$41&Calendario!$G$6:$G$41;0);0))<INDICE(Calendario!$J$6:$J$41;CONFRONTA(C2&H2;INDICE(Calendario!$A$6:$A$41&Calendario!$G$6:$G$41;0);0));J2<K2);VERO;FALSO);""))

    ed in O2:
    =SE(L2="";"";SE.ERRORE(SE(E(INDICE(Calendario!$I$6:$I$41;CONFRONTA(C2&H2;INDICE(Calendario!$A$6:$A$41&Calendario!$G$6:$G$41;0);0))=INDICE(Calendario!$J$6:$J$41;CONFRONTA(C2&H2;INDICE(Calendario!$A$6:$A$41&Calendario!$G$6:$G$41;0);0));J2=K2);VERO;FALSO);""))

    Certamente si può accorciare di molto ma a quest'ora mi si stava intrecciando il cervello.



    File Allegati File Allegati

  3. I seguenti 5 utenti hanno dato un "Like" a Berna11 per questo post:


  4. #3
    L'avatar di Jabets
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    italia
    Età
    31
    Messaggi
    55
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    9

    Re: Pronostici risultati preoblema di formattazione

    Grazie Berna, nonostante l'ora e l'intreccio del cervello, le formule funzionano alla grande!
    Non mi è chiaro del perchè, se trascino le formule, non mi esce nulla..

  5. #4
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2294
    Versione Office
    Excel 2010
    Likes ricevuti
    910
    Likes dati
    451

    Re: Pronostici risultati preoblema di formattazione

    Ciao Jabets, ti ho detto che si erano intrecciati gli occhi.
    Dunque pensavo che nel foglio Pronostici prima giornata vi erano tutte le gare invece ora guardando bene ho visto che si tratta solo della prima giornata ripetuta più volte.
    Le formule sono già trascinate fino alla fine l'unica cosa che devi fare è quella di trascinare in colonna C il numero 1 fino alla fine e ti si colora il tutto.

    Spero sia quello che volevi.

  6. #5
    L'avatar di Jabets
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    italia
    Età
    31
    Messaggi
    55
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    9

    Re: Pronostici risultati preoblema di formattazione

    Assolutamente si, è perfettamente quello che cercavo.
    Però è troppo, troppo, troppo complicata per me.
    Non sono riuscito a capirla e neanche a riproporla, ma ciò non toglie che devo ringraziarti!

  7. #6
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2294
    Versione Office
    Excel 2010
    Likes ricevuti
    910
    Likes dati
    451

    Re: Pronostici risultati preoblema di formattazione

    Ma no... se leggi attentamente le formule sono comprensibili le ho divise per risultati.
    In colonna L ti dice se i risultati del calendario sono = a quelli del foglio foglio Pronostici p.g.
    Colonna M i risultati che in J sono >K
    colonna N i risultati che in J sono <K
    colonna O i risultati pari.
    Poi le altre colonne, a seconda delle combinazioni VERO/FALSO, (si potevano anche raggruppare per colore) servono per la scelta colori.

    Se hai dei dubbi chiedi pure.

  8. #7
    L'avatar di Jabets
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    italia
    Età
    31
    Messaggi
    55
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    9

    Re: Pronostici risultati preoblema di formattazione

    Ciao Berna, ho iniziato a capirla ed almeno sono riuscito a riportarla su un altro file con successo.
    Ti ringrazio ancora per la disponibilità ed il lavoro fatto!!

  9. #8
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2294
    Versione Office
    Excel 2010
    Likes ricevuti
    910
    Likes dati
    451

    Re: Pronostici risultati preoblema di formattazione

    Hai visto che con un pò d'impegno ci si riesce...
    Approfitto per ringraziare te e tutti gli altri che mi hanno dato il loro apprezzamento.

Discussioni Simili

  1. Allineamento risultati di macro
    Di svizzera nel forum Domande su Excel VBA e MACRO
    Risposte: 10
    Ultimo Messaggio: 14/03/17, 18:53
  2. [Risolto] Risultati Esatti
    Di BETWEB nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 07/01/17, 15:46
  3. Modifica foglio pronostici con Macro VBA
    Di giovannib nel forum Domande su Excel VBA e MACRO
    Risposte: 5
    Ultimo Messaggio: 19/09/16, 20:38
  4. [Risolto] Pronostici risultati
    Di Jabets nel forum Domande su Excel in generale
    Risposte: 23
    Ultimo Messaggio: 14/06/16, 22:25
  5. riepilogo di più pronostici giocati per sistema con doppie
    Di kroma nel forum Domande su Excel in generale
    Risposte: 14
    Ultimo Messaggio: 21/02/16, 18:27

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •