Risultati da 1 a 6 di 6

Discussione: variazione excel fino a valore predefinito



  1. #1
    L'avatar di gian91io
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    camparada
    Messaggi
    17
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    0

    variazione excel fino a valore predefinito

    Buon giorno ho un problema che forse sembrerà banale ho una serie di valori in colonna intervallati da zeri,il mio obiettivo è quello di calcolare la variazione percentuale di dati valori fin che non si incontra uno zero la numerosità dei valori cambia sempre e questo mi sta creando difficoltà
    spero possiate darmi un input per andare avanti vi ringrazio in anticipo :)
    Ultima modifica fatta da:Canapone; 17/06/16 alle 08:46

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: variazione excel fino a valore predefinito

    ciao
    credo tu debba fare degli esempi concreti ed esaustivi del calcolo che intendi fare, possibilmente in un file di esempio
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3
    L'avatar di gian91io
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    camparada
    Messaggi
    17
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: variazione excel fino a valore predefinito

    nel file caricato come esempio ho tagliato un pezzo di dataset e ho calcolato manualmente le variazioni dalla prima all ultima osservazione,volevo sapere se vi fosse un modo per automatizzare questo procedimento tenendo conto che la distanza tra le suddette osservazioni cambia sempre , l unica costante è che lo zero delimita l intervallo di variazione...
    File Allegati File Allegati

  4. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: variazione excel fino a valore predefinito

    ciao
    in base al tuo esempio, potrebbe essere, in D2:
    =SE.ERRORE(SE(B3=0;B2/INDICE($B$2:B2;CERCA(2;1/($B$2:B2=0);RIF.RIGA($B$2:B2)-RIF.RIGA($B$2)+2))-1;"");"")

    da trascinare in basso, ma probabilmente si può semplificare
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  5. I seguenti utenti hanno dato un "Like"


  6. #5
    L'avatar di gian91io
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    camparada
    Messaggi
    17
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    0

    Re: variazione excel fino a valore predefinito

    Ti ringrazio mi sei stato utilissimo

  7. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: variazione excel fino a valore predefinito

    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ciao
    in base al tuo esempio, potrebbe essere, in D2:
    =SE.ERRORE(SE(B3=0;B2/INDICE($B$2:B2;CERCA(2;1/($B$2:B2=0);RIF.RIGA($B$2:B2)-RIF.RIGA($B$2)+2))-1;"");"")

    da trascinare in basso, ma probabilmente si può semplificare
    Fantastico!

Discussioni Simili

  1. Auto aggiornamento dati fino a risultato voluto
    Di vrfabio nel forum Domande su Excel VBA e MACRO
    Risposte: 1
    Ultimo Messaggio: 12/10/16, 20:36
  2. [Risolto] Formula Somma riepilogativa da più fogli fino al mese corrente
    Di Berna11 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 13/09/16, 18:53
  3. aprire browser predefinito per visitare sito web
    Di JeS nel forum Domande su Excel VBA e MACRO
    Risposte: 10
    Ultimo Messaggio: 22/03/16, 10:59
  4. OT: link per aprire un sito con browser NON predefinito da Excel
    Di aldomattana nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 14/01/16, 19:59
  5. Excel 2010 correzione sulla variazione.
    Di Pacifico437 nel forum Domande su Excel VBA e MACRO
    Risposte: 12
    Ultimo Messaggio: 16/12/15, 23:13

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •