Risultati da 1 a 10 di 10

Discussione: SOMMA sotto diverse condizioni



  1. #1
    L'avatar di Zakkino
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cesena
    Età
    32
    Messaggi
    34
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    2

    SOMMA sotto diverse condizioni

    Ciao a tutti,

    avrei una domanda di approfondimento relativa al video EP31 FORMATTAZIONE CONDIZ di EXCEL IN PILLOLE di Gerardo.



    La domanda è questa:

    Se oltre ad avere le celle evidenziate con le due diverse condizioni (Mese e Marca), io volessi fare la SOMMA dei valori individuati dalla Formattazione condizionale come sarebbe cambiata la formula?

    Grazie
    Ultima modifica fatta da:cromagno; 17/06/16 alle 11:35 Motivo: Inserito correttamente link video...

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299

    Re: SOMMA sotto diverse condizioni

    Ciao,
    si può fare.

    Scaricandomi il file di Gerardo , che saluto, puoi usare la seguente formula:

    =SOMMA(INDICE($B$9:$B$18;CONFRONTA(A5;A9:A18;0)):INDICE($B$9:$K$18;CONFRONTA(A5;A9:A18;0);CONFRONTA(A6;$B$8:$K$8;0)))


    File Allegati File Allegati
    • Tipo File: xlsx 31.xlsx (29.8 KB, 13 Visualizzazioni)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. I seguenti 3 utenti hanno dato un "Like" a ges per questo post:


  4. #3
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202

    Re: SOMMA sotto diverse condizioni

    Ciao a tutti,

    sfrutto il file di Ges -un saluto - per una possibile alternativa: stessi risultati.

    =SOMMA(INDICE(B9:M12;CONFRONTA(A5;A9:A18;0);INDICE(MESE(B8:M8&0)<=MESE(A6&0);)))

    Sto usando SOMMA(INDICE invece di MATR.SOMMA.PRODOTTO...solo accorciare un po' la formula.

    Saluti

  5. I seguenti 2 utenti hanno dato un "Like" a Canapone per questo post:


  6. #4
    L'avatar di Zakkino
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cesena
    Età
    32
    Messaggi
    34
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    2

    Re: SOMMA sotto diverse condizioni

    Grazie Ges,

    l'unica cosa che non capisco/conosco è questa:

    =SOMMA(INDICE($B$9:$B$18;CONFRONTA(A5;A9:A18;0)):INDICE($B$9:$K$18;CONFRONTA(A5;A9:A18;0);CONFRONTA(A6;$B$8:$K$8;0)))

    Quei due punti che separano il primo step di indice confronta con il secondo..

    Ti ringrazio comunque ancora.

  7. #5
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202

    Re: SOMMA sotto diverse condizioni

    Ciao Zacchino,

    provo a rispondere alla domanda che hai fatto sulla formula di GES.

    Dalla risposta che hai condiviso sembra che tu sappia già usare INDICE(..CONFRONTA.

    E' importante sapere che INDICE con il suo lavoro non restituisce un valore o una stringa, ma il riferimento della cella individuata dai suoi parametri.

    Nel tuo caso per individuare la riga e la colonna giusta vengono usati dei CONFRONTA.

    Faccio un esempio.

    La formula

    =SOMMA(A1:INDICE(A1:A5;3))

    equivale a

    =SOMMA(A1:A3)

    A3 possiamo individuarlo usando INDICE(CONFRONTA o specificarlo come parametro dell'INDICE.

    Altro esempio il segmento

    INDICE(A1:C10;7;2)

    farebbe leggere alla formula B7. Settima riga e seconda colonna di A1:C10

    L'uso di INDICE può rappresentare una buona alternativa all'uso di INDIRETTO e SCARTO, che come funzioni volatili , se usate in quantità, costringono il povero foglio elettronico a rinnovare i calcoli in continuazione.

    Spero sia chiaro

  8. I seguenti utenti hanno dato un "Like"

    ges

  9. #6
    L'avatar di Zakkino
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cesena
    Età
    32
    Messaggi
    34
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    2

    Re: SOMMA sotto diverse condizioni

    Grazie Canapone,

    si mi è tutto molto più chiaro ora.

    Avrei una domanda sulla formula che invece hai proposto tu:

    =SOMMA(INDICE(B9:K18;CONFRONTA(A5;A9:A18;0);INDICE(MESE(B8:K8&0)<=MESE(A6&0);)))

    Quei &0 che si mettono subito dopo l'intervallo che funzione hanno?

    Comunque la formula che ho copiato e incollato nella stessa cella B20 del file originale, non mi funziona. Ho trasformato i mesi scritti in testo con delle date ma non funziona.

  10. #7
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202

    Re: SOMMA sotto diverse condizioni

    Ciao,

    prova a scrivere marzo in a1.

    =MESE(A1&0)

    restituisce 3.

    Se in B9:k8 trovo delle date, formattate - immagino- come "mmmm", &0 non serve per estrarre il numero del mese e va levato.

    =SOMMA(INDICE(B9:K18;CONFRONTA(A5;A9:A18;0);INDICE(MESE(B8:K8)<=MESE(A6);)))

    Saluti
    Ultima modifica fatta da:Canapone; 17/06/16 alle 14:22

  11. #8
    L'avatar di Zakkino
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cesena
    Età
    32
    Messaggi
    34
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    2

    Re: SOMMA sotto diverse condizioni

    Continua a non funzionare, mi prende solo la prima riga.

    Ti metto il file in allegato sotto così lavoriamo sullo stesso file.

    In ogni caso grazie mille per la disponibilità.

    Zakkino
    File Allegati File Allegati

  12. #9
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1661
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: SOMMA sotto diverse condizioni

    ciao
    alla luce di come hai strutturato e formattato i dati e volendo dare una soluzione "volatile":
    =SOMMA(SCARTO($A$9;CONFRONTA(A5;A9:A18;0)-1;1;;CONFRONTA(MESE(A6);MESE(B8:K8);0)))

    oppure, come piace a me:
    =MATR.SOMMA.PRODOTTO((A9:A18=A5)*(MESE(B8:K8)<=MESE(A6))*B9:K18)
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  13. I seguenti 2 utenti hanno dato un "Like" a ninai per questo post:


  14. #10
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202

    Re: SOMMA sotto diverse condizioni

    Ciao, dal telefonino vedo poco.

    Guardo piu' tardi da casa. Spero che nel frattempo intervenga qualche amico del Forum.

    ------------------


    @Zacchino: ho scritto una bischerata. La formula non funziona.

    Saluto Ges e Ninai
    Ultima modifica fatta da:Canapone; 17/06/16 alle 19:36

Discussioni Simili

  1. Eliminare righe sotto certe condizioni
    Di saturn87 nel forum Domande su Excel in generale
    Risposte: 14
    Ultimo Messaggio: 13/08/16, 14:19
  2. Matr. Somma Prodotto - Stessa matrice per matrici diverse
    Di danyk125 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 18/07/16, 01:01
  3. Calcolare data in presenza di diverse condizioni
    Di G.Bove nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 08/05/16, 07:18
  4. Ricerca valore all'interno di matrice sotto specifiche condizioni
    Di Zakkino nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 12/02/16, 18:08
  5. Ricerca valore max sotto diverse condizioni
    Di Zakkino nel forum Domande su Excel in generale
    Risposte: 33
    Ultimo Messaggio: 09/02/16, 20:37

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •