Risultati da 1 a 4 di 4

Discussione: Restituire un nome da una corrispondenza esatta in un elenco



  1. #1
    L'avatar di ale87
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Quistello
    Età
    39
    Messaggi
    48
    Versione Office
    2003
    Likes ricevuti
    0
    Likes dati
    0

    Restituire un nome da una corrispondenza esatta in un elenco

    Buon giorno ho un problema con una formula....devo RESTITUIRE UN NOME DA UNA CORRISPONDENZA ESATTA IN UN ELENCO

    -TROVARE UNA CORRISPONDENZA ESATTA IN UN ELENCO : =INDICE($A$2:$A$5;CONFRONTA(VERO;IDENTICO($C$2:$C$5;E5);0))

    E fin qua ci siamo..poi l'altra non mi funziona e non capisco dove sbaglio

    -RESTITUIRE UN NOME DA UNA CORRISPONDENZA ESATTA IN UN ELENCO : {=INDICE($A$2:$A$5;CONFRONTA(VERO;IDENTICO($C$2:$C$5;E5);0))}

    La seconda formula è l'evoluzione della prima...
    Allego il file in Excel.. non capisco dove sbaglio !!

    La formula che non va è nella cella F5 ( digitando il nome dovrebbe inserirmi automaticamente il cognome a fianco )
    File Allegati File Allegati

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4050
    Versione Office
    2013
    Likes ricevuti
    1240
    Likes dati
    931

    Re: Restituire un nome da una corrispondenza esatta in un elenco

    Ciao,
    stai sbagliando i range nella formula....
    Tu stavi cercando il valore della cella E5 nel range C2:C5, mentre dovresti cercarlo nel range A2:A5 e farti restituire il range C2:C5:

    =INDICE($C$2:$C$5;CONFRONTA(VERO;IDENTICO($A$2:$A$5;E5);0))
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. #3
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204

    Re: Restituire un nome da una corrispondenza esatta in un elenco

    Ciao

    nella formula stai cercando MARIO (E5) nella colonna C. Mario e nella colonna A

    =INDICE($A$2:$A$5;CONFRONTA(VERO;IDENTICO($C$2:$C$5;E5);0))

    altro aspetto da considerare: la formula messi a posto i riferimenti andrebbe immessa come matriciale.

    =INDICE($C$2:$C$5;CONFRONTA(VERO;IDENTICO($A$2:$A$5;E5);0))

    confermata con control+maiusc+invio per ottenere il cognome.

    Oppure usi un altro INDICE - questa volta zoppo per come mi piace descriverlo- per far leggere il vettore di risultati prodotti da IDENTICO al CONFRONTA.


    =INDICE($C$2:$C$5;CONFRONTA(VERO;INDICE(IDENTICO($A$2:$A$5;E5););0))

    Questa formula non ha bisogno del control+maiusc+invio

    Saluti

    ----------Post unito in automatico----------

    ciao Cromagno,

    scusa la sovrapposizione.

  4. #4
    L'avatar di ale87
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Quistello
    Età
    39
    Messaggi
    48
    Versione Office
    2003
    Likes ricevuti
    0
    Likes dati
    0

    Re: Restituire un nome da una corrispondenza esatta in un elenco

    Grazie a tutti e due !!! Caso risolto :)
    Grandissimo forum mi sta aiutando tantissimo !!
    Ringrazio tutti :)

Discussioni Simili

  1. [Risolto] Elenco con menu a discesa e ricerca contestuale digitando nella cella solo parte del nome
    Di Fabrizio1975 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 20/02/17, 20:24
  2. [Risolto] Corrispondenza esatta db.somma
    Di davidevr nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 19/01/17, 16:20
  3. Salvare file con nome .... da elenco
    Di Aurelio nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 13/09/16, 10:35
  4. Ricerca corrispondenza in un elenco
    Di simone90 nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 19/02/16, 07:24
  5. Corrispondenza cella
    Di claudiopsr nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 26/01/16, 14:38

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •