Risultati da 1 a 7 di 7

Discussione: Bug di Excel o Bug nella mia testa?



  1. #1
    L'avatar di Beppe
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Brescia
    Età
    37
    Messaggi
    78
    Versione Office
    2010 Win
    Likes ricevuti
    1

    Bug di Excel o Bug nella mia testa?

    Esercizio innocuo ed abbastanza inutile, solo per addentrarsi meglio nelle formule.
    nella tabella di destra sulla prima cella (J2) ho immesso la formula

    Codice: 
    =INDICE(B2;CONFRONTA($A2;$A$2:$A$11;0);CONFRONTA(B$1;$B$1:$G$1;0))
    il primo valore mi viene restituito normalmente, nelle altre celle errore #RIF! :185:

    A
    B
    C
    D
    E
    F
    G
    H
    I
    J
    K
    L
    M
    N
    O
    P
    1
    io tu egli noi voi essi io tu egli noi voi essi
    2
    01/07/2015
    43
    3
    60
    27
    76
    41
    01/07/2015
    43
    #RIF!
    #RIF!
    #RIF!
    #RIF!
    #RIF!
    3
    02/07/2015
    56
    82
    69
    94
    11
    34
    02/07/2015
    #RIF!
    #RIF!
    #RIF!
    #RIF!
    #RIF!
    #RIF!
    4
    03/07/2015
    30
    97
    73
    91
    11
    27
    03/07/2015
    #RIF!
    #RIF!
    #RIF!
    #RIF!
    #RIF!
    #RIF!


    Dove sbaglio?

    P.S. Se uso uma matrice con più celle ad esempio B2:B11,con le opportune modifiche, attivando la maniglia di riempimento la formula funziona correttamente..
    Ciao e grazie.


    Uso Excel 2010
    Ultima modifica fatta da:Canapone; 06/07/17 alle 10:13

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7159
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1300
    Da quel che vedo c'è un errore nell'impostazione della formula, come indice hai messo solo B2, invece dovresti includere tutta la matrice di riferimento, così:

    =INDICE($B$2:$G$11;CONFRONTA($A2;$A$2:$A$11;0);CONFRONTA(B$1;$B$1:$G$1;0))

  3. #3
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1678
    Versione Office
    2010 PC
    Likes ricevuti
    895
    Likes dati
    184
    Citazione Originariamente Scritto da Beppe Visualizza Messaggio
    Dove sbaglio?
    P.S. Se uso uma matrice con più celle ad esempio B2:B11,con le opportune modifiche, attivando la maniglia di riempimento la formula funziona correttamente...:93:
    ti sei QUASI risposto da solo, nel primo argomento di INDICE() va appunto la matrice dove andare ad estrarre il dato in base al numero di riga e/o colonna che vai successivamente ad identificare con i CONFRONTA().
    ricordati anche di mettere i riferimenti di cella assoluti ($B$2:$G$11).
    il primo, te lo restituisce perchè è l'unica cella presente nel tuo range (B2).

    Ciao Ges, non ti avevo letto......, CMQ c'è qualcosa di altro che non i convince nella formula........., oltre allo scopo
    Ultima modifica fatta da:ninai; 31/07/15 alle 13:17

  4. #4
    L'avatar di Beppe
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Brescia
    Età
    37
    Messaggi
    78
    Versione Office
    2010 Win
    Likes ricevuti
    1
    Ho messo apposta solo B2. Volevo vedere come si comportava la formula trascinandola in basso e a destra. Quel che è strano, è che se vai a controllare una cella a caso all'interno dell'intervallo, i riferimenti sono esatti.
    Ultima modifica fatta da:Canapone; 06/07/17 alle 10:13

  5. #5
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1678
    Versione Office
    2010 PC
    Likes ricevuti
    895
    Likes dati
    184
    Adesso , FORSE, ho capito, fermo restando l'inutilità della procedura, per avere il risultato voluto, usa:
    =INDICE(B2;CONFRONTA($A2;$A2:$A$11;0);CONFRONTA(B$1;B$1:$G$1;0))
    ho solo alterato qualche riferimento assoluto in modo che i confronta restituiscano sempre 1.

  6. #6
    L'avatar di Beppe
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Brescia
    Età
    37
    Messaggi
    78
    Versione Office
    2010 Win
    Likes ricevuti
    1
    Che la procedura fosse inutile lo avevo premesso da subito... :127:
    Però vedi che ti ho dato da pensare!!!:167:
    Grazie ninai. Ciao.:111:

  7. #7

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7159
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1300
    Non avevo capito neanch'io cosa volevi fare, ma avendo bloccato in maniera assoluta la cella A2 e B1 è evidente che nel trascinamento non andava a "pescare" nelle celle successive.

    =INDICE(B2;CONFRONTA($A2;$A$2:$A$11;0);CONFRONTA(B$1;$B$1:$G$1;0))



Discussioni Simili

  1. come inserire i punti di penalizzazione nella tabella di excel magico 24
    Di robin68 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 29/08/16, 20:56
  2. Macro personalizzate nella Barra Multifunzione di Excel
    Di ProgrammD69 nel forum Domande su Excel in generale
    Risposte: 14
    Ultimo Messaggio: 18/05/16, 14:04
  3. testa nuova icona allegato PDF
    Di Gerardo Zuccalà nel forum Test dei vostri post
    Risposte: 0
    Ultimo Messaggio: 19/02/16, 23:39
  4. Excel 2010 Inserimento delle voci nella colonna
    Di Pacifico437 nel forum Domande su Excel VBA e MACRO
    Risposte: 13
    Ultimo Messaggio: 12/12/15, 21:48
  5. Excel 2010 nella cella inserire una funzione completa
    Di Pacifico437 nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 19/11/15, 20:29

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •