Risultati da 1 a 5 di 5

Discussione: Formula per evitare la visualizzazione di risultati doppi



  1. #1
    L'avatar di Giovanna
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Pordenone
    Messaggi
    2
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0

    Formula per evitare la visualizzazione di risultati doppi

    Ciao a tutti, vi chiedo aiuto per il seguente problema: ho impostato la funzione Matr.somma.prodotto nelle celle della colonna Tot. ore per calcolare le ore di lavoro di alcuni dipendenti, il calcolo è corretto ma vorrei evitare la ripetizione del risultato nelle celle relative allo stesso dipendente. Sto lavorando con Excel 2000. Confido nel vostro aiuto e ringraziando auguro buona giornata.
    ID COGNOME E NOME ORE TOT.ORE
    1 AMBROSIO ALESSIA 3.00 11.10
    1 AMBROSIO ALESSIA 5.10 11.10 no
    1 AMBROSIO ALESSIA 3.00 11.10 no
    2 MARCHESI 3.00 6.00
    2 MARCHESI 3.00 6.00 no
    Ciao
    Giovanna

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342

    Re: Formula per evitare la visualizzazione di risultati doppi

    Ciao Giovanna
    in assenza di un file ho messo tutto a partire dalla cella A1
    in questo caso si puo dare a meno del MATR.SOMMA.PRODOTTO basta un SOMMA.SE
    in D2 metti questa formula

    =SE(B3=B2;"";SOMMA.SE($B$2:$B$6;B2;$C$2:$C$6))

    A
    B
    C
    D
    1
    ID COGNOME E NOME ORE TOT.ORE
    2
    1
    AMBROSIO ALESSIA
    3,00
    3
    1
    AMBROSIO ALESSIA
    5,10
    4
    1
    AMBROSIO ALESSIA
    3,00
    11,10
    5
    2
    MARCHESI
    3,00
    6
    2
    MARCHESI
    3,00
    6,00
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  3. I seguenti 2 utenti hanno dato un "Like" a Gerardo Zuccalà per questo post:


  4. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    54
    Messaggi
    10047
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2578
    Likes dati
    1552

    Re: Formula per evitare la visualizzazione di risultati doppi

    Ciao,
    se preferisci mettere il risultato in corrispondenza del primo nome, in alternativa alla formula di Gerardo, che saluto, puoi usare:

    =SE(CONTA.SE($B$2:B2;B2)=1;MATR.SOMMA.PRODOTTO(($B$2:$B$10=B2)*($C$2:$C$10));"")

    Questa formula tiene conto dei nomi doppi anche se sono non consecutivi.

    Allego file con formattazione condizionale
    =VAL.NUMERO($D2)
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  5. I seguenti utenti hanno dato un "Like"


  6. #4
    L'avatar di Giovanna
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Pordenone
    Messaggi
    2
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Formula per evitare la visualizzazione di risultati doppi

    Risposta lampo! Grazie, e ancora grazie
    Giovanna

  7. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342

    Re: Formula per evitare la visualizzazione di risultati doppi

    Citazione Originariamente Scritto da Giovanna Visualizza Messaggio
    Risposta lampo! Grazie, e ancora grazie
    Giovanna
    Bene, grazie del riscontro e torna quando vuoi!
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

Discussioni Simili

  1. Risultato formula con doppi Apici che non servono...
    Di MastroGiò nel forum Domande su Excel in generale
    Risposte: 21
    Ultimo Messaggio: 26/03/17, 13:30
  2. Evitare la chiusura di excel
    Di Semiuccio nel forum Domande su Excel VBA e MACRO
    Risposte: 1
    Ultimo Messaggio: 08/02/17, 11:39
  3. [Risolto] Copiare cella sottostante ed evitare inserimenti doppi
    Di G.Bove nel forum Domande su Excel VBA e MACRO
    Risposte: 16
    Ultimo Messaggio: 04/01/17, 19:31
  4. Formula clcolo punti da misure/risultati
    Di roby8a nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 02/11/16, 12:52
  5. Evitare di eseguire una Macro se una cella è vuota
    Di Gerardo Zuccalà nel forum Domande su Excel VBA e MACRO
    Risposte: 8
    Ultimo Messaggio: 28/06/16, 09:02

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •