Risultati da 1 a 28 di 28

Discussione: Quiz della progressione



  1. #1

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1017
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0

    Quiz della progressione

    Giusto per riprendere la mano con le formule di Excel (che ormai non ricordo più nulla), un piccolo quiz ispirato da una domanda presentata in altro forum.

    Abbiamo la sottostante tabella:
    A
    B
    C
    D
    1
    quantità
    costo
    2
    #
    INPUT
    3
    1
    4
    2
    5
    3
    6
    4
    7
    5
    8
    6
    9
    7
    10
    8
    11
    9
    12
    10

    Nelle celle in colonna B (da B3 a B12) vanno inseriti dei valori (rappresentano una quantità e sono interi maggiori di 0).
    In C3 (da copiare poi fino a C12) inserire una formula che riporti il totale progressivo delle quantità (colonna B).
    In D3 (da copiare poi fino a D12) inserire una formula che, sulla base della seguente "scaglionatura":

    quantità
    fino a 100
    da 101
    a 150
    da 151
    a 200
    da 200
    a 300
    oltre 300
    prezzo
    108
    144
    216
    276
    360

    riporti il totale progressivo del costo (quantità * prezzo).
    Inserire, inoltre, in C2 una formula che dia il totale quantità, in D2 una formula che dia il totale costo.

    Esempio: inserisco in B3 70:

    A
    B
    C
    D
    1
    quantità
    costo
    2
    #
    INPUT
    70
    7.560
    3
    1
    70
    70
    7.560
    4
    2
    5
    3
    6
    4
    7
    5

    quindi in B4 inserisco 20, poi in B5 50

    A
    B
    C
    D
    1
    quantità
    costo
    2
    #
    INPUT
    140
    16.560
    3
    1
    70
    70
    7.560
    4
    2
    20
    90
    9.720
    5
    3
    50
    140
    16.560
    6
    4
    7
    5

    Tenete presente che gli scaglioni sono esclusivamente quelli e sono fissi.
    Scatenate la fantasia, ma tenete presente che NON utilizzare colonne di appoggio esterne alla tabella B3:D12 è titolo preferenziale.

    Ovviamente niente VBA.
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7141
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: Quiz della progressione

    Ciao scossa,
    è sempre un piacere leggerti, ben tornato anche da parte mia.

    Allora, se, ho ben capito:

    in C3 da trascinare in basso metterei:

    =SOMMA(INDIRETTO("B3:B"&RIF.RIGA()))

    in C2:

    =CERCA(3;1/(C3:C12<>0);C3:C12)



    in D2, per ora mi viene solo una formula con diversi SE nidificati, che però non vorrei postare e quindi vedo di trovarne una all'altezza del quiz che hai proposto!
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di Marius44
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Catania
    Età
    73
    Messaggi
    3213
    Versione Office
    Excel2010
    Likes ricevuti
    625
    Likes dati
    155

    Re: Quiz della progressione

    Ciao Marco e ben ritrovato fra noi.
    Anche se hai tentato di escludermi, provo a darti la risposta (con un piccolo escamotage che mi devi consentire). Dunque:
    cella formula
    C2 =SOMMA($B$3:$B$12)
    D2 =CERCA.ORIZZ(C2;$K$1:$P$2;2)*C2
    C3 =SE(B3="";"";SOMMA($B$3:$B3)) 'da tirare in basso fino alla C12
    D3 =SE(B3="";"";CERCA.ORIZZ(B3;$K$1:$P$2;2)*C3) 'da tirare in basso fino alla D12

    L'intervallo K1:P2 contiene la griglia alla quale (ecco l'escamotage) ho premesso una colonna per le quantità inferiori a 100)

    Allego il file a beneficio del Forum e aspetto le tue gradite precisazioni.
    Ciao,
    Mario
    File Allegati File Allegati

  4. #4

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1017
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0

    Re: Quiz della progressione

    Citazione Originariamente Scritto da ges Visualizza Messaggio

    in C3 da trascinare in basso metterei:

    =SOMMA(INDIRETTO("B3:B"&RIF.RIGA()))

    in C2:

    =CERCA(3;1/(C3:C12<>0);C3:C12)

    Ciao ges,
    secondo me le hai fatte entrambe più complicate del necessario, pensa "semplice" .....
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  5. #5
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: Quiz della progressione

    ciao
    mi sa che stiamo capendo tutti cosa diverse, non ho ancora valutato le altre risposte ma io ho capito così:

    in C3:
    =SE(B3;SOMMA($B$3:B3);"")

    in D3:
    =MIN($C3;100)*108+MEDIANA(0;$C3-100;50)*144+MEDIANA(0;$C3-150;50)*216+MEDIANA(0;$C3-200;100)*276+MAX(0;$C3-300)

    ambedue da trascinare in basso

    in C2:
    =MAX(C3:C12)
    da copiare anche in D2

    Ho capito che non bisogna usare alcun appoggio, neanche tabelle di scaglionamento, allego il mio file di lavoro


    NB
    l'hai semplificato dall'originale, onestamente in quel modo non saprei come fare


    edit
    manca la gestione dell'errore in D3:
    =SE(B3;MIN($C3;100)*108+MEDIANA(0;$C3-100;50)*144+MEDIANA(0;$C3-150;50)*216+MEDIANA(0;$C3-200;100)*276+MAX(0;$C3-300);"")
    File Allegati File Allegati
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  6. #6
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2072
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: Quiz della progressione

    Ciao
    questo è il file semioriginale
    visto che avevo risposto io
    e purtroppo come spesso accade sono caduto nel dimenticatoio
    ( più avuto risposta )

    io ho utilizzato il mio grande amore il SE
    e ho utilizzato il metodo arcano
    del calcolo irpef

    vedete Voi
    la formula è leggermente lunga.

    non sto a ripotare il tutto nell'esempio di Scossa
    solo per pigrizia
    File Allegati File Allegati

  7. #7
    L'avatar di dracoscrigno
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    ferrara
    Età
    41
    Messaggi
    2074
    Versione Office
    office pro 2010
    Likes ricevuti
    440
    Likes dati
    241

    Re: Quiz della progressione

    Vediamo cosa riesco a fare con le formule :D

    LA tabella che mi esce eè questa:

    Codice: 
    quantità costo
    # INPUT 695 184800
    1 70 70 7.560
    2 20 90 9.720
    3 50 140 16.560
    4 90 230 37.080
    5 30 260 45.360
    6 100 360 64.200
    7 110 470 103.800
    8 200 670 175.800
    9 25 695 184.800

    Come INPUT, in C2,
    Codice: 
    =CERCA(2;1/(C2:C11<>"");C2:C11)
    la stessa in D2 come costo, naturalmente cambiando la colonna di ricerca:
    Codice: 
    =CERCA(2;1/(D2:D11<>"");D2:D11)
    per determinare la quantità crescente nelle rispettive righe della colonna quantità; in C3 da trascianre verso il basso:
    Codice: 
    =SE(RIF.RIGA(B3)<=3;B3;B3+C2)
    Per determinare il costo progressivo nella colonna dei costi; in D3 da trascinare verso il basso:
    Codice: 
    =SE(C3<=100;C3*108;SE(C3<=150;10800+(C3-100)*144;SE(C3<=200;18000+(C3-150)*216;SE(C3<=300;28800+(C3-200)*276;42600+(C3-300)*360))))

  8. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7141
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: Quiz della progressione

    Ok,scossa, ci provo.

    Allora comincio a postare la mia formula del SE nidificato in D2:

    =(MIN(C2;100)*108 + SE(C2>100;(MIN(C2;150)-100)*144;0) + SE(C2>150;(MIN(C2;200)-150)*216;0)+ SE(C2>200;(MIN(C2;300)-200)*276;0)+SE(C2>300;(C2-300)*360))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  9. #9

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1017
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0

    Re: Quiz della progressione

    Citazione Originariamente Scritto da Marius44 Visualizza Messaggio
    D3 =SE(B3="";"";CERCA.ORIZZ(B3;$K$1:$P$2;2)*C3) 'da tirare in basso fino alla D12
    Ciao Mario,

    c'è un errore di fondo (colpa mia che non ho spiegato bene): devi ripartire la quantità totale (progressiva) esattamente per gli scaglioni:

    70
    70
    =70*108
    7.560
    20
    90
    =90*108
    9.720
    50
    140
    =100*108+40*144
    16.560
    40
    180
    =100*108+50*144+30*216
    24.480

    e così via ....
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  10. #10
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2072
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: Quiz della progressione

    mmmmmmmm!

    Scossa ha cambiato le carte in tavola
    vuole i totali
    perciò si può accrociare di un bel po'

  11. #11
    L'avatar di dracoscrigno
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    ferrara
    Età
    41
    Messaggi
    2074
    Versione Office
    office pro 2010
    Likes ricevuti
    440
    Likes dati
    241

    Re: Quiz della progressione

    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    Ciao ges,
    secondo me le hai fatte entrambe più complicate del necessario, pensa "semplice" .....

    In effetti, rileggendo e ripensando:

    =MAX(C3:C11)

    basta la funzione MAX()
    Perchè l' incolonnamento avrà, certamente, l' ultimo valore SEMPRE maggiore dei precedenti. E' la somma dei precedenti!

  12. #12
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: Quiz della progressione

    correggo la mia formula in D3:
    =SE(B3;MIN($C3;100)*108+MEDIANA(0;$C3-100;50)*144+MEDIANA(0;$C3-150;50)*216+MEDIANA(0;$C3-200;100)*276+MAX(0;$C3-300)*360;"")

    mancava l'ultimo fattore (360)
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  13. #13
    L'avatar di dracoscrigno
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    ferrara
    Età
    41
    Messaggi
    2074
    Versione Office
    office pro 2010
    Likes ricevuti
    440
    Likes dati
    241

    Re: Quiz della progressione

    Ok... i guru si son gia espressi... Ho visto che le mie elucubrazioni di mezzora sono gia state scritte .... andate a quel paese :D :D :D
    Continuo a leggervi standomene zitto dietro il tavolino

  14. #14

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1017
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0

    Re: Quiz della progressione

    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ....
    Non funziona bene, prova questa sequenza e vedrai che non ottieni questo risultato:

    # INPUT
    320
    63.600
    1
    70
    70
    =70*108
    7.560
    2
    20
    90
    =90*108
    9.720
    3
    50
    140
    =100*108+40*144
    16.560
    4
    40
    180
    =100*108+50*144+30*216
    24.480
    5
    140
    320
    =100*108+50*144+50*216+100*276+20*360
    63.600

    Era riferito al tuo penultimo post!

    ----------Post unito in automatico----------

    Citazione Originariamente Scritto da dracoscrigno Visualizza Messaggio
    In effetti, rileggendo e ripensando:

    =MAX(C3:C11)

    basta la funzione MAX()
    Perchè l' incolonnamento avrà, certamente, l' ultimo valore SEMPRE maggiore dei precedenti. E' la somma dei precedenti!
    Esatto!!
    Bravo draco!!

    ----------Post unito in automatico----------

    Citazione Originariamente Scritto da dracoscrigno Visualizza Messaggio
    Vediamo cosa riesco a fare con le formule :D

    LA tabella che mi esce eè questa:

    Codice: 
    quantità costo
    # INPUT 695 184800
    1 70 70 7.560
    2 20 90 9.720
    3 50 140 16.560
    4 90 230 37.080
    5 30 260 45.360
    6 100 360 64.200
    7 110 470 103.800
    8 200 670 175.800
    9 25 695 184.800
    Qualcosa non quadra nella tua progressione (vedi ultima colonna):
    #
    INPUT
    695
    198.600
    184.800
    1
    70
    70
    7.560
    7.560
    2
    20
    90
    9.720
    9.720
    3
    50
    140
    16.560
    16.560
    4
    90
    230
    37.080
    37.080
    5
    30
    260
    45.360
    45.360
    6
    100
    360
    78.000
    64.200
    7
    110
    470
    117.600
    103.800
    8
    200
    670
    189.600
    175.800
    9
    25
    695
    198.600
    184.800


    ----------Post unito in automatico----------

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ok,scossa, ci provo.

    Allora comincio a postare la mia formula del SE nidificato in D2:

    =(MIN(C2;100)*108 + SE(C2>100;(MIN(C2;150)-100)*144;0) + SE(C2>150;(MIN(C2;200)-150)*216;0)+ SE(C2>200;(MIN(C2;300)-200)*276;0)+SE(C2>300;(C2-300)*360))
    Come già svelato le formule in C2 e D2 sono banali ( basta usare MAX()) :-)

    Anche quelle in C3 .. C12 si può utilizzare la formula di ninai:
    Codice: 
    =SE(B3;SOMMA($B$3:B3);"")
    enormemente più lunga (ben 2 caratteri!! ) della mia:
    Codice: 
    =SOMMA($B$3:$B3)*(B3>0)
    ----------Post unito in automatico----------

    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    correggo la mia formula in D3:
    =SE(B3;MIN($C3;100)*108+MEDIANA(0;$C3-100;50)*144+MEDIANA(0;$C3-150;50)*216+MEDIANA(0;$C3-200;100)*276+MAX(0;$C3-300)*360;"")

    mancava l'ultimo fattore (360)
    Perfetta ninai, non avevo dubbi!
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  15. #15
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: Quiz della progressione

    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    enormemente più lunga (ben 2 caratteri!! ) della mia:
    Codice: 
    =SOMMA($B$3:$B3)*(B3>0)
    Sì, ma ti ritrovi il foglio "tempestato" di zeri
    io sono per la pulizia
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  16. #16

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1017
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0

    Re: Quiz della progressione

    Citazione Originariamente Scritto da Gianfranco55 Visualizza Messaggio
    vedete Voi
    la formula è leggermente lunga.

    non sto a ripotare il tutto nell'esempio di Scossa
    solo per pigrizia
    La tua soluzione è valida per il problema nell'altro lido, che è stato di spunto per questo quiz, se ti va di cimentarti ....

    ----------Post unito in automatico----------

    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    Sì, ma ti ritrovi il foglio "tempestato" di zeri
    io sono per la pulizia
    Tempestato di 0??? ma quando mai: basta impostare correttamente la visualizzazione degli zeri nel foglio (opzioni avanzate)
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  17. #17
    L'avatar di dracoscrigno
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    ferrara
    Età
    41
    Messaggi
    2074
    Versione Office
    office pro 2010
    Likes ricevuti
    440
    Likes dati
    241

    Re: Quiz della progressione

    Citazione Originariamente Scritto da scossa Visualizza Messaggio

    Qualcosa non quadra nella tua progressione (vedi ultima colonna):
    #
    INPUT
    695
    198.600
    184.800
    1
    70
    70
    7.560
    7.560
    2
    20
    90
    9.720
    9.720
    3
    50
    140
    16.560
    16.560
    4
    90
    230
    37.080
    37.080
    5
    30
    260
    45.360
    45.360
    6
    100
    360
    78.000
    64.200
    7
    110
    470
    117.600
    103.800
    8
    200
    670
    189.600
    175.800
    9
    25
    695
    198.600
    184.800
    =SE(C3<=100;C3*108;SE(C3<=150;10800+(C3-100)*144;SE(C3<=200;18000+(C3-150)*216;SE(C3<=300;28800+(C3-200)*276;42600+(C3-300)*360))))

    doveva essere un "1"

  18. #18
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: Quiz della progressione

    Citazione Originariamente Scritto da Gianfranco55 Visualizza Messaggio
    Ciao
    questo è il file semioriginale
    visto che avevo risposto io
    e purtroppo come spesso accade sono caduto nel dimenticatoio
    ( più avuto risposta )

    io ho utilizzato il mio grande amore il SE
    e ho utilizzato il metodo arcano
    del calcolo irpef

    vedete Voi
    la formula è leggermente lunga.

    non sto a ripotare il tutto nell'esempio di Scossa
    solo per pigrizia
    in risposta al tuo quesito, non ho trovato la risposta diretta, ma attraverso questa soluzione si può arrivare al tuo obiettivo, basta sottrarre al risultato gli importi precedenti, adattando la formula al tuo file, in G12:
    =SE(C12;MIN($E12;100)*108+MEDIANA(0;$E12-100;50)*144+MEDIANA(0;$E12-150;50)*216+MEDIANA(0;$E12-200;100)*276+MAX(0;$E12-300)*360-SOMMA(G$11:G11);"")

    ----------Post unito in automatico----------

    Citazione Originariamente Scritto da dracoscrigno Visualizza Messaggio
    =SE(C3<=100;C3*108;SE(C3<=150;10800+(C3-100)*144;SE(C3<=200;18000+(C3-150)*216;SE(C3<=300;28800+(C3-200)*276;42600+(C3-300)*360))))

    doveva essere un "1"
    scusa ma, se ho capito bene la tua procedura, forse il 42600 deve essere 56400
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  19. #19
    L'avatar di dracoscrigno
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    ferrara
    Età
    41
    Messaggi
    2074
    Versione Office
    office pro 2010
    Likes ricevuti
    440
    Likes dati
    241

    Re: Quiz della progressione

    NINAI.
    un risposta al tuo intervento; il post 18 qui sopra.
    non sto a spiegarti tutta la formula perchè mi sa che mi perderei nelle mie stesse parole (ora sono al cellulare)

    il numero costante dato, 41600 è dato dalla sommatoria di quanto segue:

    100 unità iniziali * 108 di costo
    50 unita (da 101 a 150) * 144 di costo
    50 unità (da 151 a 200) * 216
    100 unità (da 201 a 300) * 276

    dando: (100*108) + (50*144) + (50*216) + (100*276) =41600

    avendo un numero di oggetti maggiore di 300, il costo di 300 oggetti è, appunto una costante alla quale va aggiunto il costo per i pezzi successivi relativi al proprio scaglione ( 360 per ogni oggetto supplementare.

    tutto l annidamento dei se è costruito su questo concetto.

    dalla colonna comparativa postatami da scossa si nota che i miei risultati, sono maggiori rispetto alla realtà e quindi la mia costante iniziale era troppo grande (42600) e dava, appunto, risultati maggiori.
    ricalcolandola a mano mentre guardavo la tele ho trovato 41600 (probabilmente ho sbagliato a battere sul tastierino)
    con 41600, quindi correggendo, la mia colonna da gli stessi risultati da scossa ed immagino anche i tuoi.

    ammetto di non aver controllato ulteriormente ma mi son fidato della comparazione.

    cio non toglie che potrei ancora aver sbagliato :(

  20. #20
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: Quiz della progressione

    Citazione Originariamente Scritto da dracoscrigno Visualizza Messaggio
    (100*108) + (50*144) + (50*216) + (100*276) =41600
    :(
    Sono anche io al tel ma ad occhio questa somma di prodotti é da ricontrollare. Anche io ho seguito il tuo ragionamento
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  21. #21
    L'avatar di dracoscrigno
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    ferrara
    Età
    41
    Messaggi
    2074
    Versione Office
    office pro 2010
    Likes ricevuti
    440
    Likes dati
    241

    Re: Quiz della progressione

    google calcolatrice

    hai ragione da vendere.

    allora sono piu pazzo di quanto immaginassi... dopo ci guardo...

  22. #22

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1017
    Versione Office
    .
    Likes ricevuti
    366
    Likes dati
    0

    Re: Quiz della progressione

    Ciao,

    visto che da domani ricomincia la settimana e non potrò garantire la mia presenza nel forum, chiudo questo interessante confronto complimentandomi con tutti per le varie soluzioni.
    Purtroppo la soluzione di ninai non può essere accettata in quanto non (mi) ha pagato i diritti d'autore sulla funzione MEDIANA(), notoriamente di mia esclusiva proprietà!

    Avendo, inoltre, lo stesso ninai "bruciato" la mia soluzione, ho cercato una soluzione che fosse il più possibile originale, anche a discapito della lunghezza, e così ho rispolverato un''altra funzione che mi sta particolarmente simpatica SOGLIA():
    Codice: 
    =SOMMA(SOGLIA(C3;{101.151.201.301})*{10800.7200.10800.27600})+(C3-INDICE({0.100.150.200.300};SOMMA(SOGLIA(C3;{1.101.151.201.301}))))*INDICE({108.144.216.276.360};SOMMA(SOGLIA(C3;{1.101.151.201.301})))
    non ho nemmeno provato a vedere se i può semplificare, lascio a voi provarci .....

    Alla prossima

    ----------Post unito in automatico----------

    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    non ho nemmeno provato a vedere se i può semplificare, lascio a voi provarci .....
    Usando i nomi si può semplificare in:
    Codice: 
    =SOMMA(SGL*IMPSCA)+(C4-INDICE(SCGL;SMSGL))*INDICE(PRZ;SMSGL)
    matriciale da confermare con ctrl+maiusc+invio.
    Spiegazione dei nomi:
    Nome Riferito a descr.
    DIFF ={100;50;50;100} differenza tra scaglioni
    IMPSCA =DIFF*PRZN importi degli scaglioni pieni
    PRZ ={108;144;216;276;360} prezzi scaglioni
    PRZN ={108;144;216;276} prezzi scaglioni pieni
    SCGL ={0;100;150;200;300} scaglioni
    *
    SGL =SOGLIA(Foglio2!C4;{101.151.201.301}) scaglioni pieni
    *
    SMSGL =SOMMA(SOGLIA(Foglio2!C4;{1.101.151.201.301})) numero di scaglioni interessati
    *
    prima di creare il nome selezionare la cella C4
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  23. I seguenti utenti hanno dato un "Like"


  24. #23
    L'avatar di dracoscrigno
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    ferrara
    Età
    41
    Messaggi
    2074
    Versione Office
    office pro 2010
    Likes ricevuti
    440
    Likes dati
    241

    Re: Quiz della progressione

    Grazie Scossa della sfida celebrale.
    Grazie a questo giochino oggi ho utilizzato le funzioni.

    Spero ne arrivino altre :)


    NINAI.

    Ho dovuto ricreare tutto perchè l' avevo cestinato. Ho però capito dove ho commesso l' errore. E' colpa del foglio che utilizzo sotto il mouse
    Adesso allego il file. almeno ho una base memorizzata
    File Allegati File Allegati

  25. #24
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: Quiz della progressione

    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    Ciao,

    visto che da domani ricomincia la settimana e non potrò garantire la mia presenza nel forum, .....


    ....Purtroppo la soluzione di ninai non può essere accettata in quanto non (mi) ha pagato i diritti d'autore sulla funzione MEDIANA(), notoriamente di mia esclusiva proprietà!

    ......così ho rispolverato un''altra funzione che mi sta particolarmente simpatica SOGLIA():
    Codice: 
    =SOMMA(SOGLIA(C3;{101.151.201.301})*{10800.7200.10800.27600})+(C3-INDICE({0.100.150.200.300};SOMMA(SOGLIA(C3;{1.101.151.201.301}))))*INDICE({108.144.216.276.360};SOMMA(SOGLIA(C3;{1.101.151.201.301})))
    non ho nemmeno provato a vedere se i può semplificare, lascio a voi provarci .....
    Bello così!! arrivi, ci metti in subbuglio e poi risparisci....., quì bisogna prevedere delle penali


    Come non ti ho pagato i diritti, e le decine di granite con panna che ti ho dedicato nelle mie colazioni

    SOGLIA(), un'altra di quelle che non ricordo mai l'esistenza.

    comunque si può semplificare anche senza nomi, ad esempio:

    =SOMMA(SOGLIA(C3;{101.151.201.301})*{10800.7200.10800.27600})+(C3-CERCA(C3;{0.100.150.200.300}))*CERCA(C3;{0.100.150.200.300};{108.144.216.276.360})

    ma si potrà fare anche meglio

    ----------Post unito in automatico----------

    correggo quella di prima:
    =SOMMA(SOGLIA(C3;{100.150.200.300})*{10800.7200.10800.27600})+(C3-CERCA(C3;{0.100.150.200.300}))*CERCA(C3;{0.100.150.200.300};{108.144.216.276.360})

    e propongo un'altra alternativa (monofunzione):
    =CERCA(C3;{0.100.150.200.300};{0.10800.18000.28800.56400})+(C3-CERCA(C3;{0.100.150.200.300}))*CERCA(C3;{0.100.150.200.300};{108.144.216.276.360})
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  26. I seguenti utenti hanno dato un "Like"


  27. #25
    L'avatar di dracoscrigno
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    ferrara
    Età
    41
    Messaggi
    2074
    Versione Office
    office pro 2010
    Likes ricevuti
    440
    Likes dati
    241

    Re: Quiz della progressione

    Mi piacerebbe conoscervi solo per bruciarvi tutti i neuroni con litri di Oban

  28. #26
    L'avatar di Marius44
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Catania
    Età
    73
    Messaggi
    3213
    Versione Office
    Excel2010
    Likes ricevuti
    625
    Likes dati
    155

    Re: Quiz della progressione

    Buongiorno a tutti
    Non vi posso lasciare un attimo che ....
    Ieri sera vi ho trascurati un po' per vedere i risultati dei ballottaggi (e poi sono andato a nanna) e stamani trovo la geniale e istruttiva soluzione di Scossa (stavolta con la S maiuscola).
    Grazie, Marco, per permetterci di giocare e imparare e ancora complimenti. Vorrei che, compatibilmente col tuo lavoro, ci seguissi più da vicino.
    Alò prossimo gioco!!!

    Ciao a tutti,
    Mario

    PS ovviamente un Bravi a tutti coloro che hanno tentato di trovare (o l'hanno trovata) la soluzione ed un invito a Gerardo e Max: perchè Dracoscrigno NON E' fra gli esperti. A mio parere lo è di diritto.

  29. #27
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Re: Quiz della progressione

    allego file di riepilogo soluzioni, anche quella per i singoli valoriparziali:
    File Allegati File Allegati
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  30. I seguenti utenti hanno dato un "Like"

    ges

  31. #28

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7141
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: Quiz della progressione

    Grazie ninai per il lavoro di sintesi che riepiloga le varie soluzioni, così diventa un file utile da conservare.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

Discussioni Simili

  1. [Risolto] Quiz
    Di Anthony nel forum Domande su Excel in generale
    Risposte: 35
    Ultimo Messaggio: 22/11/16, 15:02
  2. Nascondere macro, ovvero il quiz della macro nascosta
    Di scossa nel forum Domande su Excel VBA e MACRO
    Risposte: 7
    Ultimo Messaggio: 02/03/16, 23:04
  3. Il Quiz della Settimana Sparsa...
    Di Textomb nel forum Domande su Excel in generale
    Risposte: 23
    Ultimo Messaggio: 15/01/16, 12:39
  4. Il Quiz della Befana
    Di Marius44 nel forum Domande su Excel in generale
    Risposte: 37
    Ultimo Messaggio: 07/01/16, 09:01
  5. Quiz #13 formattazione condizionale (barra della percentuale)
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 29/06/15, 23:07

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •