Risultati da 1 a 9 di 9

Discussione: Filtro righe in base a valori univoci della prima colonna



  1. #1
    L'avatar di sirlancilot
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Roma
    Età
    47
    Messaggi
    7
    Versione Office
    MAC
    Likes ricevuti
    0
    Likes dati
    1

    Filtro righe in base a valori univoci della prima colonna

    Salve,
    spero che qualcuno possa aiutarmi. Premetto che conosco poco le funzionalità di excel. Ho cercato in rete ma non sono riuscito a trovare nulla che mi aiuti a risolvere il problema che sto per porre.

    Ho una tabella con sei colonne... la prima è una colonna "data", le altre cinque invece sono "valuta"

    I valori delle celle della colonna data si ripetono (ad esempio 10 righe 01/01/2015, 15 righe 02/01/2015 ecc). Ovviamente i valori delle celle nelle colonne valuta differiscono.

    Desidero sapere se c'è la possibilità di applicare un filtro che estragga o visualizzi o copi ecc ecc tutte le righe in base al valore univoco della prima colonna.
    In definitiva avrei bisogno di visualizzare solo la prima riga di ogni data della colonna (prima riga del 01=01/2015, prima riga del 02/01/2015 e così via per l'intera tabella/range di data)

    Mi scuso se sono stato poco chiaro.
    Ultima modifica fatta da:Canapone; 14/07/17 alle 15:02

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7131
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299

    Re: Filtro righe in base a valori univoci della prima colonna

    Ciao,
    allega un file excel di esempio anche con poche righe.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di sirlancilot
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Roma
    Età
    47
    Messaggi
    7
    Versione Office
    MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: Filtro righe in base a valori univoci della prima colonna

    Salve,
    allego la demo. Grazie
    File Allegati File Allegati

  4. #4
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    Re: Filtro righe in base a valori univoci della prima colonna

    Ciao

    Qualcosa del genere???
    File Allegati File Allegati
    windows 10
    Excel 2016

  5. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7131
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299

    Re: Filtro righe in base a valori univoci della prima colonna

    Allora ...

    formula per selezionare gli importi:


    =SE.ERRORE(INDICE(B$2:B$45;AGGREGA(15;6;(RIF.RIGA($B$2:$B$45)-RIF.RIGA($B$2)+1)/($A$2:$A$45=$I$2);RIGHE(A1:$A$1)));"")


    formula per selezionare gli anni univoci:


    =SE.ERRORE(INDICE($A$2:$A$45;CONFRONTA(0;INDICE(CONTA.SE($G$1:G1;$A$2:$A$45&""););0));"")


    Ti ho sistemato il file come allegato, vedi se può andare.

    EDIT: Ciao Nick, non avevo visto la tua risposta.
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. I seguenti 2 utenti hanno dato un "Like" a ges per questo post:


  7. #6
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    Re: Filtro righe in base a valori univoci della prima colonna

    ciao Ges....

    Fatto bene tranquillo sicuramente la tua funziona benissimo...................
    windows 10
    Excel 2016

  8. #7
    L'avatar di sirlancilot
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Roma
    Età
    47
    Messaggi
    7
    Versione Office
    MAC
    Likes ricevuti
    0
    Likes dati
    1

    Smile Re: Filtro righe in base a valori univoci della prima colonna

    Salve,
    dire grazie è poco, ad entrambi.
    Vanno benissimo entrambe le formule. Mi avete fatto risparmiare ore di noiosissimo lavoro.
    Grazie ancora

  9. #8
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    Re: Filtro righe in base a valori univoci della prima colonna

    Di niente..........
    windows 10
    Excel 2016

  10. #9

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7131
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299

    Re: Filtro righe in base a valori univoci della prima colonna

    Grazie a te del riscontro positivo, alla prossima!
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

Discussioni Simili

  1. Risposte: 8
    Ultimo Messaggio: 10/03/17, 21:48
  2. [Risolto] Generare Colonna con valori univoci da una lista
    Di Domynix nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 05/01/17, 15:01
  3. [Risolto] corrispondenza tra righe in base al volore presente in colonna
    Di Lety88 nel forum Domande su Excel VBA e MACRO
    Risposte: 2
    Ultimo Messaggio: 07/11/16, 09:15
  4. PIVOT ordinare le etichette di colonna in base alla prima
    Di framag nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 10/03/16, 17:22
  5. Unire 2 colonne in 1 alternando in base alla tipologia della prima colonna
    Di sassa nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 30/12/15, 12:13

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •