Risultati da 1 a 8 di 8

Discussione: Funzione IF o similari, dare un valore ad una casella in base al valore di un'altra



  1. #1
    L'avatar di Dr Jackall
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Caltanissetta
    Età
    32
    Messaggi
    6
    Versione Office
    Excel 2013
    Likes ricevuti
    1

    Funzione IF o similari, dare un valore ad una casella in base al valore di un'altra (esempio alleg.)

    Salve a tutti!
    Vorrei un aiuto su una funzione che vorrei realizzare in un mio foglio di calcolo!

    In pratica ci sono molti pagamenti di ditte da gestire, e volevo creare un foglio di calcolo che automatizzasse la creazione delle ricevute.

    Questo è quello che vorrei realizzare (ho fatto un foglio in excel di esempio esplicativo che allego)

    Ho due fogli; nel primo foglio ho 4 colonne:una colonna con tutte le ditte, una colonna con tutti i pagamenti arretrati 2014, una con i pagamenti arretrati 2015, e una con i pagamenti arretrati 2016 per ditta.

    Nel secondo foglio invece ho la ricevuta da consegnare ad ogni ditta, con su scritto nome ditta, pagamenti arretrati 2014, pagamenti arretrati 2015 e pagamenti arretrati 2016.

    Vorrei che nel momento in cui nella ricevuta (foglio 2) vado ad inserire il nome della ditta, automaticamente excel vada a vedere nel primo foglio la riga corrispondente e mi copi i campi pagamenti arretrati 2014, 2015 e 2016, ed infine mi calcoli il totale, di modo da poter stampare tutte le ricevute velocemente e senza errori.

    Spero di essere stato chiaro! Vi ringrazio in anticipo!
    File Allegati File Allegati

  2. #2
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Binasco
    Età
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: Funzione IF o similari, dare un valore ad una casella in base al valore di un'altra (esempio all

    Basta scrrivere in B2 la ditta
    in B4 =CERCA.VERT(B2;Foglio1!A:D;2;FALSO)
    in b5 =CERCA.VERT(B2;Foglio1!A:D;3;FALSO)
    in b6 =CERCA.VERT(B2;Foglio1!A:D;4;FALSO)
    in b8 =SOMMA(B4:B7)

  3. #3
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2286
    Versione Office
    Excel 2010
    Likes ricevuti
    908
    Likes dati
    450

    Re: Funzione IF o similari, dare un valore ad una casella in base al valore di un'altra (esempio all

    Ciao vedo che Raffaele (ciao) ti ha già dato una soluzione.
    Ho già pronto il file che allego
    File Allegati File Allegati

  4. #4
    L'avatar di Dr Jackall
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Caltanissetta
    Età
    32
    Messaggi
    6
    Versione Office
    Excel 2013
    Likes ricevuti
    1

    Re: Funzione IF o similari, dare un valore ad una casella in base al valore di un'altra (esempio all

    Vi ringrazio tantissimo funziona alla grande!

    Scusate se ne approfitto per un'ultima domanda!
    Nel secondo foglio c'è l'elenco a scorrimento delle ditte, per caso c'è un modo per digitare una lettera ed andare direttamente alle ditte con quella lettera? O devo per forza selezionarle scorrendo ogni volta tutto l'elenco?

    Grazie ancora!

  5. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7125
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1298

    Re: Funzione IF o similari, dare un valore ad una casella in base al valore di un'altra (esempio all

    Ciao,
    con il menu a tendina della convalida dati devi selezionare ... altrimenti serve una combobox.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. #6
    L'avatar di Dr Jackall
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Caltanissetta
    Età
    32
    Messaggi
    6
    Versione Office
    Excel 2013
    Likes ricevuti
    1

    Re: Funzione IF o similari, dare un valore ad una casella in base al valore di un'altra (esempio all

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao,
    con il menu a tendina della convalida dati devi selezionare ... altrimenti serve una combobox.
    Grazie! Ho attivato la scheda "Sviluppo" e creato una combobox, come faccio a collegargli una colonna? E specificamente la colonna delle ditte della prima pagina?

  7. #7
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Binasco
    Età
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: Funzione IF o similari, dare un valore ad una casella in base al valore di un'altra (esempio all

    Se hai creato una combobox in cella B2
    Vai col mouse destro sopra la combobox/formatto controllo/controllo e metti Foglio1!$A$2:$A$13
    Ho aumentato il range di 4/5 celle vuote, per eventuali inserimenti. Casomai da rimodificare in futuro.
    Si potrebbe anche fare così, vai in excel/formule/gestione nomi/inserisci
    Assegna il Nome DITTE e in riferito a metti =SCARTO(Foglio1!$A$1;0;0;CONTA.VALORI(Foglio1!$A:$A);1)
    Vai col mouse destro sopra la combobox/formatto controllo/controllo e metti =DITTE
    In questo modo potrai aggiungere tutte le ditte che vuoi.

  8. #8
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    779
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1

    Re: Funzione IF o similari, dare un valore ad una casella in base al valore di un'altra (esempio all

    Buon Giorno

    Foglio 2

    b4 =CERCA.VERT($B$2;Foglio1!$A$1:$D$5;CONFRONTA(Foglio2!A4;Foglio1!$A$1:$D$1;0);FALSO) copia in basso

    Saluti
    Window 8.1 Excel 2013/2016

Discussioni Simili

  1. [Risolto] Nascondere contenuto di una cella in funzione del valore valore di un'altra cella
    Di Emax80 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 05/12/16, 16:54
  2. [Risolto] cambiare valore in colonna in base ad un'altra
    Di bopo57 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 25/10/16, 20:43
  3. Risposte: 4
    Ultimo Messaggio: 10/08/16, 00:58
  4. [Risolto] Come ottenere un valore in una casella combinata, da un'altra casella combinata
    Di ProgrammD69 nel forum Domande su Microsoft Access
    Risposte: 13
    Ultimo Messaggio: 26/07/16, 14:14
  5. Assegna un valore dato il valore un valore maggiore di 0 di altra cella
    Di Fabio71 nel forum Domande su Excel in generale
    Risposte: 20
    Ultimo Messaggio: 27/12/15, 21:23

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •