Risultati da 1 a 7 di 7

Discussione: Contare ed estrarre oggetti con criteri



  1. #1
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Smile Contare ed estrarre oggetti con criteri

    Ciao a tutti
    come potete vedere per facilitare il tutto ho già scritto il risultato a mano
    per cui vorrei una formula in D4 e copiare a desta per sapere quante volte incontra il criterio che è scritto sopra in D2 e E2
    Mentre in D6 vorrei una formula da copiare a destra ed in basso per estrarre i records che soddisfano lo stesso criterio
    Buon divertimento!:166:

    A
    B
    C
    D
    E
    1
    Oggetto Valore Criterio1 Criterio2
    2
    A
    23
    X A
    3
    X
    34
    Conta Conta
    4
    C
    24
    3
    2
    5
    B
    64
    Valori Valori
    6
    X
    89
    34
    23
    7
    X
    82
    89
    73
    8
    A
    73
    82
    9
    D
    97
    10
    C
    97
    Ultima modifica fatta da:Gerardo Zuccalà; 01/08/15 alle 12:44

  2. #2
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15
    Io avrei messo in D2:=CONTA.PIÙ.SE($A$2:$A$10;$D$2)
    e in E2:=CONTA.PIÙ.SE($A$2:$A$10;$E$2)

    Però mi sembra troppo semplice

    Ci arrivo io............

  3. #3
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15
    Questa formula copiata in D6 Và bene....
    =SE.ERRORE(INDICE(B$2:B$10;AGGREGA(15;6;(RIF.RIGA($B$2:$B$10)-RIF.RIGA($B$2)+1)/($A$2:$A$10=$D$2);RIGHE(A$2:A2)));"")

    Però non mi tiene conto del secondo criterio
    sono a metà dell opera.........:235:

  4. #4
    L'avatar di Beppe
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Brescia
    Età
    37
    Messaggi
    78
    Versione Office
    2010 Win
    Likes ricevuti
    1
    Citazione Originariamente Scritto da nick0573 Visualizza Messaggio
    Questa formula copiata in D6 Và bene....
    =SE.ERRORE(INDICE(B$2:B$10;AGGREGA(15;6;(RIF.RIGA($B$2:$B$10)-RIF.RIGA($B$2)+1)/($A$2:$A$10=$D$2);RIGHE(A$2:A2)));"")

    Però non mi tiene conto del secondo criterio
    sono a metà dell opera.........:235:
    sei al 99.999999% dell'opera!!!!!
    invece di $D$2 prova D$2.
    Credo sia quello...
    Spero di non aver scritto una fesseria :251:
    Windows 7
    Office 2010

  5. #5
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15
    Grande beppe
    :285:
    windows 10
    Excel 2016

  6. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da nick0573 Visualizza Messaggio
    Io avrei messo in D4:=CONTA.PIÙ.SE($A$2:$A$10;$D$2)
    e in E4:=CONTA.PIÙ.SE($A$2:$A$10;$E$2)

    Però mi sembra troppo semplice

    Ci arrivo io............
    Ciao Nick Complimenti per il tuoExcel stai facendo passi da gigante
    Comunque non hai bisogno di fare la seconda formula in (E4) perchè se semplicemente metti i riferimenti di cella giusti nella formula in D4
    trascini la formula verso destra e il gioco è fatto

    =CONTA.PIÙ.SE($A$2:$A$10;D2)

    =SE.ERRORE(INDICE(B$2:B$10;AGGREGA(15;6;(RIF.RIGA($B$2:$B$10)-RIF.RIGA($B$2)+1)/($A$2:$A$10=$D$2);RIGHE(A$2:A2)));"")
    anche questa in D6 se ottimizzi i riferimenti di cella riesci a copiare verso il basso e a destra in una formula unica

    =SE.ERRORE(INDICE($B$2:$B$10;AGGREGA(15;6;(RIF.RIGA($B$2:$B$10)-RIF.RIGA($B$2)+1)/($A$2:$A$10=D$2);RIGHE(A$2:A2)));"")

  7. #7
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15
    Grazie

    Ho tantissimo da imparare da voi........
    windows 10
    Excel 2016

Discussioni Simili

  1. [Risolto] Contare con più criteri
    Di Roker1 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 10/10/16, 11:26
  2. BLOCCARE immagini e oggetti in power point
    Di giampix74 nel forum Domande su Microsoft Power Point
    Risposte: 8
    Ultimo Messaggio: 29/09/16, 19:25
  3. cambio colore oggetti
    Di morenomax nel forum Domande su Excel VBA e MACRO
    Risposte: 21
    Ultimo Messaggio: 25/03/16, 19:27
  4. Estrarre numeri con criteri
    Di BRAZ66 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 01/08/15, 16:13

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •