Risultati da 1 a 4 di 4

Discussione: Cerco formula per tagliare una riga del foglio1 quando viene convalidata e copiarla nel foglio2



  1. #1
    L'avatar di belin.ago
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    genova
    Età
    49
    Messaggi
    11
    Versione Office
    2010
    Likes ricevuti
    1

    Cerco formula per tagliare una riga del foglio1 quando viene convalidata e copiarla nel foglio2

    Ciao a tutti,
    La mia richiesta sarebbe la seguente: trovare la giusta formula per tagliare una riga del foglio1 quando viene convalidata in apposita cella e copiarla nel foglio2 in modo sequenziale.
    Es: =SE($D$2="SI";TAGLIA RIGA$2 DEL FOGLIO1 E COPIA IN PRIMA RIGA LIBERA DEL FOGLIO2)

    Allego file esempio grazie in anticipo
    File Allegati File Allegati

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923

    Re: Cerco formula per tagliare una riga del foglio1 quando viene convalidata e copiarla nel foglio2

    Ciao,
    quello che chiedi (tagliare la riga ed incollarla) secondo me puoi farlo solo in VBA....
    Con le formule puoi fare qualcosa di simile, ma nel primo foglio i dati non devono essere cancellati.

    Nella cella A2 del foglio "ARCHIVIO" inerisci questa formula matriciale (quindi da confermare con la combinazione di tasti CTRL+MAIUSC+INVIO), e dopo copia in basso e a destra:

    =SE.ERRORE(INDICE(DATABASE!$A$1:$D$100;PICCOLO(SE(DATABASE!$D$1:$D$100="SI";RIF.RIGA($D$1:$D$100);"");RIF.RIGA(A1));RIF.COLONNA(A1));"")


    Ti riallego il file...
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. I seguenti 2 utenti hanno dato un "Like" a cromagno per questo post:


  4. #3
    L'avatar di belin.ago
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    genova
    Età
    49
    Messaggi
    11
    Versione Office
    2010
    Likes ricevuti
    1

    Re: Cerco formula per tagliare una riga del foglio1 quando viene convalidata e copiarla nel foglio2

    Grazie cromagno,
    mi adopero subito, e non è detto che possa interessarmi anche al VBA.
    tempestivo e preciso, buon proseguimento

  5. #4
    L'avatar di belin.ago
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    genova
    Età
    49
    Messaggi
    11
    Versione Office
    2010
    Likes ricevuti
    1

    Re: Cerco formula per tagliare una riga del foglio1 quando viene convalidata e copiarla nel foglio2

    grazie mille molto gentile.

Discussioni Simili

  1. [Risolto] Formula per tagliare dati
    Di g8trading nel forum Domande su Excel in generale
    Risposte: 19
    Ultimo Messaggio: 14/01/17, 22:15
  2. [Risolto] Funzione ripetuta su Foglio1 usando tabelle fisse del foglio2
    Di EnzoNN nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 27/11/16, 12:05
  3. [Risolto] cerco formula per confronto tra 2 file
    Di stardust978 nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 21/11/16, 17:32
  4. [Risolto] Cerco la formula giusta
    Di stefanoste78 nel forum Domande su Excel in generale
    Risposte: 16
    Ultimo Messaggio: 15/11/16, 12:07
  5. Inserire una textbox che appaia quando la cella viene compilata.
    Di MrFaMa nel forum Domande su Excel VBA e MACRO
    Risposte: 16
    Ultimo Messaggio: 17/02/16, 18:18

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •