Risultati da 1 a 11 di 11

Discussione: Funzione un pò troppo lunga con molti SE, E e SOMMA



  1. #1
    ProgrammD69
    Ospite L'avatar di ProgrammD69

    Funzione un pò troppo lunga con molti SE, E e SOMMA

    Buonasera,
    in allegato un file dove trovate una funzione lunga 4 righe della barra della formula per ottenere un Totale parziale in una tabella.

    L'ispirazione mi è venuta dopo aver visto il tutorial EM#3 di Gerardo.

    L'aiuto che mi serve è: riuscire a trovare una formula o codice VBA per abbreviare la formula che ho creato, anche se funziona correttamente.

    Saluti a tutti.
    File Allegati File Allegati

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299

    Re: Funzione un pò troppo lunga con molti SE, E e SOMMA

    Ciao,
    non voglio darti la soluzione completa visto che vuoi imparare, e quindi, provo a farti ragionare.

    Ti ho messo la formula in B22

    =SOMMA(INDICE($B$8:$B$17;CONFRONTA(A4;A8:A17;0)):INDICE($B$8:$M$17;CONFRONTA(A4;A8:A17;0);CONFRONTA(B3;$B$7:$M$7;0)))

    Prova a adattarla inserendola nella colonna O (TOTALE PARZ.)
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    ProgrammD69
    Ospite L'avatar di ProgrammD69

    Re: Funzione un pò troppo lunga con molti SE, E e SOMMA

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao,
    non voglio darti la soluzione completa visto che vuoi imparare, e quindi, provo a farti ragionare.

    Ti ho messo la formula in B22

    =SOMMA(INDICE($B$8:$B$17;CONFRONTA(A4;A8:A17;0)):INDICE($B$8:$M$17;CONFRONTA(A4;A8:A17;0);CONFRONTA(B3;$B$7:$M$7;0)))

    Prova a adattarla inserendola nella colonna O (TOTALE PARZ.)
    Dopo aver visto tre video di Gerardo (davvero ottimi video, complimenti !!) e cioè EP 20, EP 21 e EP 22 sulla funzioni di ricerca, e dopo aver visto bene la tua formula, ho risolto subito.
    Qui di seguito la formula da mettere nella colonna TOTALE PARZ :

    =SE(P6="";"";SOMMA(INDICE($C$6:$C$17;CONFRONTA($B$3;$B$6:$B$17)):INDICE($C$6:$N$17;CONFRONTA($B$3;$B$6:$B$17;0);CONFRONTA($C$2;$C$5:$N$5;0))))

    Rispetto al file che ho allegato, i riferimenti di cella vanno adeguati, dato mi sono esercitato su un altro foglio.

    Ringrazio dell'aiuto.
    Saluti.

  5. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299

    Re: Funzione un pò troppo lunga con molti SE, E e SOMMA

    Bene, alla prossima!
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. #5
    ProgrammD69
    Ospite L'avatar di ProgrammD69

    Re: Funzione un pò troppo lunga con molti SE, E e SOMMA

    Come già detto la formula funziona, ma solo in una casella. Non sono riuscito a farla diventare una formula dinamica, lungo la colonna del TOTALE PARZIALE.

    Le formule esatte sono:
    Codice HTML: 
    =SOMMA(INDICE($C$6:$C$17;CONFRONTA($B$3;B6:B17)):INDICE($C$6:$N$17;CONFRONTA($B$3;B6:B17;0);CONFRONTA($C$2;$C$5:$N$5;0)))
    e con la funzione se.errore
    Codice HTML: 
    =SE.ERRORE(SOMMA(INDICE($C$6:$C$17;CONFRONTA($B$3;B6:$B17)):INDICE($C$6:$N$17;CONFRONTA($B3;B6:$B17;0);CONFRONTA($C$2;$C5:$N5;0)));"")
    Non appena riesco a risolvere il caso, aggiorno la discussione.



    P.S.: la formula postata al #3 non funziona.

  7. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299

    Re: Funzione un pò troppo lunga con molti SE, E e SOMMA

    Sono sicuro che ci riesci ... è più facile di quanto sembra ...

    Ti allego file con formula nascosta .... la soluzione la devi trovare tu!
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  8. #7
    ProgrammD69
    Ospite L'avatar di ProgrammD69

    Re: Funzione un pò troppo lunga con molti SE, E e SOMMA

    Non ho ancora visionato il nuovo file di GES.

    Da me mi sono ricavato una funzione dinamica, quasi performante. Il quasi è dovuto al limite della funzione Confronta() che nel conteggiare dall'alto verso il basso si ferma al primo valore Vero (vedi tutorial di Gerardo Excel in Pillole n.20).

    La formula è:
    Codice HTML: 
    =SE.ERRORE(SOMMA(INDICE($C$6:$C17;CONFRONTA($B$3;$B$6:$B$17;0)):INDICE($C$6:$N$17;CONFRONTA($B$3;$B$6:$B6;0);CONFRONTA($C$2;$C$5:$N$5;0)));"")
    Si deve cambiare la formula Confronta() con qualcun altra ?

  9. #8
    ProgrammD69
    Ospite L'avatar di ProgrammD69

    Re: Funzione un pò troppo lunga con molti SE, E e SOMMA

    In allegato un file che riepiloga a che punto sono arrivato.
    In breve, per completare il lavoro devo far in modo che nella colonna "altra formula" (colonne Q, R e S, a fianco di TOTALE PARZ) l'importo del totale parziale non abbia sotto di se altri importi come si vede nel foglio di lavoro, ma il risultato dev'essere uguale a quello che si vede nella colonna TOTALE PARZ che ho ottenuto con una formula molto lunga.

    Qualche piccolo suggerimento ?
    File Allegati File Allegati

  10. #9

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299

    Re: Funzione un pò troppo lunga con molti SE, E e SOMMA

    Faccio solo una piccola aggiunta.

    =SE($B$3=B6;SE.ERRORE(SE(E(CONFRONTA($C$2;$C$5:$N$5;0);CONFRONTA($B$3;$B$6:B6;0));SOMMA(INDICE($C$6:C6;CONFRONTA($B$3;$B$6:B6;0)):INDICE($C$6:$N$17;CONFRONTA($B$3;$B$6:B6;0);CONFRONTA($C$2;$C$5:$N$5;0)));"");"");"")

    =SE($B$3=B6;SE.ERRORE(SOMMA(INDICE($C$6:C6;CONFRONTA($B$3;$B$6:B6;0)):INDICE($C$6:N6;CONFRONTA($B$3;$B$6:B6;0);CONFRONTA($C$2;$C$5:$N$5;0)));"");"")

    =
    SE($B$3=B6;SE.ERRORE(SUBTOTALE(9;(INDICE($C$6:C6;CONFRONTA($B$3;$B$6:B6;0)):INDICE($C$6:$N$17;CONFRONTA($B$3;$B$6:B6;0);CONFRONTA($C$2;$C$5:$N$5;0))));"");"")


    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  11. #10
    ProgrammD69
    Ospite L'avatar di ProgrammD69

    Re: Funzione un pò troppo lunga con molti SE, E e SOMMA

    La formula funziona !!!!
    Grazie dell'aiuto.

    Saluti.

  12. #11

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299

    Re: Funzione un pò troppo lunga con molti SE, E e SOMMA

    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  13. I seguenti utenti hanno dato un "Like"


Discussioni Simili

  1. Funzione IF con una somma.
    Di Laura Belli nel forum Domande su Excel VBA e MACRO
    Risposte: 46
    Ultimo Messaggio: 26/03/17, 01:31
  2. [Risolto] Ricerca carattere in determinata posizione in un testo che ne contiene molti uguali
    Di Ciccio nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 31/01/17, 17:48
  3. Formula della serie troppo lunga per grafico a torta
    Di wichwetyl nel forum Domande sui Grafici di Excel
    Risposte: 3
    Ultimo Messaggio: 05/01/17, 19:03
  4. Formula troppo lunga per timer
    Di angelix nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 07/12/16, 21:09
  5. Funzione Giorno.Lavorativo somma Ore
    Di CrazyTony nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 30/03/16, 20:47

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •