Risultati da 1 a 4 di 4

Discussione: Controllo formula MATR.SOMMA.PRODOTTO bis



  1. #1
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Controllo formula MATR.SOMMA.PRODOTTO bis

    Ciao a tutti,
    continua il mio rapporto conflittuale con la formula MATR.SOMMA.PRODOTTO. Il tutto aggravato dalla presenza di celle unite (Gerardo, Ninai --!!Perdono!!).

    In breve nella colonna R del foglio Dashboard vorrei sommare i tempi di fermo (colonna R del foglio Analisi) tenendo conto delle due date in D2 e D3 del foglio Dashboard.
    La formula usata è:
    Codice: 
    =MATR.SOMMA.PRODOTTO((Analisi!$M$2:$M$70000=$B9)*(DataDB_cuc>=$D$2)*(DataDB_cuc<=$D$3)*(Analisi!$L$2:$L$70000=R$8)*Analisi!$R$2:$R$70000)
    Ma non ottengo i dati attesi:
    Esempio:
    H-C8 : 2:42:00
    J-C13 : 1:19:00
    H-C8 : 2:42:00
    K-C14 : 0:23:00
    L-C9 : 1:27:00
    M-C10 : 2:06:00

    https://www.dropbox.com/s/1n2kv5ksmn...orum.xlsm?dl=0

    Grazie in anticipo
    Gene

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296

    Re: Controllo formula MATR.SOMMA.PRODOTTO bis

    Ciao Gene,
    hai nominato degli intervalli e purtroppo con excel per Mac non me li fa vedere .... in particolare, non so a quale intervallo si riferisce il nome "DataDB_cuc" ... l'errore è proprio qui!
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. I seguenti utenti hanno dato un "Like"


  4. #3

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923

    Re: Controllo formula MATR.SOMMA.PRODOTTO bis

    Ciao a tutti,

    @G.Bove
    come detto da ges (un saluto) il problema è per l'appunto in quegli intervalli nominati....

    Nella formula stai moltiplicando degli intervalli fissi (es. Analisi!$M$2:$M$70000) con degli intervalli variabili, che dipendono dalla formula usata per il nome definito DataDB_cuc (che prende come ultima riga, l'ultima riga del foglio "Analisi", che non è sempre 70000).

    Prova a modificare la formula in questo modo (nella cella R9 e copiare in basso) :

    =MATR.SOMMA.PRODOTTO((Analisi!$M$2:$M$500=$B9)*(Analisi!$P$2:$P$500>=$D$2)*(Analisi!$P$2:$P$500<=$D$3)*(Analisi!$L$2:$L$500=R$8)*Analisi!$R$2:$R$500)


    Ho usato 500 anzichè 70000 per poter verificare la formula più velocemente.

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  5. I seguenti 2 utenti hanno dato un "Like" a cromagno per questo post:


  6. #4
    L'avatar di G.Bove
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    51
    Messaggi
    870
    Versione Office
    2010
    Likes ricevuti
    24
    Likes dati
    186

    Re: Controllo formula MATR.SOMMA.PRODOTTO bis

    [RISOLTO]
    Azz..... Ci sono ricascato .

    Grazie.
    Gene

Discussioni Simili

  1. Controllo formula MATR.SOMMA.PRODOTTO
    Di G.Bove nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 21/06/16, 09:57
  2. Matr.somma.prodotto
    Di Khan nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 29/03/16, 13:33
  3. =matr.somma.prodotto()
    Di marigenny nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 11/11/15, 12:59
  4. matr.somma.prodotto
    Di Alessandro nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 19/10/15, 17:52
  5. Risposte: 16
    Ultimo Messaggio: 25/08/15, 10:05

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •