Risultati da 1 a 7 di 7

Discussione: Funzione indice/confronta all'interno della Funzione "O" ed "E"



  1. #1
    L'avatar di Rosaria79
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Ferrara
    Messaggi
    36
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    0

    Funzione indice/confronta all'interno della Funzione "O" ed "E"

    Salve a tutti!

    ho un problema con la funzione INDICE/CONFRONTA che vorrei inserire all'interno della seguente formula della colonna P7:P37:

    =SE.ERRORE(SE(E(C7<>"do";K7>J7;W7<>$Y$7;W7<>$Y$10);(RESTO(E7-D7;1)*24-(E7<D7)*(22-6)+MEDIANA(6;22;D7*24)-MEDIANA(6;22;E7*24))/24;SE(E(C7="do";W7<>$Y$7;W7<>$Y$10);RESTO(K7-Q7;1);""));"")

    La formula fa una distinzione tra festivi e feriali. Nei festivi, oltre alle domeniche vorrei inserire anche le festività elencate nella colonna AB9:AB20, Iil tutto all'interno di una funzione "O":

    =SE(O(C7<>"domenica";B7<>l'indice dei festivi elencati nella colonna AB9:AB20; E(K7>J7;W7<>$Y$7;W7<>$Y$10);
    allora (RESTO(E7-D7;1)*24-(E7<D7)*(22-6)+MEDIANA(6;22;D7*24)-MEDIANA(6;22;E7*24))/24;

    non riesco proprio a capire dove sbaglio.

    Allego il file di riferimento.

    Grazie mille come sempre

  2. #2
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: Funzione indice/confronta all'interno della Funzione "O" ed "E"

    Ciao Rosaria79, se ho capito bene, la formula andrebbe strutturata nel modo seguente:

    In :
    =SE.ERRORE(SE(O(E(C7<>"domenica";K7>J7;W7<>$Y$7;W7<>$Y$10);E(B7<>INDICE($AB$9:$AB$20;CONFRONTA());K7>J7;W7<>$Y$7;W7<>$Y$10));(RESTO(E7-D7;1)*24-(E7<D7)*(22-6)+MEDIANA(6;22;D7*24)-MEDIANA(6;22;E7*24))/24;SE(O(E(C7="domenica";W7<>$Y$7;W7<>$Y$10);E(B7=INDICE($AB$9:$AB$20;CONFRONTA());K7>J7;W7<>$Y$7;W7<>$Y$10));RESTO(K7-Q7;1);""));"")
    faccio presente che mancano i termini della funzione confronta, che non so da dove prendere.
    La cosa più opportuna sarebbe quella di allegare un file con pochi dati ( non sensibili ).
    Spero di esserti stato utile.
    Ciao.

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7115
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1296

    Re: Funzione indice/confronta all'interno della Funzione "O" ed "E"

    Citazione Originariamente Scritto da Rosaria79 Visualizza Messaggio
    .....
    Allego il file di riferimento.

    ....
    Manca il file!
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. #4
    L'avatar di Rosaria79
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Ferrara
    Messaggi
    36
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    0

    Re: Funzione indice/confronta all'interno della Funzione "O" ed "E"

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Manca il file!
    Hai ragione ges...la fretta porta sempre a sbagliare!

    Pkrome59 ho provato la tua formula ma non funziona.

    Adesso vi allego il file!

    In pratica la formula inserita nella colonna p7:p37 è giusta così come l'ho scritta, ma tiene conto solo delle domeniche e non delle giornate festive. Ecco..io vorrei aggiungere alla funzione SE(O(C7<>"domenica" oppure b7= ad una delle festività elencate nella colonna AB9:AB20, E(K7>J7;W7<>$Y$7;W7<>$Y$10);Resto...

    Io l'ho scritta così ma non funziona

    =SE.ERRORE(SE(O(C7<>"do";non(confronta(B7;$AB$9:$AB$20;0));E(K7>J7;W7<>$Y$7;W7<>$Y$10));(RESTO(E7-D7;1)*24-(E7<D7)*(22-6)+MEDIANA(6;22;D7*24)-MEDIANA(6;22;E7*24))/24;SE(O(C7="do";confronta(B7;AB$9:$AB$20;0);E(W7<>$Y$7;W7<>$Y$10));RESTO(K7-Q7;1);"");"")
    File Allegati File Allegati

  5. #5
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: Funzione indice/confronta all'interno della Funzione "O" ed "E"

    Ciao Rosaria79, francamente ho dei dubbi, perché visto il file, e apportate le modifiche alla formula che ti avevo suggerito, vedo che ottengo gli stessi valore che ottieni tu con la formula precedente.
    Comunque ho inserito in AC7 la Seguente:
    In CA7:
    =SE.ERRORE(SE(O(E(C7<>"do";K7>J7;W7<>$Y$7;W7<>$Y$10);SE.ERRORE(E(B7<>INDICE($AB$9:$AB$20;CONFRONTA(B7;$AB$9:$AB$20;0));K7>J7;W7<>$Y$7;W7<>$Y$10);0));(RESTO(E7-D7;1)*24-(E7<D7)*(22-6)+MEDIANA(6;22;D7*24)-MEDIANA(6;22;E7*24))/24;SE(O(E(C7="do";W7<>$Y$7;W7<>$Y$10);SE.ERRORE(E(B7=INDICE($AB$9:$AB$20;CONFRONTA(B7;$AB$9:$AB$20;0));K7>J7;W7<>$Y$7;W7<>$Y$10);0));RESTO(K7-Q7;1)));"")
    da tirare giù, allego il file di prova, fammi sapere qualcosa.
    Ciao.
    File Allegati File Allegati

  6. #6

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1011
    Versione Office
    .
    Likes ricevuti
    365
    Likes dati
    0

    Re: Funzione indice/confronta all'interno della Funzione "O" ed "E"

    Citazione Originariamente Scritto da Rosaria79 Visualizza Messaggio
    In pratica la formula inserita nella colonna p7:p37 è giusta così come l'ho scritta, ma tiene conto solo delle domeniche e non delle giornate festive. Ecco..io vorrei aggiungere alla funzione SE(O(C7<>"domenica" oppure b7= ad una delle festività elencate nella colonna AB9:AB20, E(K7>J7;W7<>$Y$7;W7<>$Y$10);Resto...
    Quindi vorresti che anche il 6 gennaio calcolasse 14:00 in P12 e 1 in Q12?

    Premesso che devi modificare anche la formula in colonna Q, prova così (scritte al volo, senza entrare nel merito delle altre formule/calcoli, quindi da verificare):
    In P7::
    =SE.ERRORE(SE(E(C7<>"do";SE.ERRORE(CONFRONTA(B7;Impostazioni!H8:H19;0);0)=0;K7>J7;W7<>$Y$7;W7<>$Y$10);(RESTO(E7-D7;1)*24-(E7<D7)*(22-6)+MEDIANA(6;22;D7*24)-MEDIANA(6;22;E7*24))/24;SE(E(O(C7="do";SE.ERRORE(CONFRONTA(B7;Impostazioni!H8:H19;0);0)>0);W7<>$Y$7;W7<>$Y$10);RESTO(K7-Q7;1);""));"")

    in Q7::
    =SE(O(C7="do";SE.ERRORE(CONFRONTA(B7;Impostazioni!H8:H19;0);0)>0);(RESTO(E7-D7;1)*24-(E7<D7)*(22-6)+MEDIANA(6;22;D7*24)-MEDIANA(6;22;E7*24))/24;"")
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  7. I seguenti utenti hanno dato un "Like"


  8. #7
    L'avatar di Rosaria79
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    Ferrara
    Messaggi
    36
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    0

    Re: Funzione indice/confronta all'interno della Funzione "O" ed "E"

    Citazione Originariamente Scritto da pkrome59 Visualizza Messaggio
    Ciao Rosaria79, francamente ho dei dubbi, perché visto il file, e apportate le modifiche alla formula che ti avevo suggerito, vedo che ottengo gli stessi valore che ottieni tu con la formula precedente.
    Comunque ho inserito in AC7 la Seguente:
    In CA7:
    =SE.ERRORE(SE(O(E(C7<>"do";K7>J7;W7<>$Y$7;W7<>$Y$10);SE.ERRORE(E(B7<>INDICE($AB$9:$AB$20;CONFRONTA(B7;$AB$9:$AB$20;0));K7>J7;W7<>$Y$7;W7<>$Y$10);0));(RESTO(E7-D7;1)*24-(E7<D7)*(22-6)+MEDIANA(6;22;D7*24)-MEDIANA(6;22;E7*24))/24;SE(O(E(C7="do";W7<>$Y$7;W7<>$Y$10);SE.ERRORE(E(B7=INDICE($AB$9:$AB$20;CONFRONTA(B7;$AB$9:$AB$20;0));K7>J7;W7<>$Y$7;W7<>$Y$10);0));RESTO(K7-Q7;1)));"")
    da tirare giù, allego il file di prova, fammi sapere qualcosa.
    Ciao.

    Ciao pkrome59,
    la formula che mi hai indicato purtroppo non funziona.

    Quindi vorresti che anche il 6 gennaio calcolasse 14:00 in P12 e 1 in Q12?

    Premesso che devi modificare anche la formula in colonna Q, prova così (scritte al volo, senza entrare nel merito delle altre formule/calcoli, quindi da verificare):
    In P7::
    =SE.ERRORE(SE(E(C7<>"do";SE.ERRORE(CONFRONTA(B7;Impostazioni!H8:H19;0);0)=0;K7>J7;W7<>$Y$7;W7<>$Y$10);(RESTO(E7-D7;1)*24-(E7<D7)*(22-6)+MEDIANA(6;22;D7*24)-MEDIANA(6;22;E7*24))/24;SE(E(O(C7="do";SE.ERRORE(CONFRONTA(B7;Impostazioni!H8:H19;0);0)>0);W7<>$Y$7;W7<>$Y$10);RESTO(K7-Q7;1);""));"")

    in Q7::
    =SE(O(C7="do";SE.ERRORE(CONFRONTA(B7;Impostazioni!H8:H19;0);0)>0);(RESTO(E7-D7;1)*24-(E7<D7)*(22-6)+MEDIANA(6;22;D7*24)-MEDIANA(6;22;E7*24))/24;"")
    Invece scossa la tua formula funziona benissimo!
    Tra l'altro mi sono accorta adesso che la formula in P7 l'avevo fatta giusta anche io ma non avendo modificato Q7 non mi ero accorta della soluzione.
    In ogni modo grazie mille a tutti voi!

Discussioni Simili

  1. [Risolto] Ordinare con la funzione "piccolo"..ma "portandosi dietro" anche altri dati affiancati
    Di mauri73 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 05/02/17, 14:57
  2. [Risolto] Come leggere la seguente formula =SE.ERRORE(INDIRETTO("'"&A1&"'!K1";1);""))
    Di sitolofi nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 20/12/16, 14:54
  3. Menù dinamico, con Convalida Dati con funzione indiretta e condizione "se"
    Di corradoverse nel forum Domande su Excel VBA e MACRO
    Risposte: 5
    Ultimo Messaggio: 12/09/16, 13:00
  4. Come inserire il "formato" in una formula INDICE E CONFRONTA già esistente
    Di giteti58 nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 11/09/16, 01:27
  5. >Come estrappolare la somma "automatica" di un DB con funzione "FILTRO"<
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 11/06/16, 11:44

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •