Risultati da 1 a 6 di 6

Discussione: Collegamento dati/celle



  1. #1
    L'avatar di miki2303
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Ragusa
    Età
    43
    Messaggi
    3
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    1

    Collegamento dati/celle

    Salve a tuttil mio quesito riguarda il collegamento di dati in celle diverse partendo da una cella "madre", cercherò di spiegrmi meglio
    Ho creato un file excel chiamato Format (foglio di lavoro con lo stesso nome), ipotizziamo di avere nella cella C7 un menù a tendina con le seguenti informazioni (Immobile 1;Immobile 2;Immobile 3 ecc.), ad ogni immobile corrisponde un codice immobile, un comune ed un indirizzo di ubicazione, dati che vorrei evitare di trascrivere ogni volta e che gradirei mi venissero restituiti in automatico scegliendo la sola voce dal menù a tendina. Ad es. cliccando su "Immobile 1" nella sopra descritta cella C7 vorrei mi venisse restituito il relativo codice immobile nella cella G7, il Comune di appartenenza dello stesso immobile nella cella C9 e il rispettivo indirizzo nella cella G9. Ho caricato un allegato (anche se solo parzialmente completo dovrebbe aiutare a capire il mio problema)Ringrazio tutti in anticipo per l'aiuto
    File Allegati File Allegati

  2. #2
    L'avatar di dracoscrigno
    Clicca e Apri
    Data Registrazione
    May 2016
    Località
    ferrara
    Età
    41
    Messaggi
    2074
    Versione Office
    office pro 2010
    Likes ricevuti
    440
    Likes dati
    241

    Re: Collegamento dati/celle

    Sicuramente, la prima cosa che devi fare, è avere un foglio come base di dati, mi pare che ora sia il foglio 2, che non abbia celle unite, le quali, servono solo a fare impazzire che deve poi scrivere una macro od impostare una formula ;)
    La base dei dati deve essere uno spartano foglio quadrettato dove sono i dati ad essere ordinati e non il foglio ;)

    Le altre cose che non sono la base dei dati si chiamano maschere e servono a render i dati appetibili all' occhio umano. Ecco, nelle maschere ci puoi infilare anche il calendario della bellissima Jaimie Alexander

    a parte questo, le mie modestissime capacità di formularo mi fan pensare che una volta che avrai un intabellamento dei dati allora con il cerca verticale potrai impostare tutte le celle collegate alla C7

    Avrai una tabellina con:
    la colonna dei dati che va in G7, la colonna dei dati che va in G8, la colonna dei dati che va in G) e così via per tutti i dati che corrispondono allo stesso record.
    Poi, metti ogni campo nella tua maschera dove meglio credi

  3. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Collegamento dati/celle

    Ciao Miky benvenuto in forumexcel.it
    In parte ti ha risposto Draco (Un saluto) infatti ha detto che
    con il cerca verticale potrai impostare tutte le celle collegate alla C7
    E quindi come prima cosa dovresti preparare una tabella che io ho messo nel foglio chiamato "Servizio" che sarà il foglio di input per tutte le formule successive

    Fai attenzione a due cose
    1) non usare celle unite, excel vede le celle unite come fumo negli occhi e molte volte le formule non funzionano

    2) Ho messo il campo "Unita operativa" come primo campo sulla sinistra della tabella cosi da essere prnta per poter lavorare con il CERCA.VERT

    Tutto i resto è facile
    Esempio

    A
    B
    C
    D
    2
    Unità operativa Cod. immobile Comune Indirizzo
    3
    Unicredit Modica Sorda Sampieri
    238314
    Milano Via…
    4
    Unicredit Vittoria Cancellieri
    102299
    Napoli Piazza
    5
    Tizio
    2365
    Torino Via…
    6
    Caio
    365
    Palermo Piazza
    7
    Sempronio
    325
    Genova Via…
    8
    Rossi
    365
    Bologna Piazza
    9
    Bianchi
    258
    Firenze Via…
    10
    verdi
    369
    Bari Piazza
    11
    Zuccu
    547
    Catania Via…
    12
    Duppu
    589
    Venezia Piazza
    13
    Zan
    1547
    Verona Via…
    14
    DAP
    589
    Messina Piazza
    15
    Pak
    248
    Padova Via…
    16
    Ind
    248
    Trieste Piazza
    17
    Brambilla
    12548
    Taranto Via…
    18
    Musumeci
    125478
    Brescia Piazza
    19
    Esposito
    25489
    torino Via…
    20
    Soldo
    36523
    Milano Piazza
    21
    lira
    36214
    Vicenza Via…
    22
    Sterlina
    1254889
    Lecce Piazza
    Sheet: Servizio
    File Allegati File Allegati
    Ultima modifica fatta da:Gerardo Zuccalà; 26/06/16 alle 20:34

  4. #4
    L'avatar di miki2303
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Ragusa
    Età
    43
    Messaggi
    3
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    1

    Re: Collegamento dati/celle

    ringrazio entrambi per la tempestiva e dettagliata risposta, anche se purtroppo non sono stato comunque capace di risolvere il problema, provo ad inserire la formula con il cerca.vert ma mi da sempre errore, sicuramente sbaglio qualcosa. Ho ulteriormente completato il mio format creando un foglio come base dati che ho chiamato Dati sorgente, il risultato che vorrei ottenere io è tutto nel foglio Format dove, scegliendo un codice dal menù a tendina della cella B7 (ad es. 101444) mi compaia in automatico Unicredit Pozzallo nella cella F7, Pozzallo nella cella B9, e C.so Vittorio Veneto, 2 nella cella F9 e così via cambiando il codice immobile scelto dal menù a tendina. Ho fatto una miriade di tentativi..ma niente, non ho mai usato prima la funzione cerca.vert e quindi non la conosco ancora bene
    Grazie comunque a entrambi...ci riuscirò prima o poi
    File Allegati File Allegati

  5. #5
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2072
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117

    Re: Collegamento dati/celle

    ciao

    in F7
    Codice: 
    =INDICE('Dati sorgente'!B2:B21;CONFRONTA(B7;'Dati sorgente'!A2:A21;0))
    uguale a
    Codice: 
    =CERCA.VERT(B7;'Dati sorgente'!A2:D21;2;FALSO)
    in B9
    Codice: 
    =INDICE('Dati sorgente'!C2:C21;CONFRONTA(B7;'Dati sorgente'!A2:A21;0))
    uguale a
    Codice: 
    =CERCA.VERT(B7;'Dati sorgente'!A2:D21;3;FALSO)
    in F9
    Codice: 
    =INDICE('Dati sorgente'!D2:D21;CONFRONTA(B7;'Dati sorgente'!A2:A21;0))
    uguale a
    Codice: 
    =CERCA.VERT(B7;'Dati sorgente'!A2:D21;4;FALSO)
    ciao

  6. I seguenti 2 utenti hanno dato un "Like" a Gianfranco55 per questo post:


  7. #6
    L'avatar di miki2303
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Ragusa
    Età
    43
    Messaggi
    3
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    1

    Re: Collegamento dati/celle

    Un grazie davvero di cuore...mi hai risolto un bel problema,grande Gianfranco55 e grande tutto il forum

Discussioni Simili

  1. Collegamento celle tra file diversi
    Di simone gagli nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 14/02/17, 17:52
  2. Risposte: 3
    Ultimo Messaggio: 14/11/16, 22:00
  3. Risposte: 33
    Ultimo Messaggio: 17/10/16, 22:42
  4. collegamento file
    Di Nick___92 nel forum Domande su Excel in generale
    Risposte: 0
    Ultimo Messaggio: 15/06/16, 20:24
  5. Collegamento tra 2 fogli
    Di pippo2019 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 09/10/15, 13:26

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •