Risultati da 1 a 7 di 7

Discussione: Problema con formula matriciale



  1. #1
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Binasco
    Età
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Problema con formula matriciale

    Ciao a tutti
    Ho un problema con la una formula nel post numero17
    http://www.forumexcel.it/forum/7-dom...cro/3736-macro

    Dall' allegato, in Team 1 range(I7:L13)
    Le date sono formattate come numero, se le formatto come DATA. Quei Zeri in colonna L diventano 00/01/1900
    Ho provato fare un controllo e per non farlo pesare troppo, ho usato la matriciale per ottenere solo i numeri della colonna A. Ora in Team 1, cella B7 metto =SE.ERRORE(INDIRETTO("'GIU2016'!B"&8);""). Quando arrivo in L7, non riesco combinare la formula >>>se la cella relativa in "GIU2016" è vuota = "" & SE.ERRORE(INDIRETTO("'GIU2016'!L"&8);"")<<< provato anche con val.errore

    Inoltre vorrei chiedere una variante se possibile.
    Se scrivo in B1 =INDIRETTO("'GIU2016'!L$8:L"&CONTA.VALORI(E:E)+6)
    Come posso riscrivere tale formula riferendomi alla cella B1
    =SE.ERRORE(INDICE('GIU2016'!A$8:A$29;PICCOLO(SE('GIU2016'!$H$8:$H$29='TEAM 1'!$A$2;RIF.RIGA('GIU2016'!A$8:A$29)-RIF.RIGA('GIU2016'!A$8)+1);RIGHE($A$7:A7)));"")

    Ps. Che io sappia su File chiusi (senza VBA), funziona solo il =MATR.SOMMA.PRODOTTO() o sbaglio?
    Grazie in anticipo
    Ultima modifica fatta da:Raffaele_53; 29/06/16 alle 03:25

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202

    Re: Problema con formula matriciale

    Ciao Raffaele,

    senza modificare le formule potresti impostare un formato personalizzato del tipo

    "gg/mm/aaaa;;"

    oppure da Opzioni/Impostazioni avanzate sotto "Opzioni di visualizzazione per il foglio lavoro" deselezionare "Visualizza zero nelle celle con valore zero".

    Non ho capito la seconda parte. INDIRETTO - se non è stato riprogrammato nelle ultime versioni di Excel - non legge file chiusi.

    Saluti

  3. #3
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Binasco
    Età
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: Problema con formula matriciale

    Ciao Canapone e grazie mille
    OK, avevo letto mà non ho mai fatto "Opzioni/Impostazioni...deselezionare "Visualizza zero...".
    Con le matriciali sono ZERO
    Però se scrivo in B1 il tutto ex INDIRETTO('GIU2016'!A$8:A$29)
    Nella matriciale potrei/forse scrivere la cella tipo B1
    =SE.ERRORE(INDICE(INDIRETTO(B1);PICCOLO(SE(INDIRETTO(B1)='TEAM 1'!$A$2;RIF.RIGA(INDIRETTO(B1))-RIF.RIGA(INDIRETTO(B1))+1);RIGHE($A$7:A7)));"")

    La cosa che non riesco nella formula è un'altra.
    Assocciare un verifica se cella=vuota ed SE.ERRORE (per me, in un caso lavora bene, altri non funziona)

    PS. La domanda doppia, esiste una formula che legge in file chiusi?
    Si, alcune lo fanno
    Quale sarebbe la migliore? INDIRETTO.EXT ok, mà non voglio caricarlo sui vari PC
    Altra sarebbe ='C:\Users\xxx\Documents\[prova.xlsx]Foglio2'!$A$1
    Forse alcune altre. Però avrei bisogno di un REFLASH (come si chiama con file già aperti)
    Se in ufficio1, scrivo un "qualcosa".
    Nell' ufficio2, non vedo nulla (se non trascino le formule in basso)
    Altre soluzioni ben accette (tranne VBA, saprei come fare, però al quale dovrei mettere un TIMER per il REFLASH ogni TOT minuti)

  4. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202

    Re: Problema con formula matriciale

    Ciao Raffaele,

    rispondo di nuovo parzialmente.


    L'intervallo in B1 da far elaborare alle formule con INDIRETTO - INDIRETTO('GIU2016'!A$8:A$29)- potrebbe funzionare solo per elaborare A8:A29.

    Copiando a destra la formula otterresti sempre gli stessi risultati.

    Per sistemare il SE cella vuota avrei bisogno dell'esempio su un file.

    Saluti

  5. I seguenti utenti hanno dato un "Like"

    ges

  6. #5
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Binasco
    Età
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: Problema con formula matriciale

    Ciao Canapone
    Ti allego un file per spiegarmi meglio
    Nel foglio GIU2016 in B1, c'è una formula che conta le righe presenti in GIU2016.
    Dai vari fogli Team, vorrei usare questo riferimento per fare la Matriciale di Gerardo che funziona benissimo, tranne che ha come riferimento un range fisso (solo le righe A$8:A$29) e che usa un SE('GIU2016'!$H$8:$H$29='TEAM 1' ecc ecc parola già scritta in A2 che neppure qui riesco modificare =A2
    Il resto della matriciale poi non la digerisco proprio.
    Ex se volessi che in Team3, vadano solo i record = TEAM 3 e solo le date relative a maggio/giugno togliendo i due record in riga18 e 25?
    Grazie mille
    EDIT Trovato
    B1="'GIU2016'!$A8:A"&(CONTA.VALORI('GIU2016'!A:A)+5)
    B2="'GIU2016'!$H8:H"&(CONTA.VALORI('GIU2016'!A:A)+5)

    Adesso mi rimane solo escludere alcune date
    =SE.ERRORE(INDICE(INDIRETTO('GIU2016'!B1);PICCOLO(SE(INDIRETTO('GIU2016'!B2)=A2;RIF.RIGA(INDIRETTO('GIU2016'!B1))-RIF.RIGA('GIU2016'!A$8)+1);RIGHE($A$7:A7)));"")
    File Allegati File Allegati
    Ultima modifica fatta da:Raffaele_53; 01/07/16 alle 12:33

  7. #6
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202

    Re: Problema con formula matriciale

    Ciao

    per isolare maggio

    =SE.ERRORE(INDICE('GIU2016'!A$8:A$29;PICCOLO(SE('GIU2016'!$H$8:$H$29=$A$2;SE(MESE('GIU2016'!$I$8:$I$29)=5;RIF.RIGA(A$1:A$22)));RIGHE($A$1:A1)));"")

    Matriciale

    Saluti

  8. #7
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Binasco
    Età
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: Problema con formula matriciale

    Ok, grazie mille nuovamente

Discussioni Simili

  1. UDF matriciale: E' possibile implementarla?
    Di dracoscrigno nel forum Domande su Excel VBA e MACRO
    Risposte: 8
    Ultimo Messaggio: 06/03/17, 19:25
  2. [Risolto] Aiuto per Formula matriciale per inserimento dati in cella
    Di andrea1897 nel forum Domande su Excel in generale
    Risposte: 19
    Ultimo Messaggio: 19/12/16, 10:31
  3. Formula matriciale molto difficile
    Di Sasyjoe nel forum Domande su Excel in generale
    Risposte: 28
    Ultimo Messaggio: 26/02/16, 20:18
  4. Formattazione condizionale: come usare formula matriciale?
    Di follaro nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 09/01/16, 20:52
  5. Risposte: 16
    Ultimo Messaggio: 25/08/15, 10:05

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •