Risultati da 1 a 4 di 4

Discussione: Ricerca dati con criterio in formato tasto



  1. #1
    L'avatar di BRAZ66
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    MILANO
    Età
    51
    Messaggi
    172
    Versione Office
    Excel 2013
    Likes ricevuti
    5
    Likes dati
    53

    Ricerca dati con criterio in formato tasto

    Saluti al Forum e buone vacanze a tutti,
    eccomi con nuova richiesta del vostro aiuto,ieri grazie a Gerardo avevo risolto un problema simile,oggi però modificando la ricerca ,la sua formula richiede una modifica ,che ho provato a cercare tutto il pomeriggio...mi arrendo e chiedo il vostro aiuto...a tal proposito allego il file che meglio spiega il tutto...GRAZIE

    307

    [IMG][/IMG]
    Ultima modifica fatta da:BRAZ66; 02/08/15 alle 22:21 Motivo: ALLEGATA IMMAGINE

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Brazz66

    Visto che hai la versione di excel 2010
    in D24
    =SE.ERRORE(INDICE($A$22:$A$40;AGGREGA(14;6;(RIF.RIGA($A$22:$A$40)-RIF.RIGA($A$22)+1)/((VAL.NUMERO(RICERCA(SINISTRA(D$23;2);$B$22:$B$40))+VAL.NUMERO(RICERCA(STRINGA.ESTRAI(D$23;4;2);$B$22:$B$40))+VAL.NUMERO(RICERCA(DESTRA(D$23;2);$B$22:$B$40))=3));RIGHE($A$1:A1)));"")


    In D24
    Oppure Prova questa formula matrice CTRL+SHIF+ENTER che va bene per tutte le formule di excel
    incolla

    =SE.ERRORE(INDICE($A$22:$A$40;GRANDE(SE(((VAL.NUMERO(RICERCA(SINISTRA(D$23;2);$B$22:$B$40))+VAL.NUMERO(RICERCA(STRINGA.ESTRAI(D$23;4;2);$B$22:$B$40))+VAL.NUMERO(RICERCA(DESTRA(D$23;2);$B$22:$B$40))))=3;RIF.RIGA($A$22:$A$40)-RIF.RIGA($A$22)+1);RIGHE($A$1:A1)));"")
    Ultima modifica fatta da:Gerardo Zuccalà; 02/08/15 alle 23:05

  3. #3
    L'avatar di BRAZ66
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    MILANO
    Età
    51
    Messaggi
    172
    Versione Office
    Excel 2013
    Likes ricevuti
    5
    Likes dati
    53
    pensa che avevo modificato la tua formula di ieri così,
    =SE.ERRORE(INDICE($B$3:$B$5276;AGGREGA(14;6;(RIF.RIGA($K$3:$K$5276)-RIF.RIGA($K$6)+1)/((VAL.NUMERO(RICERCA(STRINGA.ESTRAI(AG$5276;1;2);$K$3:$K$5276))+VAL.NUMERO(RICERCA(STRINGA.ESTRAI(AG$5276;4;2);$K$3:$K$5276))+VAL.NUMERO(RICERCA(STRINGA.ESTRAI(AG$5276;7;2);$K$3:$K$5276)))9=2);RIGHE($B$1:B1)));"")
    sostituendo però DESTRA e SINISTRA.....ecco perchè non riuscivo...forse.... GRAZIE GERARDO la tua funziona perfettamente :255:

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao adesso sono con il cellulare comunque nella tua formula noto diversi errori, tu hai fatto =2 ma devi fare =3 perché sono tre i numeri che ricerchi e quando si incontrano tutti e tre, ti da VERO e quindi ti dà il numero di riga

Discussioni Simili

  1. Estrarre dati con criterio
    Di BRAZ66 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 15/02/17, 18:54
  2. Registra dati con il tasto invio
    Di RUGANT54 nel forum Domande su Excel VBA e MACRO
    Risposte: 17
    Ultimo Messaggio: 13/02/17, 14:46
  3. Tipi di dati non corrispondenti nell'espressione criterio.
    Di Stavros nel forum Domande su Microsoft Access
    Risposte: 4
    Ultimo Messaggio: 10/10/16, 14:50
  4. Ricerca con criterio
    Di BRAZ66 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 24/06/16, 12:26
  5. Trasformare il formato cella da formato data a formato normale
    Di para siempre nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 12/03/16, 01:23

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •