Risultati da 1 a 7 di 7

Discussione: Ricerca con criteri somma



  1. #1
    L'avatar di BRAZ66
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    MILANO
    Età
    51
    Messaggi
    172
    Versione Office
    Excel 2013
    Likes ricevuti
    5
    Likes dati
    53

    Ricerca con criteri somma

    Buon giorno Forum,
    da giorni cerco di trovare una soluzionepiù rapida per una mia ricerca,fin'ora ho usato sistema elementare,lunghissimo direi,Chiedo a VOI se è possibile attraverso una formula ottenere lo stesso risultato ...mi risparmierebbe giorni per estrarre dati. Vi posto il file che meglio spiega,rimango a disposizione per chiarimenti e Vi ringrazio per la vostra disponibilità SALUTI
    Allegato 313

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    Ciao
    Il tuo quesito è prettamente da VBA.
    Volendo forzare con le formule, puoi:
    - crearti colonne di appoggio, con le 20 combinazioni in numeri, invece che in lettere, esempio, da R3 verso destra:
    123 124 125 126 134 135 136 145 146 156 234 235 236 245 246 ecc. ecc. fino a BY3.

    - in R4:
    =INDICE($A4:$F4;R$3)
    e trascino fino a BY19

    in BZ4:CA19 scrivi dei numeri maggiori di 71 (per evitare degli ambi finali)

    in H4:
    =SE.ERRORE(INDICE($R4:$BY4;CONFRONTA(74+INT((COLONNE($H$4:H$4)-1)/3);INDICE($R4:$BY4+$S4:$BZ4+$T4:$CA4;);0)+RESTO(COLONNE($H$4:J$4);3));"")
    e trascini fino a P19

    allego file:

  3. #3
    L'avatar di BRAZ66
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    MILANO
    Età
    51
    Messaggi
    172
    Versione Office
    Excel 2013
    Likes ricevuti
    5
    Likes dati
    53
    NINAI funziona alla grande,non sai quanto lavoro mi risparmia così!! GRAZIE GRAZIE...:23: ...sono distante anni luce ...con Excell

  4. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    Grazie del riscontro
    Tieni presente però che nella stessa riga vi potrebbero essere più di una combinazione che da la stessa somma, in questo modo ne viene segnalata solo una (la prima in sequenza).

  5. #5
    L'avatar di BRAZ66
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    MILANO
    Età
    51
    Messaggi
    172
    Versione Office
    Excel 2013
    Likes ricevuti
    5
    Likes dati
    53
    Hai perfettamente ragione NINAI, dovrò allora cercare le altre ed inserirle manualmente,ma comunque un po di ore di lavoro mi viene risparmiato,grazie ancora.

  6. #6
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    ciao
    ti propongo un'altra versione, "semplificata" che in aggiunta ha una formattazione condizionale qualora vi siano più di una combinazione per quella somma.

    le formule sono diverse ed anche la disposizione delle combinazioni. ti allego file con ambedue le soluzioni in due fogli separati.
    Si può anche fare in modo di restituire le diverse combinazioni ma si deve cambiare la struttura dei dati, fare rapporti separati per ogni criterio.

  7. #7
    L'avatar di BRAZ66
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    MILANO
    Età
    51
    Messaggi
    172
    Versione Office
    Excel 2013
    Likes ricevuti
    5
    Likes dati
    53
    ciao NINAI,
    ti ringrazio per queste nuove soluzioni, in effetti sto trovando molte combinazioni,certo che il foglio 2 mi è molto d'aiuto perchè la formattazzione che hai usato mi evidenzia se ci sono più combinazioni e perdo meno tempo nella ricerca. Capisco che per avere le altre combinazioni si dovrebbe stutturare diversamente con altre formule, pensa che trovo anche 3 combinazioni per singolo criterio,comunque grazie a te ho fatto passi da gigante..

Discussioni Simili

  1. Somma valori con criteri temporali
    Di damiaà nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 28/06/16, 11:13
  2. somma con criteri
    Di ROBYVMG nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 25/12/15, 13:32
  3. Ricerca con più criteri
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 28
    Ultimo Messaggio: 02/11/15, 22:20
  4. somma.più.se con criteri appartenenti allo stesso intervallo_criteri
    Di Francesco Lavista nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 21/08/15, 18:11
  5. Quiz #14 Somma con due criteri
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 28/06/15, 18:34

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •