Risultati da 1 a 4 di 4

Discussione: INDICE/CONFRONTA/GRANDE con valori uguali



  1. #1
    L'avatar di MattoMar
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Roma
    Età
    29
    Messaggi
    2
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    1

    INDICE/CONFRONTA/GRANDE con valori uguali

    Salve a tutti,
    vi chiedo un aiuto su un file excel a cui devo mettere mano.
    Praticamente, in "foglio1" ho una tabella formata da una prima colonna con le variabili e da successive colonne che invece contengono le frequenze (ogni colonna rappresenta una classe).
    La mia esigenza è quella di creare sul "foglio2" diverse tabelle che che contengano solo i primi 5 elementi più frequenti per colonna ordinati in ordine decrescente.
    Cercando un po' di soluzioni online ho utilizzato una formula del genere

    Codice: 
    =INDICE(Foglio1!A2:A10;CONFRONTA(GRANDE(Foglio1!B2:B10;1);Foglio1!B2:B10;0);1)
    Il problema nasce quando le variabili si presentano con la stessa frequenza. Con questa formula pesco sempre la stessa variabile che quindi viene ripetuta più volte.
    La domanda è, come posso fare per riuscire a mostrare anche le altre che però hanno la stessa frequenza?

    Vi Allego una parte della tabella su cui sto lavorando in modo che tutto possa essere più chiaro.
    Grazie in anticipo, purtroppo su questo argomento non sono così ferrato...anzi, spero di essere stato chiaro nell'esposizione.

    Marco
    File Allegati File Allegati

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: INDICE/CONFRONTA/GRANDE con valori uguali

    Ciao benvenuto in forumexcel.it

    Prova a mettere questa formula in A3 e copia in basso

    =INDICE(Foglio1!$A$2:$A$10;AGGREGA(15;6;(RIF.RIGA(Foglio1!$A$2:$A$10)-RIF.RIGA(Foglio1!$A$2)+1)/(Foglio1!$B$2:$B$10=D3);CONTA.SE($D$3:D3;D3)))

    Un saluto

    EDIT

    Ciao MattoMar, visto che sei nuovo dai un'occhiata al regolamento

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di MattoMar
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Roma
    Età
    29
    Messaggi
    2
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    1

    Re: INDICE/CONFRONTA/GRANDE con valori uguali

    Ciao Gerardo, grazie tantissimo!

    Sei stato rapidissimo e funziona perfettamente.
    Stavo cercando di capire come funzionasse la formula nel dettaglio ma ho notato anche il tuo canale youtube e probabilmente troverò li la risposta.
    Che dire...di nuovo grazie e cerco di farmi una cultura!

  5. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: INDICE/CONFRONTA/GRANDE con valori uguali

    Ciao grazie per il riscontro, se vuoi capire questa formula guarda il video excel magico 28
    Ciao

Discussioni Simili

  1. [Risolto] problema errore #NUM con le funzioni di CONFRONTA e GRANDE
    Di davide574 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 15/12/16, 21:23
  2. Indice e confronta co SE(E(O(rif,rig(rrf.col))))
    Di Amerigo nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 21/09/16, 00:21
  3. funzioni INDICE-CONFRONTA-GRANDE insieme
    Di Davide nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 07/06/16, 12:15
  4. Indice confronta con risultati multipli
    Di yari1 nel forum Domande su Excel VBA e MACRO
    Risposte: 18
    Ultimo Messaggio: 07/04/16, 12:50
  5. Indice + Confronta con tre criteri non funziona
    Di MarcoM nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 09/10/15, 19:03

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •