Risultati da 1 a 16 di 16

Discussione: AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati



  1. #1
    L'avatar di davidecit
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Italia
    Età
    28
    Messaggi
    7
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0

    AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati

    Salve, spiego rapidamente la mia situazione.
    Ho delle righe con dei numeri (numeri prenotati per una lotteria), ed il tabellone con i numeri da 1 a 90 sulla destra.
    Ora vorrei che se inserisco i numeri che ogni persona prende, nel tabellone a dx diventino rossi, ed in caso di doppioni (cioè che se per errore due persone abbiano scelto lo stesso numero), nel tabellone diventino verdi invece che rossi.

    Con la formattazione condizionale mi sono avvicinato un pò, i numeri nel tabellone si fanno rossi (ma solo alcuni e solo per la prima riga . Se estendo la formula a più righe non funziona)

    Un altro problema è che se i numeri che hanno scelto le persone vengono inseriti in ordine crescente, si fanno rossi sul tabellone, altrimenti no, o almeno così mi sembra che accada.

    Allego il file per una maggiore comprensione perchè spiegarlo a parole mi risulta difficile
    File Allegati File Allegati

  2. #2

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2808
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979

    Re: AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati

    Usa queste formattazioni condizionali:
    seleziona il range U10:AI15
    =CONTA.SE($B$2:$P$6;U10)>1 per il verde (doppioni)
    =CONTA.SE($B$2:$P$6;U10)=1 per il rosso (numero estratto)

    P.S. E' gradita una presentazione QUI

  3. #3
    L'avatar di davidecit
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Italia
    Età
    28
    Messaggi
    7
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0

    Re: AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati

    Citazione Originariamente Scritto da Rubik72 Visualizza Messaggio
    Usa queste formattazioni condizionali:
    seleziona il range U10:AI15
    =CONTA.SE($B$2:$P$6;U10)>1 per il verde (doppioni)
    =CONTA.SE($B$2:$P$6;U10)=1 per il rosso (numero estratto)

    P.S. E' gradita una presentazione QUI
    Presentazione effettuata

    Formule precise, incredibile! Che bello vedere tanta conoscenza!

    Grazie di cuore, penso di aver proprio risolto

    Volevo chiederti un altro paio di cose, molto probabilmente stupide:

    1) In una colonna, le celle possono avere larghezza variabile? Cioè che magari le cellette dei numeri in basso sono piccole, mentre sopra vorrei scrivere "NUMERI SCELTI", ma l'unica scelta (di dubbio gusto), per ovviare al problema mi sembra quella di scrivere in ogni celletta una lettera, tipo |N | U | M | E | R | I |"

    2) Nella colonna dove ricevo il risultato dei soldi ho questa formula
    = "€ " & T2*R2

    ora vorrei che se la cifra contiene dei decimali tipo € 10,5 venga mostrato € 10,50, con lo 0 alla fine. Ho smanettato un pò ma nulla

    3) Vorrei aggiungere un "contatore" del genere: Numeri disponibili xx/90, dove xx è la sottrazione tra 90 e i numeri che sono accesi sul tabellone


    Grazie e scusa se abuso della tua disponibilità

  4. #4

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923

    Re: AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati

    Ciao a tutti,

    @davidecit

    1) In una colonna, le celle possono avere larghezza variabile? Cioè che magari le cellette dei numeri in basso sono piccole, mentre sopra vorrei scrivere "NUMERI SCELTI", ma l'unica scelta (di dubbio gusto), per ovviare al problema mi sembra quella di scrivere in ogni celletta una lettera, tipo |N | U | M | E | R | I |"
    Puoi usare semplicemente lo strumento "unione celle" (si trova nella scheda "HOME", nella sezione "Allineamento")

    2) Nella colonna dove ricevo il risultato dei soldi ho questa formula
    = "€ " & T2*R2
    Perchè non utilizzi direttamente la formattazione della cella (tasto destro --> Formatta celle...):
    sulla sinistra (Categoria) , scegli la voce "Valuta", mentre sulla destra scegli il numero delle cifre decimali (2 in questo caso).

    3) Vorrei aggiungere un "contatore" del genere: Numeri disponibili xx/90, dove xx è la sottrazione tra 90 e i numeri che sono accesi sul tabellone
    Considerando che in una lotteria un numero può venire scelto una volta sola (forse a questo ti serve il verde della formattazione condizionale?), la formula da usare potrebbe essere questa (da mettere ad esempio nella cella X5):

    =90-MAX(FREQUENZA($B$2:$P$6;{0.90}))

    oppure:

    =90-CONTA.VALORI($B$2:$P$6)

    Ti riallego il file...

    [EDIT]

    Per quanto riguarda il titolo, in futuro evita di scrivere parole ti "AIUTO", limitati a riassumere il problema:
    Regola nr.5 "il titolo"
    Assicurarti che il titolo sia il più chiaro possibile e che corrisponda al problema, usa termini appropriati che saranno usati come meta tag per una eventuale ricerca su Google.
    Evita di scrivere frasi inutili come “Aiuto” “Urgente ” “Non ci capisco niente” e "sono bloccato"
    perché potrebbero rivelarsi non appropriate e di conseguenza le tue discussioni potrebbero essere non lette.

    Ti consiglio di scrivere titoli che vanno dritto al problema esempio: "come faccio ad analizzare dati....." "come faccio ad estrarre records....." "come faccio a calcolare......." "come creare una TPivot......"
    I titoli ed i testi devono essere scritti in italiano corretto, sia grammaticamente che ortograficamente; postare frasi con errori evidenti è sempre una forma di NON rispetto per chi legge.
    Per approfondire, dai un'occhiata al Regolamento.

    Ciao
    Tore
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  5. I seguenti utenti hanno dato un "Like"


  6. #5
    L'avatar di davidecit
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Italia
    Età
    28
    Messaggi
    7
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0

    Re: AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati

    Ciao, grazie ancora per la disponibilità.

    Il numero verde mi serve per individuare doppioni, quindi teoricamente potrebbero essercene più di uno.

    Per le 2 cifre dopo la virgola, io vorrei che le cifre senza decimali non avessero ,00 mentre quelle con decimali si. Quindi tipo 10 € e 11,50 €.

  7. #6

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923

    Re: AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati

    Citazione Originariamente Scritto da davidecit Visualizza Messaggio
    Per le 2 cifre dopo la virgola, io vorrei che le cifre senza decimali non avessero ,00 mentre quelle con decimali si. Quindi tipo 10 € e 11,50 €.
    Ciao,
    prova così...
    come formato celle scegli la voce "Valuta" e come decimali scegli zero (0).
    La formula da usare nella S2 (e copiare eventualmente in basso):

    =SE(INT(T2*R2)=T2*R2;T2*R2;TESTO(T2*R2;"0,00 €"))
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  8. I seguenti 2 utenti hanno dato un "Like" a cromagno per questo post:


  9. #7
    L'avatar di davidecit
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Italia
    Età
    28
    Messaggi
    7
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0

    Re: AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati

    Ragazzi siete squisiti. Purtroppo ho un problema con la formattazione condizionale:

    I numeri "acquistati" non semrpe si fanno rossi, idem per i doppioni, che non sempre si fanno verdi.

    Allego file
    File Allegati File Allegati

  10. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7146
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati

    Ciao,
    prova così:

    =CONTA.SE($B$2:$P$16;V6)>1 (verde, doppioni)


    =CONTA.SE($B$2:$P$16;V6)=1 (rossi, univoci)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  11. #9
    L'avatar di davidecit
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Italia
    Età
    28
    Messaggi
    7
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0

    Re: AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao,
    prova così:

    =CONTA.SE($B$2:$P$16;V6)>1 (verde, doppioni)

    =CONTA.SE($B$2:$P$16;V6)=1 (rossi, univoci)
    La situazione è migliorata: ora molti dei numeri che dovevano essere rossi effettivamente lo sono diventati ma:

    - Se segno dei numeri nuovi non diventano rossi
    - I doppioni continuano a non diventare verdi.
    File Allegati File Allegati

  12. #10
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    781
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1

    Re: AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati

    Buona Sera



    =CONTA.SE($B$2:$P$91;V6)>1 (verde, doppioni)






    =CONTA.SE($B$2:$P$91;V6)=1 (rossi, univoci)

    Saluti
    Window 8.1 Excel 2013/2016

  13. #11
    L'avatar di davidecit
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Italia
    Età
    28
    Messaggi
    7
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0

    Re: AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati

    Citazione Originariamente Scritto da Pitagora Visualizza Messaggio
    Buona Sera



    =CONTA.SE($B$2:$P$91;V6)>1 (verde, doppioni)






    =CONTA.SE($B$2:$P$91;V6)=1 (rossi, univoci)

    Saluti
    Grazie mille maestro, sembra veramente tutto ok

    ----------Post unito in automatico----------

    Non chiamatemi "cacacaxxi" però mi trovo nella colonna S:

    Le cifre senza decimali scritte " € 7" e quelle con i decimali "10,50 €".


    Ora la domanda è: come posso far si che anche per le cifre intere la € sia postposta al numero?A

    Allego sempre file per consultazione
    File Allegati File Allegati

  14. #12

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7146
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Re: AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati

    Citazione Originariamente Scritto da davidecit Visualizza Messaggio
    ...come posso far si che anche per le cifre intere la € sia postposta al numero?A

    .
    Se vuoi che il simbolo della € venga prima il numero, in S2 da trascinare in basso:

    =SE(INT(T2*R2)=T2*R2;T2*R2;TESTO(T2*R2;"€ 0,00 "))

    Se invece vuoi che il simbolo della € venga dopo il numero basta che selezioni la colonna e col tasto destro scegli "Formato" -->"Contabilità"
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  15. #13
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati

    Ciao Ragazzi
    Io in S2 metterei semplicemente questa formula

    =R2*T2 e da copiare in basso

    Poi per mettere il segno dell'Euro personalizzerei il formato del numero cosi:
    €. 0,00; €-0,00;€. 0,00 ( vedi immagine)

    Ovviamente se vuoi il segno dell'euro dopo il numero metti l' € dopo cosi
    0,00 €.; -0,00€ ; 0,00 €.



    PS Oltretutto questa soluzione ti permette di avere il formato in numero e non in testo qualora dovessero ancora servirti i quei numeri

    Un saluto

  16. #14
    L'avatar di davidecit
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Italia
    Età
    28
    Messaggi
    7
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0

    Re: AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati

    Grazie, è tutto perfetto così , resta solo un piccolo "problemuccio": per i numeri interi, non vorrei 7,00 € ma semplicemente 7 €, ma credo che sia difficilmente realizzabile rimanendo con il campo "numero". Anche perchè come dici tu, i numeri mi servono per una somma, quindi è importante che non siano visti come testo
    Ultima modifica fatta da:Gerardo Zuccalà; 13/07/16 alle 19:38

  17. #15
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    781
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1

    Re: AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati

    Buon Giorno

    Ho applicato una formattazione condizionale per personalizzare il "Totale da pagare"

    Se il numero dei biglietti acquistati e zero la cella e' vuota

    Saluti
    File Allegati File Allegati
    Window 8.1 Excel 2013/2016

  18. #16
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: AIUTO funziona CONFRONTA per valori presenti in una colonna ed in una tabella e duplicati

    Citazione Originariamente Scritto da davidecit Visualizza Messaggio
    Grazie, è tutto perfetto così , resta solo un piccolo "problemuccio": per i numeri interi, non vorrei 7,00 € ma semplicemente 7 €, ma credo che sia difficilmente realizzabile rimanendo con il campo "numero". Anche perchè come dici tu, i numeri mi servono per una somma, quindi è importante che non siano visti come testo
    Ciao Davidecit, sono da cellulare,
    a quell punto devi solamente cambiare la personalizzazione del formato del numero quindi inserisci (al punto 3 dell'immagine) questo format 0 €;-0 €;0 €
    Fammi sapere!




Discussioni Simili

  1. Da tabella a colonna con valori unici
    Di Gianfranco55 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 05/03/17, 20:00
  2. [Risolto] Mettere Valori di una tabella in una sola colonna
    Di AminTheWise nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 25/02/17, 16:07
  3. Ricerca valore in tabella e restituzione valori di riga e colonna
    Di ajejebrazorf nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 10/01/17, 19:55
  4. [Risolto] Estendere formattazione condizionale di una colonna per valori duplicati sulle altre colonne
    Di lopsi67 nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 17/10/16, 18:24
  5. Indice + Confronta con tre criteri non funziona
    Di MarcoM nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 09/10/15, 19:03

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •