Risultati da 1 a 6 di 6

Discussione: Estrazione elenco con somma



  1. #1
    L'avatar di Hesinberg!
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    Milano
    Età
    28
    Messaggi
    6
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    4

    Estrazione elenco con somma

    Ciao a tutti, sono di nuovo qua per chiedervi un'altra volta una mano.

    Dovrei far comparire sotto ogni persona che si trova nel foglio "TOTALI" la descrizione dei beni acquistati da quella persona (che si trovano nella tabella del foglio "BENI") ed in fondo a queste descrizioni il totale del prezzo di tali beni. Spero di essermi spiegato.

    Grazie in anticipo a chiunque mi aiuti!

    PS: In allegato trovate il file Excel.
    File Allegati File Allegati

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1341

    Re: Informazione per Esame Excel [2]

    Citazione Originariamente Scritto da Hesinberg! Visualizza Messaggio
    Ciao a tutti, sono di nuovo qua per chiedervi un'altra volta una mano.

    Dovrei far comparire sotto ogni persona che si trova nel foglio "TOTALI" la descrizione dei beni acquistati da quella persona (che si trovano nella tabella del foglio "BENI") ed in fondo a queste descrizioni il totale del prezzo di tali beni. Spero di essermi spiegato.

    Grazie in anticipo a chiunque mi aiuti!

    PS: In allegato trovate il file Excel.
    Buongiorno heisenberg
    Non so se hai letto il regolamento, ma in questo forum è obbligatorio inserire una immagine avatar, e in particolare mi riferisco a questa regola


    Regola nr.11 “Immagini profilo e avatar”
    In questo forum è obbligatorio inserire una immagine Avatar, altrimenti lo staff provvederà alla rimozione dell'account al prossimo aggiornamento.
    L'ideale sarebbe il proprio volto cosi come accade nei social più famosi, ma va bene anche una qualsiasi altra immagine, è semplicissimo basta andare in "Impostazioni"(in alto a destra) e poi a sinistra "Modifica Avatar".
    Non utilizzare immagini inappropriate su questo forum cioè quelle che approvano la pornografia, la pirateria, la violenza, la Politica, la Religione e che comunque potrebbero ledere qualsiasi individuo di questo forum con la conseguenza rimozione delle immagini, avvertimenti ed infine nei casi più gravi la rimozione dal forum.
    Un saluto

    ----------Post unito in automatico----------

    Heisenberg
    Anche il titolo non va bene, perchè deve sempre anticipare il problema, e il perchè te lo spiego sempre nel regolamento
    Se non vuoi incorrere in altre infrazioni ti invito a leggere il regolamento
    Grazie

    Regola nr.5 "il titolo"
    Assicurarti che il titolo sia il più chiaro possibile e che corrisponda al problema, usa termini appropriati che saranno usati come meta tag per una eventuale ricerca su Google.
    Evita di scrivere frasi inutili come “Aiuto” “Urgente ” “Non ci capisco niente” e "sono bloccato"
    perché potrebbero rivelarsi non appropriate e di conseguenza le tue discussioni potrebbero essere non lette.
    Ti consiglio di scrivere titoli che vanno dritto al problema esempio: "come faccio ad analizzare dati....." "come faccio ad estrarre records....." "come faccio a calcolare......." "come creare una TPivot......"
    I titoli ed i testi devono essere scritti in italiano corretto, sia grammaticamente che ortograficamente; postare frasi con errori evidenti è sempre una forma di NON rispetto per chi legge.
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  3. #3

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    46
    Messaggi
    3528
    Versione Office
    Excel 2013
    Likes ricevuti
    1227
    Likes dati
    1299

    Re: Informazione per Esame Excel [2]

    Per l'elenco, inserisci in Foglio Totali
    A3=SE.ERRORE(INDICE(BENI!$A$3:$A$24;AGGREGA(15;6;(RIF.RIGA(BENI!$A$3:$A$24)-RIF.RIGA(BENI!$A$3)+1)/(BENI!$C$3:$C$24=TOTALI!A$2);RIGHE($1:1)));"")

    e ricopi in basso e a destra

    mentre per il totale
    A15=MATR.SOMMA.PRODOTTO((BENI!$C$3:$C$24=TOTALI!A$2)*BENI!$B$3:$B$24)

    e ricopi a dx

    EDIT: Ciao @Gerardo Zuccalà, il titolo l'ho corretto io

  4. I seguenti 3 utenti hanno dato un "Like" a Rubik72 per questo post:


  5. #4

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    38
    Messaggi
    4748
    Versione Office
    2013
    Likes ricevuti
    1501
    Likes dati
    1052

    Re: Informazione per Esame Excel [2]

    Citazione Originariamente Scritto da Rubik72 Visualizza Messaggio
    Per l'elenco, inserisci in Foglio Totali
    A3=SE.ERRORE(INDICE(BENI!$A$3:$A$24;AGGREGA(15;6;(RIF.RIGA(BENI!$A$3:$A$24)-RIF.RIGA(BENI!$A$3)+1)/(BENI!$C$3:$C$24=TOTALI!A$2);RIGHE($1:1)));"")

    e ricopi in basso e a destra

    mentre per il totale
    A15=MATR.SOMMA.PRODOTTO((BENI!$C$3:$C$24=TOTALI!A$2)*BENI!$B$3:$B$24)

    e ricopi a dx
    Mi hai anticipato... sei un fulmine


    io ho usato la forma matriciale... la posto come alternativa (da copiare in basso e a destra):

    =SE.ERRORE(INDICE(BENI!$A$1:$A$24;PICCOLO(SE(BENI!$C$3:$C$24=TOTALI!A$2;RIF.RIGA($C$3:$C$24);"");RIF.RIGA(A1)));"")

    per la somma (da copiare a destra):

    =SOMMA.SE(BENI!$C$3:$C$24;TOTALI!A$2;BENI!$B$3:$B$24)


    P.S.
    Per la forma matriciale devi confermare la formula con la combinazione di tasti CTRL+MAIUSC+INVIO

    ----------Post unito in automatico----------

    [EDIT]

    @Hesinberg!

    visto che queste formule ti servono per l'esame... le avete usate nelle lezioni (tipo la funzione AGGREGA proposta da Rubik)?
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  6. I seguenti utenti hanno dato un "Like"


  7. #5
    L'avatar di Marius44
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Catania
    Età
    74
    Messaggi
    4022
    Versione Office
    Excel2010
    Likes ricevuti
    832
    Likes dati
    176

    Re: Informazione per Esame Excel [2]

    Salve a tutti
    Premesso che non ci penso neppure di ... mettermi in gara con voi (perderei di sicuro), ma, ragionando lentamente come si addice ad un ... attempato, nelle formule proposte da Rubik e da Cromagno il riferimento al Foglio TOTALI! non si potrebbe togliere? Credo di si, visto che la formula E' su quel foglio.

    A parte tutto, veramente bravi. Complimenti.
    Ciao,
    Mario

  8. #6

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    38
    Messaggi
    4748
    Versione Office
    2013
    Likes ricevuti
    1501
    Likes dati
    1052

    Re: Informazione per Esame Excel [2]

    Citazione Originariamente Scritto da Marius44 Visualizza Messaggio
    Salve a tutti
    Premesso che non ci penso neppure di ... mettermi in gara con voi (perderei di sicuro), ma, ragionando lentamente come si addice ad un ... attempato, nelle formule proposte da Rubik e da Cromagno il riferimento al Foglio TOTALI! non si potrebbe togliere? Credo di si, visto che la formula E' su quel foglio.

    A parte tutto, veramente bravi. Complimenti.
    Ciao,
    Mario
    Ciao Mario,
    scusa, ho letto solo ora il tuo commento...

    Si hai ragione

    Excel mette in automatico i nomi dei fogli nei riferimenti (anche se il foglio è lo stesso) dopo che si è preso un riferimento da un altro foglio.... per pigrizia non l'ho cancellato.

    Ciao
    Tore

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

Discussioni Simili

  1. Estrazione Casuale
    Di synflex nel forum Domande su Excel VBA e MACRO
    Risposte: 1
    Ultimo Messaggio: 05/03/17, 12:08
  2. [Risolto] Estrazione di dati per una somma
    Di FELIX nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 31/01/17, 15:09
  3. estrazione condizionata dati e somma valori per ogni singolo cliente
    Di GioPL nel forum Domande su Excel VBA e MACRO
    Risposte: 4
    Ultimo Messaggio: 19/07/16, 15:26
  4. estrazione dati
    Di D@nilo nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 21/02/16, 18:18
  5. Popolamento elenco e somma valori singoli
    Di freepredator nel forum Domande su Excel in generale
    Risposte: 15
    Ultimo Messaggio: 11/11/15, 11:27

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •