Risultati da 1 a 22 di 22

Discussione: funzione [conta.se]: contare il valore di un testo in una cella con "concatena"



  1. #1
    L'avatar di delittogoloso
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    poggio mirteto
    Età
    33
    Messaggi
    12
    Versione Office
    MS 2010 pc
    Likes ricevuti
    0
    Likes dati
    0

    [RISOLTO] funzione [conta.se]: contare il valore di un testo in una cella con "concatena"

    salve ragazzi.

    sto cercando di creare un foglio di lavoro per un torneo di beach volley dove i partecipanti cambiano sempre compagno sfidandosi in "uno contro tutti".

    se i partecipanti sono "A", "B", "C" e "D", questi si sfideranno accoppiandosi uno per volta:

    A/B vs C/D
    A/C vs B/D
    A/D vs B/C

    in una cella ho creato proprio questi accoppiamenti con la funzione "concatena" (ho fatto una tabella dove per ora ci sono "A,B,C,D", ma poi ci saranno i nomi tipo: anna, giulia, francesca, daria che si sostituiranno agli abbinamenti).

    vicino agli abbinamenti ho messo le celle per il punteggio finale, e ancora dopo una cella che mi dice il vincitore (mi copia la cella con "concatena" che ha il punteggio maggiore).

    il problema è che nell'insieme delle partite (che non sono solo 3, quello è un esempio!) vorrei che venissero contate le vittorie di "A", o "B", o "C" (naturalmente ognuna nella cella del rispettivo giocatore che però assumerà un nome differente!)

    come posso fare?! la spiegazione è chiara?

    grazie delittogoloso
    Ultima modifica fatta da:delittogoloso; 05/07/16 alle 22:56

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342

    Re: funzione [conta.se]: contare il valore di un testo in una cella con "concatena"

    Ciao DelittoGoloso
    la tua domanda mi sembra interessante anche se abbastanza articolata e quindi per evitare fraintendimenti, ti consiglio di allegare un file di esempio (senza dati sensibili) e magari con il risultato atteso scritto a mano cosi che si capisce meglio quello che vuoi ottenre
    Aiutaci ad Aiutarti
    Un Saluto
    Ciao
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  3. #3
    L'avatar di delittogoloso
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    poggio mirteto
    Età
    33
    Messaggi
    12
    Versione Office
    MS 2010 pc
    Likes ricevuti
    0
    Likes dati
    0

    Re: funzione [conta.se]: contare il valore di un testo in una cella con "concatena"

    caricato il file...non c'è nessun dato sensibile perchè è ancora allo stato embrionale!
    ti (vi!) spiego:

    - la prima tabella è quella dove andranno inseriti i nomi dei partecipanti (per sorteggio) divisi in 4 gironi (in B1 ho messo "anna", ma negli altri per semplificare ho messo le lettere dell'alfabeto)

    - poco più sotto c'è il calendario delle gare con gli accoppiamenti fatti con la formula "concatena" (colonne B e D)
    - alla destra di ogni gara ci sono 3 celle per il risultato che verrà messo manualmente (ho fatto esempio per le prime 3 partite), e nella colonna successiva c'è il nome della coppia vincitrice (a seconda del valore maggiore della colonna "risultato"

    il mio problema è che vorrei avere (in una cella che per ora ho messo nella tabella dei sorteggi - ad esempio in C6 per "anna") il numero delle partite vinte (e magari in un'altra cella quelle delle partite giocate), solo che se utilizzo la funzione "=CONTA.SE(H14:H25;B6)" (ovvero: ricerca nell'intervallo selezionato il valore scritto in B6 - anna in questo caso), visto che ho utilizzato in QUELL'INTERVALLO la funzione "CONCATENA" non avrò automaticamente le volte che si ripete "anna" perchè c'è anche scritto altro (nel caso specifico "/ B")
    File Allegati File Allegati

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342

    Re: funzione [conta.se]: contare il valore di un testo in una cella con "concatena"

    Ok adesso molto meglio

    in C6 metti questa formula e trascinala in basso

    =MATR.SOMMA.PRODOTTO(--(VAL.NUMERO(RICERCA(B6;$B$14:$B$25))))

    ovviamente adesso sarai ad adattarle alle prossime colonne

    Un sauto
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  5. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    54
    Messaggi
    10153
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2598
    Likes dati
    1558

    Re: funzione [conta.se]: contare il valore di un testo in una cella con "concatena"

    Un saluto a tutti,
    se non sbaglio, nella richiesta parli di avere il numero delle partite vinte da parte di ciascuno, ma non vedo nessuna colonna dedicata, nel caso aggiungi una colonna dopo C6 e inserisci questa formula da trascinare in basso:

    =MATR.SOMMA.PRODOTTO(($E$14:$E$25>$G$14:$G$25)*(STRINGA.ESTRAI($B$14:$B$25;1;TROVA("/";$B$14:$B$25)-2)=B6))


    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342

    Re: funzione [conta.se]: contare il valore di un testo in una cella con "concatena"

    Ciao a tutti
    Mi sa che avevo capito male la domanda
    Prova questa

    In C6

    =MATR.SOMMA.PRODOTTO(VAL.NUMERO(RICERCA(B6;$D$14:$D$25))+VAL.NUMERO(RICERCA(B6;$B$14:$B$25))*($E$14:$E$25<>"")*($G$14:$G$25<>""))
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  7. #7

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    54
    Messaggi
    10153
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2598
    Likes dati
    1558

    Re: funzione [conta.se]: contare il valore di un testo in una cella con "concatena"

    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Ciao a tutti
    Mi sa che avevo capito male la domanda
    ...
    Ciao Gerardo ... e allora io cosa ho capito???
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  8. #8
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342

    Re: funzione [conta.se]: contare il valore di un testo in una cella con "concatena"

    EDIT 2

    Piu la testo questa formula e più mi accorgo che ci sono errori

    Questa dovrebbe andare meglio

    =MATR.SOMMA.PRODOTTO(--(VAL.NUMERO(RICERCA(B6;$B$14:$B$25))))+MATR.SOMMA.PRODOTTO(--(VAL.NUMERO(RICERCA(B6;$D$14:$D$25)));--($E$14:$E$25<>""))
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  9. #9
    L'avatar di delittogoloso
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    poggio mirteto
    Età
    33
    Messaggi
    12
    Versione Office
    MS 2010 pc
    Likes ricevuti
    0
    Likes dati
    0

    Re: funzione [conta.se]: contare il valore di un testo in una cella con "concatena"

    ho provato con la prima soluzione di gerardo:
    nella sua formula ho dovuto cambiare l'intervallo di matrice (invece di B14:B25 ho messo H14:H25 - che è quella dove c'è scritto chi ha vinto)

    con questa modifica il numero di partite vinte per ognuna FUNZIONA in C6
    - le altre formule non le ho provate.

    in caso l'altro quesito è sulle PARTITE GIOCATE (quindi partite vinte + partite perse)...
    grazie a tutti!

  10. #10

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    58
    Messaggi
    1214
    Versione Office
    .
    Likes ricevuti
    457
    Likes dati
    0

    Re: funzione [conta.se]: contare il valore di un testo in una cella con "concatena"

    Ciao,

    da quello che ho capito io, per le partite giocate:
    Codice: 
    =SOMMA(--(SE.ERRORE(TROVA(B6;$B$14:$D$25);0)>0))
    matriciale da confermare con ctrl+maiusc+invio

    per le partite vinte:
    Codice: 
    =SOMMA(--(SE.ERRORE(TROVA(B6;$H$14:$H$25);0)>0))
    matriciale da confermare con ctrl+maiusc+invio
    Ultima modifica fatta da:scossa; 05/07/16 alle 19:39 Motivo: corretta formula
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  11. #11
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342

    Re: funzione [conta.se]: contare il valore di un testo in una cella con "concatena"

    Ciao Delitto goloso
    No ho capito hai rislto?

    perche in questo esempio io conto 9 volte Anna

    dimmi se era quello che volevi, se non è cosi prova a scrivere il risultato atteso



    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  12. #12
    L'avatar di delittogoloso
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    poggio mirteto
    Età
    33
    Messaggi
    12
    Versione Office
    MS 2010 pc
    Likes ricevuti
    0
    Likes dati
    0

    Re: funzione [conta.se]: contare il valore di un testo in una cella con "concatena"

    @gerardo: ho utilizzato la tua prima formula modificando l'intervallo di ricerca: =MATR.SOMMA.PRODOTTO(--(VAL.NUMERO(RICERCA(B6;$H$14:$H$25))))
    tutte le altre formule NON funzionano (comprese quelle degli altri utenti): per un verso o per un altro vanno a contare solo quante volte il nome "anna" si ripete nell'intervallo B14:D25 (e questo non serve a nulla, nemmeno per le partite giocate, visto che fa il conteggio anche senza alcun risultato=

  13. #13
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342

    Re: funzione [conta.se]: contare il valore di un testo in una cella con &quot;concatena&quot;

    Citazione Originariamente Scritto da delittogoloso Visualizza Messaggio
    visto che fa il conteggio anche senza alcun risultato=
    ok forse ci siamo
    vorresti contare quante volte c'è "anna" solo nell'intervallo in H15:H25 a patto che ci sia stata giocata la partita, e corretto?

    ----------Post unito in automatico----------

    se si Allora prova questa

    =MATR.SOMMA.PRODOTTO(--(VAL.NUMERO(RICERCA(B6;$H$14:$H$25)));--($E$14:$E$25<>"");--($G$14:$G$25<>""))
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  14. #14
    L'avatar di delittogoloso
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    poggio mirteto
    Età
    33
    Messaggi
    12
    Versione Office
    MS 2010 pc
    Likes ricevuti
    0
    Likes dati
    0

    Re: funzione [conta.se]: contare il valore di un testo in una cella con &quot;concatena&quot;

    non hai capito...ehehe
    quest'ultima formula mi conta le vittorie.
    ma già la tua prima formula (modificando l'intervallo) lo faceva.
    quello che servirebbe è contare le partite giocate (sia vinte che perse).

    altro quesito:
    e se volessi avere ANCHE il numero di punti fatti e subiti dalle squadre con "anna"?

  15. #15
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    1009
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    401
    Likes dati
    1

    Re: funzione [conta.se]: contare il valore di un testo in una cella con &quot;concatena&quot;

    Buona Sera

    c6 =CONTA.SE($B$14:$D$25;"*"&B6&"*") copia in basso partite giocate

    c7=CONTA.PIÙ.SE($H$14:$H$25;"*"&B6&"*";$H$14:$H$25;"<>"&$H$19) copia in basso partite vinte

    Saluti
    Window 8.1 Excel 2013/2016

  16. #16
    L'avatar di delittogoloso
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    poggio mirteto
    Età
    33
    Messaggi
    12
    Versione Office
    MS 2010 pc
    Likes ricevuti
    0
    Likes dati
    0

    Re: funzione [conta.se]: contare il valore di un testo in una cella con &quot;concatena&quot;

    @pitagora:
    partite giocate non funziona (anche senza alcun risultato mi da 3 per ogni giocatore!
    partite vinte funziona

  17. #17
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Binasco
    Età
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: funzione [conta.se]: contare il valore di un testo in una cella con &quot;concatena&quot;

    Premesso che le formule di scossa funzionano
    Forse no le hai inserite come MATRICIALI

    Con quella di Gerardo
    >>>quest'ultima formula mi conta le vittorie.
    =MATR.SOMMA.PRODOTTO(--(VAL.NUMERO(RICERCA(B6;H$14:H$25))))

    >>>contare le partite giocate (sia vinte che perse).
    =MATR.SOMMA.PRODOTTO(--(VAL.NUMERO(RICERCA(B6;B$14:D$25))))

    >>>ANCHE il numero di punti fatti e subiti dalle squadre con "anna"?
    =MATR.SOMMA.PRODOTTO(--(VAL.NUMERO(RICERCA(B6;B$14:B$25)))*(E$14:E$25))+MATR.SOMMA.PRODOTTO(--(VAL.NUMERO(RICERCA(B6;D$14:D$25)))*(G$14:G$25))

    EDIT quella sopra per punti fatti, questa per punti subiti
    =MATR.SOMMA.PRODOTTO(--(VAL.NUMERO(RICERCA(B6;B$14:B$25)))*(G$14:G$25))+MATR.SOMMA.PRODOTTO(--(VAL.NUMERO(RICERCA(B6;D$14:D$25)))*(E$14:E$25))

  18. #18

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    54
    Messaggi
    10153
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2598
    Likes dati
    1558

    Re: funzione [conta.se]: contare il valore di un testo in una cella con &amp;quot;concatena&amp;quot;

    Citazione Originariamente Scritto da delittogoloso Visualizza Messaggio
    @pitagora:
    partite giocate non funziona (anche senza alcun risultato mi da 3 per ogni giocatore!
    partite vinte funziona
    Le formule di Pitagora funzionano!
    Non vorrei che sei stato indotto in errore dal fatto che lui ha scritto: in C6 la prima formula e in C7 la seconda .. è evidente che la seconda va messa in un'altra colonna.

    ----------Post unito in automatico----------

    Citazione Originariamente Scritto da delittogoloso Visualizza Messaggio
    non hai capito...ehehe
    quest'ultima formula mi conta le vittorie.
    ma già la tua prima formula (modificando l'intervallo) lo faceva.
    quello che servirebbe è contare le partite giocate (sia vinte che perse).

    altro quesito:
    e se volessi avere ANCHE il numero di punti fatti e subiti dalle squadre con "anna"?
    Questa discussione sta diventando una barzelletta poichè le formule funzionano ma evidentemente non è chiaro quel che vorresti ottenere .... a questo punto meglio che alleghi un altro file excel con i risultati che vuoi ottenere evidenziati e scritti a mano
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  19. #19

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    58
    Messaggi
    1214
    Versione Office
    .
    Likes ricevuti
    457
    Likes dati
    0

    Re: funzione [conta.se]: contare il valore di un testo in una cella con &quot;concatena&quot;

    Dalle risposte "sbagliate" che abbiamo dato appare evidente che l'esempio postato è stato fuorviante; comunque, alla luce delle spiegazioni fornite io l'ho capita così:

    per le giocate (in C6 e poi copiate sotto):
    Codice: 
    =SOMMA(--(SE.ERRORE(TROVA(B6;$B$14:$D$25);0)>0)*($H$14:$H$25<>"da disputare"))
    matriciale da confermare con ctrl+maiusc+invio

    per le vinte (ad esempio in D6 e poi copiate sotto):
    Codice: 
    =SOMMA(--(SE.ERRORE(TROVA(B6;$H$14:$H$25);0)>0))
    sempre matriciale da confermare con ctrl+maiusc+invio
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  20. #20
    L'avatar di delittogoloso
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    poggio mirteto
    Età
    33
    Messaggi
    12
    Versione Office
    MS 2010 pc
    Likes ricevuti
    0
    Likes dati
    0

    Re: funzione [conta.se]: contare il valore di un testo in una cella con &quot;concatena&quot;

    evidentemente sono stupido io...guardate la pic dei risultati



  21. #21

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    58
    Messaggi
    1214
    Versione Office
    .
    Likes ricevuti
    457
    Likes dati
    0

    Re: funzione [conta.se]: contare il valore di un testo in una cella con &quot;concatena&quot;

    Citazione Originariamente Scritto da delittogoloso Visualizza Messaggio
    guardate la pic dei risultati
    come fai a dire che le partite giocate sono sbagliate??

    anna ha gioacato una partita, come B, come C e come D:

    B
    C
    5
    partite giocate
    6
    anna
    1
    7
    B
    1
    8
    C
    1
    9
    D
    1

    quindi la mia formula per le giocate è corretta, così come per le vinte
    partite vinte
    anna
    1
    B
    1
    C
    0
    D
    0
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  22. #22
    L'avatar di delittogoloso
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    poggio mirteto
    Età
    33
    Messaggi
    12
    Versione Office
    MS 2010 pc
    Likes ricevuti
    0
    Likes dati
    0

    Re: funzione [conta.se]: contare il valore di un testo in una cella con &quot;concatena&quot;

    ehm..infatti l'ho detto! sono stupido...scusatemi.
    in effetti per un MIO problema di idiozia (eheh) non associavo le altre partite...chiedo venia!

Discussioni Simili

  1. [Risolto] Testo interno di una "Shape" preso da una cella
    Di atievoli nel forum Domande su Excel VBA e MACRO
    Risposte: 2
    Ultimo Messaggio: 11/02/17, 09:51
  2. [Risolto] Ordinare con la funzione "piccolo"..ma "portandosi dietro" anche altri dati affiancati
    Di mauri73 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 05/02/17, 13:57
  3. Risposte: 4
    Ultimo Messaggio: 09/08/16, 23:58
  4. Funzione indice/confronta all'interno della Funzione "O" ed "E"
    Di Rosaria79 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 28/06/16, 19:57
  5. >Come estrappolare la somma "automatica" di un DB con funzione "FILTRO"<
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 11/06/16, 10:44

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •