Risultati da 1 a 12 di 12

Discussione: Esiste una funzione sostitutiva di PIU.SE?



  1. #1
    L'avatar di dandyrama
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    milano
    Messaggi
    6
    Versione Office
    2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Esiste una funzione sostitutiva di PIU.SE?

    Salve.
    Sono appena iscritto al forum. Saluto tutti i partecipanti e ringrazio in anticipo chi mi dedicherà del tempo per aiutarmi.

    Ho un foglio di calcolo in cui nella colonna B inserisco delle tipologie di spesa (consumabili, viaggi, rappresentanza, attrezzatura, etc)
    Alla colonna C vorrei inserire una formula che mi dia una percentuale a seconda della tipologia inserita nella colonna B.

    In pratica vorrei dire alla colonna C:
    - se nella colonna B c'è "attrezzatura", "viaggi" inserisci nella colonna C il valore 80%, se c'è "rappresentanza" inserisci nella colonna C il valore 50%, etc, etc

    Ho visto in rete che la funzione PIU.SE potrebbe fare al caso mio, però ho notato anche che è disponibile solo dalla versione excel 2016.
    io ho la versione 2011 per MAC.


    Esiste una formula sostitutiva che potrebbe aiutarmi? Una soluzione alternativa?
    Grazie mille
    Giuseppe

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Esiste una funzione sostitutiva di PIU.SE?

    Ciao DandyRama, benvenuto in forumexcel.it
    Come già anticipato da te la funzione PU.SE è disponibile dalla versione di excel 2016, però si può fare anche senza questa funzione mettendo tanti =SE() nidificati
    es. =SE(A1="rosso";1;SE(A1="Giallo";2;3) si possono mettere fino a 64 volte SE
    tuttavia per capire bene quello che vorresti, prova a mettere un piccolo file di excel. senza dati sensibili cosi da poterci lavorare sopra
    Un saluto

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di Alessandro
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Roma
    Età
    45
    Messaggi
    851
    Versione Office
    2010 64 bit
    Likes ricevuti
    113
    Likes dati
    61

    Re: Esiste una funzione sostitutiva di PIU.SE?

    come 64? non erano 7? però io sono rimasto al 2007
    Ultima modifica fatta da:Canapone; 14/07/17 alle 15:00

  5. #4
    L'avatar di dandyrama
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    milano
    Messaggi
    6
    Versione Office
    2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: Esiste una funzione sostitutiva di PIU.SE?

    Ciao Gerardo.
    Grazie mille della risposta e scusa per il ritardo con cui ti rispondo, ma ero convinto che mi arrivasse una mail per notificarmi la risposta.
    Ho provato con la tua formula e ci sono riuscito.
    Non ti rendi conto di quanto mi hai aiutato.
    Grazie mille ancora.
    Giuseppe
    Ultima modifica fatta da:Canapone; 14/07/17 alle 15:00

  6. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Esiste una funzione sostitutiva di PIU.SE?

    Ciao Giuseppe, mi fa piacere che hai risolto, tuttavia per quanto riguarda la mail dovresti averla ricevuta, altrimenti guarda nella posta indesiderata i nello spam, un saluto

  7. #6
    L'avatar di Raffaele_53
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Binasco
    Età
    64
    Messaggi
    506
    Versione Office
    2007
    Likes ricevuti
    85
    Likes dati
    7

    Re: Esiste una funzione sostitutiva di PIU.SE?

    >>>come 64? non erano 7? però io sono rimasto al 2007
    Anche 2007 n'è ha 64

    Ps. Non era meglio un cerca.vert

  8. #7
    L'avatar di dandyrama
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    milano
    Messaggi
    6
    Versione Office
    2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: Esiste una funzione sostitutiva di PIU.SE?

    si hai ragione, era nello spam, adesso ho messo l'indirizzo in white list.
    grazie ancora.
    Non so come faccio a chiudere la conversazione come "risolta", lo posso fare io ho un amministratore? Perchè per me è risolta :-)
    giuseppe
    Ultima modifica fatta da:Canapone; 14/07/17 alle 15:01

  9. #8
    L'avatar di dandyrama
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    milano
    Messaggi
    6
    Versione Office
    2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: Esiste una funzione sostitutiva di PIU.SE?

    Ciao Gerardo.
    Pensavo di aver risolto e invece no purtroppo.
    Inserisco i SE nidificati e mi riporta un errore quando inserisco + di 8 se.
    Allego, come da tue prime indicazioni due file.
    Sono uguali.
    Alla colonna F c'è una formula che dà un valore percentuale a seconda del contenuto della colonna A.
    (File in allegato "8VOLTE SE"): Se nella colonna F, nella formula, inserisco 8 volte SE non ho problemi.
    (File in allegato "9VOLTE SE"): Se nella colonna F, nella formula, inserisco 9 volte SE, all'inizio non mi dà problemi poi quando salvo il file e lo riapro, mi dà nelle colonne i valori esatti, ma al posto della formula mi dà #VALORE!".

    non so più come fare.
    Grazie mille.
    giuseppe
    File Allegati File Allegati

  10. #9

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299

    Re: Esiste una funzione sostitutiva di PIU.SE?

    Ciao,
    non vedo nessuna formula nella colonna F del file "9VOLTE SE", mentre nell'altro file in F c'è questa formula con 8 SE:

    =SE(A2="ASSICURAZIONI AUTO MOTO";80%;SE(A2="AUTO DILAZIONI";80%;SE(A2="AUTO PARCHEGGI AREA C";80%;SE(A2="AUTO BENZINA";80%;SE(A2="AUTO TELEPASS";80%;SE(A2="UTENZE CELLULARI";20%;SE(A2="UTENZE TELEFONO";20%;SE(A2="VIAGGI";25%;0%))))))))

    Che si potrebbero ridurre a 4 così:

    =SE(O(A2="ASSICURAZIONI AUTO MOTO";A2="AUTO DILAZIONI";A2="AUTO PARCHEGGI AREA C";A2="AUTO BENZINA";A2="AUTO TELEPASS");80%;SE(A2="UTENZE CELLULARI";20%;SE(A2="UTENZE TELEFONO";20%;SE(A2="VIAGGI";25%;0%))))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  11. #10
    L'avatar di dandyrama
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    milano
    Messaggi
    6
    Versione Office
    2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: Esiste una funzione sostitutiva di PIU.SE?

    Ciao.
    Grazie mille.
    Adesso mi funziona. Anche quando lo chiudo e lo riapro mi mantiene la formula. non so come mai, se era un problema di numero di SE, non mi dava il messaggio di errore subito. Invece dovevo chiuderlo e poi alla riapertura mi segnalava l'errore con "#VALORE!

    Io ho risolto aggiungendo altri due SE alla tua formula.

    Mi chiedevo, se voglio raggrupparli tutti come fai tu,
    in pratica ho tre valori (25%, 20%, 80%) ognuno voglio associarlo a più di 2 voci...ho ripreso la tua formula e l'ho modificata, e naturalmente non funziona.
    Per curiosità, potrei sapere dove sbaglio?
    =SE(O(C2="ASSICURAZIONI AUTO MOTO";C2="AUTO DILAZIONI";C2="AUTO PARCHEGGI AREA C";C2="AUTO BENZINA";C2="AUTO TELEPASS");80%;SE(C2="UTENZE CELLULARI";20%;SE(C2="UTENZE TELEFONO";20%;SE(C2="RISTORANTI ";25%;SE(C2="VIAGGI";25%;0%))))


    grazie mille ancora
    Giuseppe

  12. #11

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299

    Re: Esiste una funzione sostitutiva di PIU.SE?

    In rosso la parte da eliminare, in blu quella da aggiungere

    Citazione Originariamente Scritto da dandyrama Visualizza Messaggio
    ..

    in pratica ho tre valori (25%, 20%, 80%) ognuno voglio associarlo a più di 2 voci...ho ripreso la tua formula e l'ho modificata, e naturalmente non funziona.
    Per curiosità, potrei sapere dove sbaglio?

    =SE(O(C2="ASSICURAZIONI AUTO MOTO";C2="AUTO DILAZIONI";C2="AUTO PARCHEGGI AREA C";C2="AUTO BENZINA";C2="AUTO TELEPASS");80%;SE(O(C2="UTENZE CELLULARI";20%;SE(C2="UTENZE TELEFONO");20%;SE(O(C2="RISTORANTI ";25%;SE(C2="VIAGGI");25%;0%))))

    ..

    La formula esatta, in base alla tue indicazioni, è così:

    =SE(O(C2="ASSICURAZIONI AUTO MOTO";C2="AUTO DILAZIONI";C2="AUTO PARCHEGGI AREA C";C2="AUTO BENZINA";C2="AUTO TELEPASS");80%;SE(O(C2="UTENZE CELLULARI";C2="UTENZE TELEFONO");20%;SE(O(C2="RISTORANTI ";C2="VIAGGI");25%;0%)))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  13. #12
    L'avatar di dandyrama
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    milano
    Messaggi
    6
    Versione Office
    2011 MAC
    Likes ricevuti
    0
    Likes dati
    1

    Re: Esiste una funzione sostitutiva di PIU.SE?

    Grazie mille ancora.
    ciao
    Giuseppe

Discussioni Simili

  1. [Risolto] esiste una funzione/espressione che restituisce ERRORE per 2 celle diverse?
    Di nemoclipru nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 05/03/17, 20:17
  2. Esiste un manuale Excel VBA per MAC?
    Di BrtPla nel forum Foglio di calcolo su altre Piattaforme
    Risposte: 5
    Ultimo Messaggio: 05/01/17, 15:33
  3. Completamento automatico: esiste in Excel?
    Di nanuccio nel forum Domande su Excel in generale
    Risposte: 25
    Ultimo Messaggio: 27/02/16, 20:17
  4. Esiste un modo per velocizzare un countif
    Di lalla nel forum Domande su Excel VBA e MACRO
    Risposte: 0
    Ultimo Messaggio: 19/11/15, 22:20
  5. Valore Max (Esiste funzione Se matriciale?)
    Di mrk14 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 12/08/15, 14:06

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •