Risultati da 1 a 8 di 8

Discussione: Come estrarre le centinaia da un numero



  1. #1
    L'avatar di angelimaleducati
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    foggia
    Età
    37
    Messaggi
    2
    Versione Office
    excel 2003
    Likes ricevuti
    0
    Likes dati
    0

    Come estrarre le centinaia da un numero

    Buonasera, avrei bisogno di una formula avendo un numero nella cella A1 esempio 134 , nella cella B1 deve essere 100 e 34 nella cella C1 , se il numero della cella A1 è inferiore a 100 nella cella B1 deve essere lo stesso numero è nella cella C1 0 .Se nella cella A1 il numero è superiore a 200 nella cella B1 deve essere 100 nella cella C1 100 e nella D1 la differenza. Faccio alcuni esempi.
    A1 23 B1 23 C1 0
    A1 145 B1 100 C1 45
    A1 236 B1 100 C1 100 D1 36

    Quindi mi servirebbe la formula per le celle b c d.

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7124
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1298

    Re: aiuto per formula

    Ciao,
    allega un file excel come esempio.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di angelimaleducati
    Clicca e Apri
    Data Registrazione
    Jul 2016
    Località
    foggia
    Età
    37
    Messaggi
    2
    Versione Office
    excel 2003
    Likes ricevuti
    0
    Likes dati
    0

    Re: aiuto per formula

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao,
    allega un file excel come esempio.
    Allego esempio
    File Allegati File Allegati

  4. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1656
    Versione Office
    2010 PC
    Likes ricevuti
    891
    Likes dati
    184

    Cool Re: aiuto per formula

    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao,
    allega un file excel come esempio.
    Oppure usa la funzione resto da contrapporre con un boleano oppure un se(), con un rif.riga() per i multipli di 100
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  5. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7124
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1298

    Re: aiuto per formula

    Ciao,
    non so se ho ben capito:

    in B1 da trascinare in basso:

    =SE(A1<>"";SE(A1<100;A1;SE(E(A1>=100;A1<=200);100;SE(A1>200;100)));"")

    in C1 da trascinare in basso:

    =SE(A1<>"";SE(A1<100;0;SE(E(A1>=100;A1<=200);34;SE(A1>200;100)));"")

    in D1 non mi sembra ben definito, potrebbe essere così:

    =SE(A1<>"";SE(A1<100;0;SE(E(A1>=100;A1<=200);0;SE(A1>200;A1-B1)));"")

    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. I seguenti utenti hanno dato un "Like"


  7. #6
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: aiuto per formula

    Ciao Angelimaleducati, e un caro saluto all'amico Ges, prendendo spunto dalle tue formule propongo le seguenti:

    In F1:
    =SE(A1<>"";SE(A1<=100;A1;SE(A1>100;100;0));"")

    In G1:
    =SE(A1<>"";SE(E(A1>100;A1<=200);A1-B1;SE(A1>200;100;0));"")

    In H1:
    =SE(A1<>"";SE(A1>200;A1-(B1+C1);0);"")
    tutte e tre le formule da tirare giù alla bisogna.
    Allego il file di prova, ciao.
    File Allegati File Allegati

  8. I seguenti utenti hanno dato un "Like"

    ges

  9. #7
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1656
    Versione Office
    2010 PC
    Likes ricevuti
    891
    Likes dati
    184

    Re: aiuto per formula

    ciao
    un'alternativa, in unica formula, in B1:
    =MEDIANA(0;100;$A1-100*(COLONNE($B1:B1)-1))

    e trascini a destra e copi in basso

    ----------Post unito in automatico----------

    se invece degli zeri si vuole cella vuota:
    =SE($A1>100*(COLONNE($B1:B1)-1);MIN(100;$A1-100*(COLONNE($B1:B1)-1));"")
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  10. I seguenti 3 utenti hanno dato un "Like" a ninai per questo post:


  11. #8
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202

    Re: aiuto per formula

    Ciao a tutti,

    molto simile alla formula di Ninai e fuori tempo massimo...

    =MAX(0;MIN(100;$A1-100*RIF.COLONNA(A$1)+100))

    da trascinare a destra


    Se si dovesse lavorare anche con numeri negativi

    =MAX(0;MIN(100;ASS($A1)-100*RIF.COLONNA(A$1)+100))*SEGNO($A1)


    Saluti

  12. I seguenti 3 utenti hanno dato un "Like" a Canapone per questo post:


Discussioni Simili

  1. [Risolto] funzione per estrarre un numero da una stringa partendo da un carattere speciale trovato
    Di nemoclipru nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 07/03/17, 05:58
  2. [Risolto] estrarre un numero di caratteri da una stringa di testo.
    Di Samuela nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 25/01/17, 10:15
  3. Estrarre numero a destra da testo
    Di Samuela nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 21/01/17, 11:20
  4. [Risolto] dovrei estrarre un numero ma non ci riesco
    Di Eddie18 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 22/10/16, 11:00
  5. Risposte: 5
    Ultimo Messaggio: 14/07/16, 13:46

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •