Risultati da 1 a 7 di 7

Discussione: Creare delle sequenze orarie



  1. #1
    L'avatar di Keishusan
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Rimini
    Messaggi
    35
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0

    Creare delle sequenze orarie

    Ciao a tutti,
    non so come impostare questo tipo di lavoro, ho dei dati di partenza che corrispondono ad un nome e a delle fasce orarie, dovrei ottenere una sorta di grafico per l'orario corrispondente.

    In allegato l'esempio per capire.

    Grazie mille
    Alessandro
    File Allegati File Allegati

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7164
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1304

    Re: Creare delle sequenze orarie

    Ciao,
    se ho capito bene.

    In G5 da trascinare a destra:

    =SE.ERRORE(INDICE($E$4:$E$6;CONFRONTA(SE(E(G13>=$C$4;G13<=$D$6);G13);$C$4:$C$6));"")

    In G17 da trascinare a destra:

    =SE.ERRORE(INDICE($E$8:$E$9;CONFRONTA(SE(E(G13>=$C$8;G13<=$D$9);G13);$C$8:$C$9));"")


    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. I seguenti 2 utenti hanno dato un "Like" a ges per questo post:


  4. #3

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1229
    Likes dati
    923

    Re: Creare delle sequenze orarie

    Ciao a tutti,

    io stavo provando a fare una formula "universale" (per il file allegato naturalmente).... devo dire che mi sono incartato un paio di volte

    Comunque rimane qualche dubbio su quando inizia e quando finisce un turno.
    Esempio....
    Turno A = 10:00 - 12:30
    Turno B = 12:30 - 14:00

    nella cella delle 12:30, ci va il turno A o il turno B? In teoria entrambi.....

    Comunque, nella cella G15 puoi usare questa formula matriciale (da copiare poi in basso e a destra):

    =SE.ERRORE(INDIRETTO("E"&MAX(SE.ERRORE((1/(RIF.RIGA($B$4:$B$9)>=CONFRONTA($E15;$B$4:$B$9;0)+3))*(1/(RIF.RIGA($B$4:$B$9)<=SE.ERRORE(CONFRONTA("*";INDIRETTO("B"&CONFRONTA($E15;$B$4:$B$9;0)+4&":B9");0)-2+CONFRONTA($E15;$B$4:$B$9;0)+3;9)))*(1/(G$13>=$C$4:$C$9))*(1/(G$13<=$D$4:$D$9))*RIF.RIGA($B$4:$B$9);"")));"")
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  5. I seguenti 2 utenti hanno dato un "Like" a cromagno per questo post:


  6. #4
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133

    Re: Creare delle sequenze orarie

    Ciao a tutti, anche io come Cromagno, che saluto, "ottima formula, non posso darti il riscontro perché mi è sparito il mi piace", stavo pensando ad una formula unica, e visto che mi sono scervellato non poco in questa torrida serata Reggina, posto anche la mia probabile soluzione:

    In G15:
    =SE.ERRORE(SE(E($G$13:$AA$13>=INDIRETTO("$C$"&CONFRONTA($E15;$B$4:$B$9;0)+3);$G$13:$AA$13<=INDIRETTO("$D$"&CONFRONTA($E15;$B$4:$B$9;0)+3));INDIRETTO("$E$"&CONFRONTA($E15;$B$4:$B$9;0)+3);SE(E($G$13:$AA$13>=INDIRETTO("$C$"&CONFRONTA($E15;$B$4:$B$9;0)+4);$G$13:$AA$13<=INDIRETTO("$D$"&CONFRONTA($E15;$B$4:$B$9;0)+4));INDIRETTO("$E$"&CONFRONTA($E15;$B$4:$B$9;0)+4);SE(E($G$13:$AA$13>=INDIRETTO("$C$"&CONFRONTA($E15;$B$4:$B$9;0)+5);$G$13:$AA$13<=INDIRETTO("$D$"&CONFRONTA($E15;$B$4:$B$9;0)+5));INDIRETTO("$E$"&CONFRONTA($E15;$B$4:$B$9;0)+5);"")));"")
    da tirare verso destra e successivamente giù, sempre alla bisogna.
    Allego il file di prova.
    Di nuovo ciao a tutti.
    File Allegati File Allegati
    Ultima modifica fatta da:pkrome59; 10/07/16 alle 00:40

  7. I seguenti utenti hanno dato un "Like"


  8. #5
    L'avatar di Keishusan
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Rimini
    Messaggi
    35
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Creare delle sequenze orarie

    Grazie a tutti, ottime formule. Ges la tua era la più leggera ma non funziona se c'è solo una sequenza.
    L'unico problema (ma errore mio che non mi sono spiegato) è che l'orario inizia alla destra del numero, per quello ho messo le ore scritte in verticale.

    Alessandro

  9. #6

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1229
    Likes dati
    923

    Re: Creare delle sequenze orarie

    Citazione Originariamente Scritto da Keishusan Visualizza Messaggio
    L'unico problema (ma errore mio che non mi sono spiegato) è che l'orario inizia alla destra del numero, per quello ho messo le ore scritte in verticale.
    Cioè?

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  10. #7
    L'avatar di Keishusan
    Clicca e Apri
    Data Registrazione
    Jun 2016
    Località
    Rimini
    Messaggi
    35
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0

    Re: Creare delle sequenze orarie

    Citazione Originariamente Scritto da cromagno Visualizza Messaggio
    Cioè?
    Immaginando l'orario che scorre, lo scoccare delle "10:00" (per esempio) è tra la casella delle "10:00" e quella delle "10:30", invece negli esempi sembra che l'orario parta all'interno della casella delle 10:00.
    Nel mio primo esempio si vede infatti che la Persona_1 inizia a lavorare alle 10:00 ma la casella che si va a riempire è quella sotto le 10:30.

    ----------Post unito in automatico----------

    Ad ogni modo ho risolto, grazie mille, gli aiuti sono stati preziosi ;-)

Discussioni Simili

  1. calcolo ore straordinario su fasce orarie notturne e diurne
    Di paraca nel forum Domande su Excel in generale
    Risposte: 25
    Ultimo Messaggio: 10/03/17, 17:18
  2. Sostituzione variabile nelle sequenze macro
    Di Ðenver nel forum Domande su Excel VBA e MACRO
    Risposte: 7
    Ultimo Messaggio: 15/09/16, 20:50
  3. [Risolto] Sequenze numeriche
    Di Khan nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 19/04/16, 09:35
  4. Creare tabella avendo delle condizioni logiche
    Di carega83 nel forum Domande su Excel in generale
    Risposte: 19
    Ultimo Messaggio: 08/04/16, 14:03
  5. Conteggio ore in più fasce orarie
    Di Paolo71 nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 10/03/16, 13:03

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •