Risultati da 1 a 3 di 3

Discussione: Confusione con operatori logici E ed O



  1. #1
    L'avatar di Khan
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Padova
    Messaggi
    55
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    1

    Confusione con operatori logici E ed O

    Questa formula senz’altro funziona: =SE(E(O([@OPERAZIONE]="ENEL";[@OPERAZIONE]="GAS");OGGI()>=[@DATA]);"S";"N")
    Anche questa:
    =SE(A2="";"";SE(OGGI()>=A2;"S";"N"))

    In questo torrido caldo ho fatto diverseprove per avere una unica formula ma mi sono arreso.
    Suggerimenti?

    Allego file modificato per maggiore chiarezza.

    http://www.filedropper.com/stipendi
    The saddest aspect of life right now is that science gathers knowledge faster than society gathers wisdom. - Isaac Asimov

    Windows 10 + Excel 2013

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1672
    Versione Office
    2010 PC
    Likes ricevuti
    894
    Likes dati
    184
    Ciao
    Non sono per niente sicuro di aver capito quali sono le condizioni per la "S" o la "N" (soprattutto per la data), ma dovrebbe essere qualcosa del genere:
    =SE(A2="";"";SE((A2<OGGI())*((B2="enel")+(B2="gas"));"S";"N"))

  3. #3
    L'avatar di Khan
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Padova
    Messaggi
    55
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    1
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    Ciao
    Non sono per niente sicuro di aver capito quali sono le condizioni per la "S" o la "N" (soprattutto per la data), ma dovrebbe essere qualcosa del genere:
    =SE(A2="";"";SE((A2<OGGI())*((B2="enel")+(B2="gas"));"S";"N"))
    Correggendo in questo modo funziona tutto.

    SE(A2="";"";SE((A2>=OGGI())*((B2="ENEL")+(B2="GAS"));"N";"S"))

    Grazie ninai per l'aiuto
    The saddest aspect of life right now is that science gathers knowledge faster than society gathers wisdom. - Isaac Asimov

    Windows 10 + Excel 2013

Discussioni Simili

  1. [Risolto] estrarre dati con filtri dinamici e operatori logici dinamici
    Di demmas nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 20/02/17, 07:09

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •